在线检测未来函数

通达信威力巨大的主图指标公式

来源:Internet,编辑:股旁网,2020-03-03

N:=25;
M1:=3;
M2:=3;
M3:=6;
M4:=6;
M5:=9;
M6:=9;
NN:=11;
M:=6;
UPPER4:=(1+M5/100)*MA(CLOSE,N);
LOWER4:=(1-M6/100)*MA(CLOSE,N);
UPPER5:=(1+M1/100)*MA(CLOSE,N);
LOWER5:=(1-M2/100)*MA(CLOSE,N);
ENE2:=(UPPER5+LOWER5)/2;
{STICKLINE(CLOSE>LOWER5,LOWER5,UPPER4,1,-1),COLORRED;
STICKLINE(CLOSE<LOWER5,LOWER5,LOWER4,1,-1),COLORGREEN;}
DRAWBAND(CLOSE,RGB(85,0,0),LOWER5,RGB(0,85,0));
UPPER:=(1+M1/100)*MA(CLOSE,N);
LOWER:(1-M2/100)*MA(CLOSE,N),COLORYELLOW;
UPPER2:=(1+M3/100)*MA(CLOSE,N),COLORWHITE;
LOWER2:=(1-M4/100)*MA(CLOSE,N),COLORWHITE;
UPPER3:=(1+M5/100)*MA(CLOSE,N),COLORWHITE;
LOWER3:=(1-M6/100)*MA(CLOSE,N),COLORWHITE;
ENE:=(UPPER+LOWER)/2;
MA5:MA(C,5),COLORWHITE;
MA20:MA(C,20),COLORWHITE,LINETHICK4;
角度5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416,NODRAW;
IF(角度5>0,MA5,DRAWNULL),LINETHICK2,COLORRED;
角度20:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416,NODRAW;
IF(角度20>0,MA20,DRAWNULL),LINETHICK4,COLORRED;
X1A:=30;
X1B:HHV(C,X1A),COLORMAGENTA,LINETHICK3;
X1C:=IF(ISLASTBAR,BARSLAST(C=CONST(X1B))+1,1/0);
X1D:=IF(X1C=1,' 1',IF(X1C=2,' 2',IF(X1C=3,' 3',IF(X1C=4,' 4',IF(X1C=5,' 5',
IF(X1C=6,' 6',IF(X1C=7,' 7',IF(X1C=8,' 8',IF(X1C=9,' 9',IF(X1C=10,' 10',
IF(X1C=11,' 11',IF(X1C=12,' 12',IF(X1C=13,' 13',IF(X1C=14,' 14',IF(X1C=15,' 15',
IF(X1C=16,' 16',IF(X1C=17,' 17',IF(X1C=18,' 18',IF(X1C=19,' 19',IF(X1C=20,' 20',
IF(X1C=21,' 21',IF(X1C=22,' 22',IF(X1C=23,' 23',IF(X1C=24,' 24',IF(X1C=25,' 25',
IF(X1C=26,' 26',IF(X1C=27,' 27',IF(X1C=28,' 28',IF(X1C=29,' 29',IF(X1C=30,' 30',' 0'))))))))))))))))))))))))))))));
X1E:DRAWTEXT(ISLASTBAR,X1B,X1D),COLORFF5500;
X2A:=30;
X2B:LLV(C,X2A),COLORMAGENTA,LINETHICK3;
X2C:=IF(ISLASTBAR,BARSLAST(C=CONST(X2B))+1,1/0);
X2D:=IF(X2C=1,' 1',IF(X2C=2,' 2',IF(X2C=3,' 3',IF(X2C=4,' 4',IF(X2C=5,' 5',
IF(X2C=6,' 6',IF(X2C=7,' 7',IF(X2C=8,' 8',IF(X2C=9,' 9',IF(X2C=10,' 10',
IF(X2C=11,' 11',IF(X2C=12,' 12',IF(X2C=13,' 13',IF(X2C=14,' 14',IF(X2C=15,' 15',
IF(X2C=16,' 16',IF(X2C=17,' 17',IF(X2C=18,' 18',IF(X2C=19,' 19',IF(X2C=20,' 20',
IF(X2C=21,' 21',IF(X2C=22,' 22',IF(X2C=23,' 23',IF(X2C=24,' 24',IF(X2C=25,' 25',
IF(X2C=26,' 26',IF(X2C=27,' 27',IF(X2C=28,' 28',IF(X2C=29,' 29',IF(X2C=30,' 30',' 0'))))))))))))))))))))))))))))));
X2E:DRAWTEXT(ISLASTBAR,X2B,X2D),COLORFF00FF;
CV:=CLOSE;
BBIBOLL:=(MA(CV,3)+MA(CV,6)+MA(CV,12)+MA(CV,24))/4;
UPR:BBIBOLL+M*STD(BBIBOLL,NN),COLORWHITE,DOTLINE,LINETHICK1;
DWN:BBIBOLL-M*STD(BBIBOLL,NN),COLORWHITE,DOTLINE,LINETHICK1;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
STICKLINE(MA5<BBIBOLL AND C<MA5,H,L,0,0),COLORGRAY;
STICKLINE(MA5<BBIBOLL AND C<MA5,O,C,3,1),COLORGRAY;

通达信威力巨大的主图指标公式

 

通达信威力巨大的主图指标公式的选股公式

相关文章