载入中...
在线检测未来函数
载入中...

通达信623四线主图指标公式

来源:Internet,编辑:股旁网,2020-03-13

MA5:MA(CLOSE,5),COLORWHITE,LINETHICK2;
MA7:MA(CLOSE,7),COLORYELLOW,LINETHICK2;
MA10:MA(CLOSE,10),COLORMAGENTA,LINETHICK3;
HIGHN:=10;
AA:=REF(C,HIGHN)=HHV(C,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND C=HHV(C,HIGHN+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(C,DDD),C);
DINGBU1:=REF(DINGBU,DDD+1);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+10);
LOWN:=10;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
DD1:=BARSLAST(CC1);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
ZZ:=5;
AC:=REF(C,ZZ)=HHV(C,2*ZZ+1);
AD:=BACKSET(AC,ZZ+1);
AE:=FILTER(AD,ZZ) AND C=HHV(C,ZZ+1);
AF:=BARSLAST(AE);
AG:=IF(AE,CURRBARSCOUNT,0);
AH:=IF(AF,REF(C,AF),C);
AI:=IF(AF,REF(AG,AF),AG);
AL:=CONST(AI);
短T:DRAWLINE(CURRBARSCOUNT=AL,C,ISLASTBAR,REF(C,AL-1),1),DOTLINE,COLORYELLOW LINETHICK3;
T线:DRAWLINE(CURRBARSCOUNT=GDCS1,C,ISLASTBAR,REF(C,GDCS1-1),1),DOTLINE,COLORGREEN;
ZT:= CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND CLOSE=HIGH;
冲击涨停:=HIGH>=ZTPRICE(REF(CLOSE,1),0.1) AND CLOSE < HIGH AND CLOSE > OPEN AND (PERIOD=5);
开盘%:(OPEN - REF(CLOSE,1))/REF(CLOSE,1)*100,NODRAW,COLORLIMAGENTA;
KBTB:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1)) AND OPEN = CLOSE;
KB_CNT:=COUNT(KBTB,135);
DRAWTEXT(ZT AND 开盘%>5 AND (PERIOD=5),HIGH*0.96,'★'),COLOR00D7FF;
STICKLINE(ZT AND NOT(KBTB) AND (PERIOD=5),CLOSE*0.9985,OPEN*1.0015,1.286,0),COLOR00D7FF;
STICKLINE(冲击涨停 AND (PERIOD=5),CLOSE*0.9985,OPEN+(C-O)*0.4,1.286,0),COLOR00D7FF;
{布中:EMA(CLOSE,20) COLORYELLOW LINETHICK2;}
BOLL轨:=EMA(CLOSE,20) COLORBLUE LINETHICK1 DOTLINE;
BOLL翘:=IF(BOLL轨>REF(BOLL轨,1),BOLL轨,DRAWNULL),COLORRED,LINETHICK1 POINTDOT{ DOTLINE};
UB:BOLL+2*STD(CLOSE,20)COLORRED LINETHICK2 DOTLINE;
LB:=BOLL-2*STD(CLOSE,20)COLORRED LINETHICK1 DOTLINE;
SS1:=C>O AND C/O<1.02 ;
SS2:=C>MA(C,13) AND C/MA(C,13)<1.03;
SS3:=MA(C,13)>REF(MA(C,13),2);
Z1:=STRCAT(DYBLOCK,' ');
Z2:=STRCAT(Z1,HYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0.4,0,0,STRCAT(Z3,GNBLOCK)),COLORYELLOW;

通达信623四线主图指标公式

 

通达信623四线主图指标公式的选股公式如下:

相关文章