载入中...
在线检测未来函数
载入中...

通达信单手擒妖主图指标公式

来源:Internet,编辑:股旁网,2020-03-18

顶点:=IF(CURRBARSCOUNT>7 AND REFX(H,1)<H AND REFX(H,2)<H AND REFX(H,3)<H AND REFX(H,4)<H AND REFX(H,5)<H AND REFX(H,6)<H AND REFX(H,7)<H &&
H>REF(H,1) AND H>REF(H,2) AND H>REF(H,3) AND H>REF(H,4) AND H>REF(H,5) AND H>REF(H,6) AND H>REF(H,7),H,0),NODRAW;
上次顶点:=BARSLAST(顶点>0),NODRAW;
DRAWTEXT(顶点>0,H,'顶'),COLORMAGENTA;
DRAWNUMBER(顶点>0,H*1.05,H),COLORMAGENTA;
底点:=IF(CURRBARSCOUNT>7 AND REFX(L,1)>L AND REFX(L,2)>L AND REFX(L,3)>L AND REFX(L,4)>L AND REFX(L,5)>L AND REFX(L,6)>L AND REFX(L,7)>L &&
L<REF(L,1) AND L<REF(L,2) AND L<REF(L,3) AND L<REF(L,4) AND L<REF(L,5) AND L<REF(L,6) AND L<REF(L,7),L,0),NODRAW;
上次底点:=BARSLAST(底点>0),NODRAW;
DRAWTEXT(底点>0,L,'底' ), COLORYELLOW;
条件:=顶点>0;
顶点1位置:=BARSLAST(条件),COLORYELLOW,NODRAW; {上一次即倒数第一次条件距今位置}
顶点2位置:=REF(BARSLAST(条件),顶点1位置+1)+顶点1位置+1,COLORRED,NODRAW;{倒数第二次条件距今位置}
顶点3位置:=REF(BARSLAST(条件),顶点2位置+1)+顶点2位置+1,COLORGREEN,NODRAW;{倒数第三次条件距今位置}
顶点4位置:=REF(BARSLAST(条件),顶点3位置+1)+顶点3位置+1,COLORBLUE,NODRAW;{倒数第四次条件距今位置}
顶点1价:CONST(REF(H,顶点1位置)),DOTLINE,COLORYELLOW,LINETHICK1;{顶点1最高价}
顶点2价:CONST(REF(H,顶点2位置)),DOTLINE,COLORRED,LINETHICK1;{顶点1最高价}
顶点3价:CONST(REF(H,顶点3位置)),DOTLINE,COLORGREEN,LINETHICK1;{顶点1最高价}
顶点4价:CONST(REF(H,顶点4位置)),DOTLINE,COLORBLUE,LINETHICK1;{顶点1最高价};
破1位:BARSSINCEN(C>顶点1价,顶点1位置-1),NODRAW;
破2位:BARSSINCEN(C>顶点2价,顶点2位置-1),NODRAW;
破3位:BARSSINCEN(C>顶点3价,顶点3位置-1),NODRAW;
破4位:BARSSINCEN(C>顶点4价,顶点4位置-1),NODRAW;
STICKLINE(破1位=0 AND C>O,C,O,2,0),COLORYELLOW;
STICKLINE(破2位=0 AND C>O,C,O,2,0),COLORYELLOW;
STICKLINE(破3位=0 AND C>O,C,O,2,0),COLORYELLOW;
STICKLINE(破4位=0 AND C>O,C,O,2,0),COLORYELLOW;
STICKLINE(破1位=0 AND C<=O,C*0.99,C*0.95,2,0),COLORYELLOW;
STICKLINE(破2位=0 AND C<=O,C*0.99,C*0.95,2,0),COLORYELLOW;
STICKLINE(破3位=0 AND C<=O,C*0.99,C*0.95,2,0),COLORYELLOW;
STICKLINE(破4位=0 AND C<=O,C*0.99,C*0.95,2,0),COLORYELLOW;
生命线:MA(C,30),COLORYELLOW,LINETHICK2;

通达信单手擒妖主图指标公式

 

通达信单手擒妖主图指标公式的选股公式如下:

相关文章