在线检测未来函数

通达信抢钱宝主图指标公式

来源:Internet,编辑:股旁网,2020-07-23

本文指标含有选股公式如下:

http://www.gupang.com/202007/52326.html

YS1:=(HIGH+LOW+CLOSE*2)/4;

RK3:=EMA(YS1,10);
RK4:=STD(YS1,10);
RK5:=(YS1-RK3)*100/RK4;
RK6:=EMA(RK5,5);
RK7:=EMA(RK6,10);
涨:=EMA(RK6,10)+100/2-5,COLORRED;
H_2:=O<MA(C,60) AND C>MA(C,60) AND C>O AND O-L<0.02 AND REF(C,1)/REF(C,2)<1.099 AND REF(C,2)/REF(C,3)<1.099 ;
H_3:=SUM(CROSS(MA(C,250),MA(C,90)) AND MA(C,90)<REF(MA(C,90),1),3) <1;
H_4:=SUM(CROSS(MA(C,90),MA(C,20)) AND MA(C,20)<REF(MA(C,20),1),3) <1;
H_5:=SUM(CROSS(MA(C,120),MA(C,20)),5) <1;
H_6:=NOT(LAST(C<=O,5,1));
H_7:=SUM((REF(C,1)/REF(C,2)<=0.91),5) <1;
H_8:=SUM((REF(C>O,1) AND O>REF(H,1) AND C<O),5) <1;{倒挂}
H_9:=SUM(DOWNNDAY(C,4),5) <1;
H_10:=SUM((SUM(C<O,4)=4),5) <1;
H_11:=ABS(C-O)>ABS(H-C);
H_12:=SUM((C/REF(C,1)>1.099),10) <2;
H_13:=SUM(CROSS(MA(C,250),MA(C,120) AND C<MA(C,120) AND C<MA(C,250) ),60) <1;
H_14:=SUM(REF(MA(C,60),2)<REF(MA(C,30),2) AND MA(C,60)>MA(C,30) AND C<MA(C,30) AND MA(C,30)<REF(MA(C,30),1) ,3)<1;
H_15:=SUM((SUM(C<O AND C<REF(C,1) AND O<REF(C,1),5)=4),15) <1 ;
H_16:=C>REF(C,1);
H_17:=MA(C,10)>REF(MA(C,10),1);
H_18:=NOT(REF(MA(C,250),1)>MA(C,250) AND REF(MA(C,250),1)-MA(C,250)>0.01 AND REF(MA(C,120),1)>MA(C,120) AND REF(MA(C,120),1)-MA(C,120)>0);
H_19:=NOT(MA(C,60) <MA(C,120) AND MA(C,60)<MA(C,250) AND MA(C,60)<REF(MA(C,60),1) AND REF(MA(C,120),1)-MA(C,120)>0.002 AND REF(MA(C,250),1)-MA(C,250)>0.0096);{北希REF(MA(C,250),1)-MA(C,250)>0.002}
H_20:=NOT(MA(C,60) <MA(C,120) AND MA(C,60)<MA(C,250) AND MA(C,120)>MA(C,250) AND MA(C,60)<REF(MA(C,60),1) AND REF(MA(C,120),1)>MA(C,120) AND REF(MA(C,250),1)<=MA(C,250)){天原;新安};
H_21:=SUM(((HHV(H,15)-LLV(L,15))/LLV(L,15)>0.8),90) <1;
H_22:=NOT(MA(C,60) <MA(C,120) AND MA(C,60)<MA(C,250) AND MA(C,60)<REF(MA(C,60),1) AND MA(C,250)<=REF(MA(C,250),1) AND REF(MA(C,120),1)-MA(C,120)>0.01);
H_23:=REF(MA(C,20),1)-MA(C,20)<0.01;
H_24:=NOT(MA(C,60) <MA(C,120) AND MA(C,60)<MA(C,250) AND MA(C,250)<MA(C,120) AND MA(C,250)<=REF(MA(C,250),1) AND REF(MA(C,60),1)-MA(C,60)>0.03);
H_25:=REF(MA(C,30),1)-MA(C,30)<0.016;
H_26:=NOT(MA(C,20)<REF(MA(C,20),1) AND MA(C,30)<REF(MA(C,30),1) AND MA(C,120)<REF(MA(C,120),1) AND MA(C,250)<REF(MA(C,250),1) AND MA(C,20)<MA(C,30) AND MA(C,20)<MA(C,120) AND MA(C,20)<MA(C,250) AND MA(C,30)<MA(C,120) AND MA(C,30)<MA(C,250) AND MA(C,120)<MA(C,250)) ;
H_27:=SUM(REF(C>O,1) AND O/REF(C,1)>1.02 AND O>REF(H,1) AND C<O AND REF(C,1)>REF(O,1),8) <1;{倒挂2}
H_28:= H_27 AND H_26 AND H_25 AND H_24 AND H_23 AND H_22 AND H_21 AND H_20 AND H_19 AND H_6 AND H_7 AND H_8 AND H_9 AND H_10 AND H_11 AND H_12 AND H_13 AND H_4 AND H_14 AND H_15 AND H_16 AND H_17 AND H_18 ;
H_29:= H_2;
H_30:=IF(NAMELIKE('*ST'),0,1) AND (BARSCOUNT(C)+1)>30 AND DYNAINFO(10)>100;
H_31:=H_29 AND H_28 AND 涨>REF(涨,1) AND MA(C,10)>REF(MA(C,10),1) ;
抢钱宝:=H_31 AND SUM(H_31,10)<2 AND H_30 ;
STICKLINE(抢钱宝,O,O-0.01,0,0),COLOR0000FF;
DRAWICON(抢钱宝,O-0.01,26);
DRAWTEXT(抢钱宝 ,O-0.01,'↖抢钱'),COLOR00FFFF;
M3:MA(CLOSE,3),COLORRED,LINETHICK;
M13:MA(CLOSE,13),COLORRED,LINETHICK;
M34:MA(CLOSE,34),COLORRED,LINETHICK;
X:=BARSLAST(REF(CROSS(C,MA(C,120)),1)) AND CROSS(MA(C,20),MA(C,120));
IF(M34<REF(M34,1),M34,DRAWNULL),COLORGREEN,LINETHICK;
STICKLINE(M3>=M13 AND M34>=REF(M34,1) ,H ,L ,0.1 ,0 ),COLORRED;
STICKLINE(M3>=M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,3 ,1 ),COLORRED;
STICKLINE(M3>=M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,3 ,0 ),COLORRED;
STICKLINE(M3<M13 AND M34>=REF(M34,1) ,H ,L ,0.1 ,0 ),COLORYELLOW;
STICKLINE(M3<M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,3 ,1 ),COLORYELLOW;
STICKLINE(M3<M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,3 ,0 ),COLORYELLOW;
STICKLINE(M3<M13 AND M34<REF(M34,1) ,H ,L ,0.1 ,0 ),COLORGREEN;
STICKLINE(M3<M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,3 ,1 ),COLORGREEN;
STICKLINE(M3<M13 AND M34<REF(M34,1) AND C<O ,O ,C ,3 ,0 ),COLORGREEN;
STICKLINE(M3>=M13 AND M34<REF(M34,1) ,H ,L ,0.1 ,0 ),COLORMAGENTA;
STICKLINE(M3>=M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,3 ,1 ),COLORMAGENTA;
STICKLINE(M3>=M13 AND M34<REF(M34,1) AND C<O ,O ,C ,3 ,0 ),COLORMAGENTA;

通达信抢钱宝主图指标公式

 

相关文章