在线检测未来函数

通达信高概率买点指标公式

来源:Internet,编辑:股旁网,2020-08-21

N:=5;
VAR11:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR22:=8,COLORGREEN,LINETHICK0;
建仓:=CROSS(VAR11,VAR22) AND ((C/REF(C,1)<1.018) OR C<REF(O,1)) AND (H!=C);
A5:=EMA((L+H+C*2)/4,5);
A13:=EMA((L+H+C*2)/4,13);
A21:EMA((L+H+C*2)/4,21);
A55:EMA((L+H+C*2)/4,55);
STICKLINE(A13>A55 AND A21>=REF(A55,1) AND A55>REF(A55,1),A55,A21,0.3,0),COLORF344C7;
STICKLINE(A21>A55 AND A21<REF(A21,1) AND A55>REF(A55,1),A55,A21,0.3,0),COLORF344C7;
STICKLINE(A21<A55 AND A13<=REF(A21,1) AND A13<REF(A55,1),A55,A21,0.3,0),COLOR32CD99;
海面:EMA(C,120),COLORFA05FF,LINETHICK2;
IF(海面>=REF( 海面,1),海面,DRAWNULL),COLORFA05FF,LINETHICK2;
IF(海面<REF (海面,1), 海面,DRAWNULL),COLOR399C7F,LINETHICK2;
VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
AA5:=SMA(A4,3,1);
A6:=3*A4-2*AA5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买K:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2)) AND ((C/REF(C,1)<1.018) OR C<REF(O,1)) AND (H!=C);
买:=MA(CLOSE,1);
卖:=(LOW+HIGH+CLOSE)/3;
老板:= MA(卖,5);
买卖:=LLV(老板,10);
短买:=建仓;
K:=SMA(VAR3/2,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
最佳买入时机:=买K;
BIAS1W:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2W:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3W:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
MM1:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6;
MN:=MA(MM1,3);
VAR24:=LLV(LOW,36);
VAR25:=HHV(HIGH,30);
VAR26:=EMA((CLOSE-VAR24)/(VAR25-VAR24)*4,4)*25;
背离:=IF(MN<-4 ,1.7,0);
标识:=IF(A21>A55,A21,A55);
STICKLINE(底背离,A55,标识*1.01,1,0),COLORA67D3D;
STICKLINE(短买,A55,标识*1.02,1,0),COLORWHITE;
STICKLINE(最佳买入时机 AND (短买=0),A55,标识*1.04,1,0),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.151,0,0,'底背离'),COLORA67D3D;
DRAWTEXT_FIX(ISLASTBAR,0.031,0,0,'短买'),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0.061,0,0,'最佳买入时机'),COLORYELLOW;

通达信高概率买点指标公式

 

相关文章