在线检测未来函数

通达信仓木操盘主图指标公式

来源:Internet,编辑:股旁网,2020-09-17

N:=30;
M:=5;
STICKLINE(HIGH/REF(CLOSE,1)>1.092,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(LOW/REF(CLOSE,1)<0.9004 AND CLOSE/REF(CLOSE,1)>0.9,OPEN,CLOSE,1,0),COLORGREEN;
STICKLINE(CLOSE/REF(CLOSE,1)>1.092,OPEN,CLOSE,2,0),COLORYELLOW;
X_1:=120101400;
X_2:=1;
MA5:MA(CLOSE,5)*X_2,COLORYELLOW;
MA20:MA(CLOSE,20)*X_2,COLORWHITE;
X_3:=MA(CLOSE,610)*X_2;
X_4:=MA(CLOSE,120);
X_5:=MA(CLOSE,233);
X_6:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
X_7:=(X_6/2+22)*1;
X_8:=EMA(VOL,13);
X_9:=EMA(AMOUNT,13);
X_10:=X_9/X_8/100;
X_11:=(CLOSE-X_10)/X_10*100;
X_12:=X_11<0 AND AMV.AMV1;
X_13:=(X_12 AND X_6<X_7)*X_2;
DRAWICON(X_13*X_2,LOW*0.985,24)*X_2,COLORYELLOW;
DRAWICON(REF(X_13,1)*X_2 AND CLOSE>OPEN AND CLOSE>REF(CLOSE,1),LOW*0.985,7)*X_2,COLORYELLOW;
X_14:=CLOSE;
X_15:=REF(X_14,M)=HHV(X_14,2*M+1);
X_16:=FILTER(X_15,M);
X_17:=BACKSET(X_16,M+1);
X_18:=FILTER(X_17,M);
X_19:=REF(X_14,M)=LLV(X_14,2*M+1);
X_20:=FILTER(X_19,M);
X_21:=BACKSET(X_20,M+1);
X_22:=FILTER(X_21,M);
X_23:=REF(CLOSE,BARSLAST(X_18));
X_24:=REF(CLOSE,BARSLAST(X_22));
X_25:=BARSLAST(X_18)<BARSLAST(X_22) AND NOT(X_18);
X_26:=BARSLAST(X_18)>BARSLAST(X_22) AND NOT(X_22);
前高:IF(X_25,X_23,X_23)*X_2,POINTDOT,COLORMAGENTA;
STICKLINE(X_25,X_23,X_23,9,0),COLORMAGENTA;
DRAWICON(CROSS(CLOSE,前高)*X_2,LOW*0.994,5),COLORYELLOW;
STICKLINE(HIGH/REF(CLOSE,1)>1.098 AND CLOSE/REF(CLOSE,1)<1.098,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(LOW/REF(CLOSE,1)<0.9004 AND CLOSE/REF(CLOSE,1)>0.9,OPEN,CLOSE,1,0),COLORGREEN;
STICKLINE(CLOSE>REF(CLOSE,1)*1.095,CLOSE,OPEN,1.5,0),COLORYELLOW;
X_27:=MA(JAX.济安线#WEEK,20)*X_2;
DRAWTEXT(DATE=X_1 AND X_2=0,HIGH*1.01,2336),COLORYELLOW;

通达信仓木操盘主图指标公式

 

相关文章