在线检测未来函数

通达信神奇止损线主图指标公式

来源:Internet,编辑:股旁网,2020-09-18

精准计数周期:=90;
基准点前N天:=0;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
支撑:REFDATE(V2,DATE),DOTLINE,LINETHICK1,COLORLIRED;
阻力:REFDATE(V3,DATE),DOTLINE,LINETHICK1,COLORGREEN;
DRAWTEXT(ISLASTBAR,阻力,'阻力'),COLORGREEN;
DRAWTEXT(ISLASTBAR,支撑,'支撑'),COLORLIRED;
N:=5;
A1:=REF(H,N)=HHV(H,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);{高点}
A2:=REF(L,N)=LLV(L,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);{低点}
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2;
E2:=(H+L)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2));
H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS
(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);{过滤后低点}
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);
U1:=T1>REF(T1,1); {前一低}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);
U2:=T2>REF(T2,1); {前二低}
短期支撑:DRAWLINE(U2,L,U1,L,1),COLORRED LINETHICK2;
DRAWICON(U1,L*0.99,9);
DRAWICON(U2,L*0.99,9);
AA1:=DRAWTEXT(CLOSE>=REF(CLOSE,1)*1.094,HIGH,'涨停'),COLORRED;
STICKLINE(V/REF(V,1)>1.9,OPEN,CLOSE,1,0),COLORYELLOW;
STICKLINE(AA1,C,O,3,0),COLORMAGENTA,LINETHICK1;
STICKLINE(AA1,H,L,0,0),COLORMAGENTA,LINETHICK1;
价涨不破:=LLV(L,3)>=REF(L,3);
三日量缩:=HHV(VOL,3)<REF(VOL,3);
高量柱:=C/REF(C,1)>=1.03 AND VOL=HHV(VOL,35);
倍量柱:=C/REF(C,1)>=1.03 AND VOL>=REF(VOL,1)*1.91;
梯量柱:=VOL>REF(VOL,1) AND REF(VOL,1)>REF(VOL,2) AND C/REF(C,1)>=1.03;
高黄金柱:=REF(高量柱,3) AND 价涨不破 AND 三日量缩;
倍黄金柱:=REF(倍量柱,3) AND 价涨不破 AND 三日量缩;
梯黄金柱:=REF(梯量柱,3) AND 价涨不破 AND 三日量缩;
STICKLINE(高黄金柱,LLV(L,3),LLV(L,3),25,1),COLORYELLOW;
STICKLINE(倍黄金柱,LLV(L,3),LLV(L,3),25,1),COLORYELLOW;
STICKLINE(梯黄金柱,LLV(L,3),LLV(L,3),25,1),COLORYELLOW;
DRAWTEXT(高黄金柱,L*0.99,'↖成立')COLORYELLOW;
DRAWTEXT(倍黄金柱,L*0.99,'↖成立')COLORYELLOW;
DRAWTEXT(梯黄金柱,L*0.99,'↖成立')COLORYELLOW;

通达信神奇止损线主图指标公式

 

相关文章