在线检测未来函数

通达信龙虎榜敢死队主图指标公式

来源:Internet,编辑:股旁网,2020-09-30

{使用说明:1、在趋势线为红色的基础上。可一直持股。2、在趋势线为红色的基础上,若有建仓持股、加仓、回踩、大黑马等提示,可加仓或重仓。3、趋势线由红变绿时,股票不涨停则止盈止损。4、参照成交量等其它指标,以防主力挖坑,以免卖飞牛股到时买不回来。}

涨幅偏离:=(((C-REF(C,1))/REF(C,1))-((INDEXC-REF(INDEXC,1))/REF(INDEXC,1)))*100>=0.07;{必须做收盘数据下载}
STICKLINE(涨幅偏离,C,(O+C)/2,2,0),COLORYELLOW;
跌幅偏离:=(((C-REF(C,1))/REF(C,1))-((INDEXC-REF(INDEXC,1))/REF(INDEXC,1)))<=-0.07;
STICKLINE(跌幅偏离,C,(O+C)/2,2,0),COLORGREEN;
振幅偏离:=(H-L)/L>=0.15;{振幅大于15个点}
STICKLINE(振幅偏离,O,C,1,0),COLORMAGENTA;
DRAWTEXT( 振幅偏离,H*1.1,'振'),COLORMAGENTA;
换手偏离:=DYNAINFO(37)>=0.20;
STICKLINE(换手偏离,O,(O+C)/2,2,0),COLORWHITE;
三天涨幅:=(SUM((C-REF(C,1))/REF(C,1)*100,3))>=20;
STICKLINE(三天涨幅,C,(O+C)/2,2,0),COLORYELLOW;
DRAWTEXT( 三天涨幅,L*0.98,'三连阳'),COLORYELLOW;
三天跌幅:=(SUM((C-REF(C,1))/REF(C,1)*100,3))<=-20;
STICKLINE(三天跌幅,C,(O+C)/2,2,0),COLORGREEN;
DRAWTEXT( 三天跌幅,L*0.98,'三连阴'),COLORGREEN;
MX:=EMA(C,2);
MXA:=EMA(SLOPE(C,21)*20+C,42);
AA:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,30))/MA(CLOSE,30);
趋势线:DMA((2*CLOSE+LOW+HIGH)/4,AA),LINETHICK3,COLORRED;
CC:=(CLOSE/趋势线);
MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);
MAAA:=((MA1-趋势线)/趋势线)/3;
TMP:=MA1-MAAA*MA1;
JJ:IF(TMP<=趋势线,趋势线,DRAWNULL),LINETHICK3,COLORGREEN;
XJ:IF(TMP<=趋势线,TMP,DRAWNULL),LINETHICK2,COLORBLUE;
{WWW.GUPANG.COM 股旁网}
建仓:CROSS(MX,MXA),NODRAW;
SEL:=CROSS(MXA,MX);
DRAWICON(建仓,L-0.8,9);
STICKLINE(建仓,O,C,2.5,0),COLORMAGENTA;
DRAWICON(SEL,H+0.1,2);
DRAWTEXT(建仓,L-0.68,'↖建仓持股'),COLORMAGENTA;
DRAWTEXT(SEL,H+0.38,'↙清仓持币'),COLORBLUE;
STICKLINE(MX>=MXA,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(MX>=MXA,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(MX<MXA,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(MX<MXA,CLOSE,OPEN,3,1),COLORGREEN;
STICKLINE(建仓,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(SEL,OPEN,CLOSE,2,0),COLORBLUE;
CP:=MA(CLOSE,9),COLORCYAN,LINETHICK1;
JD:=MA(CLOSE,18),COLORMAGENTA;
DRAWICON(CROSS(CP,JD) AND MX>=MXA,JD-0.1,1);
DRAWTEXT(CROSS(CP,JD) AND MX>=MXA,JD-0.38,'↖加仓'),COLORYELLOW;
BL:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
DRAWTEXT(FILTER(BL,3),H+0.2,'↙倍量柱');
STICKLINE(FILTER(BL,3),OPEN,CLOSE,1.5,0);
XG:=SUMBARS(FILTER(BL,3),1);
STICKLINE(XG,REF(L,XG-1),REF(L,XG-1),10,0);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
AAAB:=(DIF-DEA)*2*60;
起爆:=CROSS(AAAB-REF(AAAB,1),15);
STICKLINE(起爆,O,C,2.5,0),COLORYELLOW;
DRAWTEXT(起爆,(O+H)/2,'↖起爆'),COLORCYAN,LINETHICK2;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA21:=MA(C,21);
MA60:=MA(C,60);
操盘线:=MA(C,4);
安全线:=MA(C,19);
空:=EMA(CLOSE,5);
均衡:=EMA(空,0),COLORFFFFFF;
下趋势双线持币:=HHV(MA(HIGH,3),2);
上趋势单线持股:=LLV(MA(HIGH,3),1);
VAR5:=FILTER(均衡>REF(均衡,1) AND 下趋势双线持币<REF(下趋势双线持币,1) AND CLOSE>REF(CLOSE,1),11);
FF:=RANGE(C/MA21,0.97,1.15)OR RANGE(O/MA21,0.97,1.15);
金股:= VAR5 AND C>MA(C,21) AND EVERY(MA21>REF(MA21,1),7) AND FF;
IF( 金股>=1,L*0.996,DRAWNULL);
DRAWTEXT( 金股>=1,L*0.98,'↖回踩'),COLORMAGENTA;
Q1:=MA((L+H+C)/3,5);
压力:=HHV(Q1,60);
AHC1:=CLOSE*VOL;
AHC2:=EMA((EXPMA(AHC1,3)/EXPMA(VOL,3)+EXPMA(AHC1,6)/EXPMA(VOL,6)+EXPMA(AHC1,12)/EXPMA(VOL,12)+EXPMA(AHC1,24)/EXPMA(VOL,24))/4,13);
上轨:=1.06*AHC2;
顶:=1.13*AHC2;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
启爆:=CROSS(C,上轨) AND ZT;
DRAWTEXT(启爆,L*0.85,'启爆'),COLORYELLOW;
DRAWICON(启爆,L*0.90,24);
DRAWICON(启爆,L*0.92,25);
DRAWICON(启爆,L*0.94,26);
超牛:=CROSS(C,顶) AND ZT;
DRAWTEXT(超牛,L*0.98,'超牛'),COLORRED;
STICKLINE(超牛,O,C,2.5,0),COLORRED;
BOLL:=MA(C,20);
UPPER:=BOLL+2*STD(C,20);
LOWER:=BOLL-2*STD(C,20);
黑马:=CROSS(C,UPPER) AND C/REF(C,1)>1.05;
DRAWTEXT(大黑马,L-1.15,'大黑马'),COLORYELLOW;
敢死队:=大黑马 AND C>MA(C,60) AND C>MA(C,90) AND C>MA(C,120) AND C>MA(C,250);
DRAWTEXT(大黑马 AND C>MA(C,60) AND C>MA(C,90) AND C>MA(C,120) AND C>MA(C,250),H*1.03,'敢死队'),COLORYELLOW;
单阳:=C/REF(C,1)>=1.09 ;
不破价:=REF(C,BARSLAST(单阳));
DRAWTEXT(单阳,H-H*0.02,'阳'),COLOR00FFFF;
LS0:=BARSLAST(单阳);
LS11:=IF(1,LS0=1,单阳);
LS21:=IF(1,LLV(L,1)>REF(L,1),1);
单阳不破:=LS11 AND LS21;
STICKLINE(单阳不破,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破,不破价-不破价*0.02,'1'),COLORGREEN;
LS12:=IF(2,LS0=2,单阳);
LS22:=IF(2,LLV(L,2)>REF(L,2),1);
单阳不破2:=LS12 AND LS22;
STICKLINE(单阳不破2,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破2,不破价-不破价*0.02,'2'),COLORGREEN;
LS13:=IF(3,LS0=3,单阳);
LS23:=IF(3,LLV(L,3)>REF(L,3),1);
单阳不破3:=LS13 AND LS23;
STICKLINE(单阳不破3,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破3,不破价-不破价*0.02,'3'),COLORGREEN;
LS14:=IF(4,LS0=4,单阳);
LS24:=IF(4,LLV(L,4)>REF(L,4),1);
单阳不破4:=LS14 AND LS24;
STICKLINE(单阳不破4,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破4,不破价-不破价*0.02,'4'),COLORGREEN;
LS15:=IF(5,LS0=5,单阳);
LS25:=IF(5,LLV(L,5)>REF(L,5),1);
单阳不破5:=LS15 AND LS25;
STICKLINE(单阳不破5,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破5,不破价-不破价*0.02,'5'),COLORGREEN;
LS16:=IF(6,LS0=6,单阳);
LS26:=IF(6,LLV(L,6)>REF(L,6),1);
单阳不破6:=LS16 AND LS26;
STICKLINE(单阳不破6,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破6,不破价-不破价*0.02,'6'),COLORGREEN;
LS17:=IF(7,LS0=7,单阳);
LS27:=IF(7,LLV(L,7)>REF(L,7),1);
单阳不破7:=LS17 AND LS27;
STICKLINE(单阳不破7,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破7,不破价-不破价*0.02,'7'),COLORGREEN;
LS18:=IF(8,LS0=8,单阳);
LS28:=IF(8,LLV(L,8)>REF(L,8),1);
单阳不破8:=LS18 AND LS28;
STICKLINE(单阳不破8,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破8,不破价-不破价*0.02,'8'),COLORGREEN;
LS19:=IF(9,LS0=9,单阳);
LS29:=IF(9,LLV(L,9)>REF(L,9),1);
单阳不破9:=LS19 AND LS29;
STICKLINE(单阳不破9,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破9,不破价-不破价*0.02,'9'),COLORGREEN;
LS110:=IF(10,LS0=10,单阳);
LS210:=IF(10,LLV(L,10)>REF(L,10),1);
单阳不破10:=LS110 AND LS210;
STICKLINE(单阳不破10,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破10,不破价-不破价*0.02,'10'),COLORGREEN;
C2:=REF(C,1),NODRAW;
涨停1:=REF(C,11)*1.1-C<0.01 AND H=C,NODRAW;
STICKLINE(涨停1,OPEN,CLOSE,1,0),COLORRED;
STICKLINE(涨停1,H,L,0,0),COLORRED;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2) AND L=C,1,0),NODRAW;
STICKLINE(跌停,OPEN,CLOSE,1,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;

通达信龙虎榜敢死队主图指标公式

 

相关文章