在线检测未来函数

通达信回调买进主图指标公式

来源:Internet,编辑:股旁网,2020-12-23

N1:=10;
N2:=30;
N3:=56;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
{STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,1),COLORRED;}{红1}
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
{STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3,0),COLORFFCC66;}
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),8,1),COLORYELLOW;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),5,2),COLOR00FF00{98FD};
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00C8FF;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10ECFF;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10FFFF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00D900;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORBLUE;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR090FF2;
PMA:MA(C,5),COLORRED,LINETHICK2;
IF(PMA>REF(PMA,1),PMA,DRAWNULL),COLORRED,LINETHICK2;
IF(PMA<REF(PMA,1),PMA,DRAWNULL),COLORGREEN,LINETHICK2;
X:=(3*C+L+O+H)/6;
多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLORFF00FF,LINETHICK3;
{用法:黄托底买进,蓝压顶卖出。}
DRAWTEXT_FIX(C>0,0.004,1,0,'黄托底买进,蓝压顶卖出'),COLORYELLOW;
DD:=多空线<REF(多空线,1);
IF(DD,多空线,DRAWNULL),COLOR00FFFF,LINETHICK2;
A:=(PMA>多空线);
IF(A,多空线,DRAWNULL),COLOR33FF33,POINTDOT,LINETHICK4;
VAR21:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR22:=8;
BB:=CROSS(VAR21,VAR22);
DRAWTEXT(BB,L*0.98,'买进!'),COLOR0099FF;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
MM:={REF(MACD,1)<REF(MACD,2) AND}((MACD>0 AND MACD>REF(MACD,1)) OR
(MACD<0 AND MACD>REF(MACD,1)));
ZF:=(C-REF(C,1))/REF(C,1)*100;
HZ10:=REF(MA(V/CAPITAL*100,10),1);
TJA:=RANGE(DYNAINFO(57)/10000,50000,1800000);{流通市值介于5亿到180亿之间,盘子过小的DDE波动大不稳定,盘子过大的股性不活}
TJC:=C<80;{不做高价股}{WWW.GUPANG.COM}
TJD:=IF(DYNAINFO(57)/10000<1800000,HZ10>2.0,HZ10>0.3);{不做10天均换手在2.5%以下的}
JC:=TJA AND TJC AND TJD;SV:=SUM(V,5)/5<REF(SUM(V,5)/5,5)*1.2;
M5:=MA(C,5);
M10:=MA(C,10);
M13:MA(C,13),DOTLINE,COLORYELLOW;
M20:=MA(C,20);
M30:=MA(C,30);
YCX:=M5>=REF(M5,1);
H1:=MAX(MAX(M5,M13),M30);
L1:=MIN(MIN(M5,M13),M30);
一阳穿三:=H1<C AND O<L1 AND YCX AND M30>REF(M30,1);
DRAWTEXT(一阳穿三 ,H*1.01,'阳穿三' ),COLORWHITE,LINETHICK2;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.5;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5){*1.5};
FF1:=BB1 AND CC1 AND DD1 AND EE1;
老鼠仓:=FF1 AND JC AND SUM(V,5)/5<REF(SUM(V,5)/5,5)*1.5 AND (SUM(ZF>9.9,10)>0 OR MM);
DRAWTEXT(老鼠仓 ,H*1.06,'老鼠仓' ),COLORWHITE,LINETHICK2;
DIF55:=(EMA(CLOSE,30)-EMA(CLOSE,90))*0.55;
DEA55:=(EMA(DIF55,26));
MACD周:=(DIF55-DEA55)*2;
Z1:=MA(C,21);
ZX:=REF(Z1,6.5);
A1:=(C-REF(C,1))/REF(C,1)*100;
A2:=SLOPE(CLOSE,3)/CLOSE*100;
MA5:=BARSLAST(A1>3);
XGS:={CROSS(C,ZX) AND C>ZX AND} A1>3 AND CROSS(A2,0);
AA:=REF(CLOSE,1);
DDS:=SMA(MAX(CLOSE-AA,0),5,1)/SMA(ABS(CLOSE-AA),5,1)*1000;
HHD:=DDS-LLV(DDS,10);
SS:=(MA(HHD,2)*3+HHD*13)/16;
短线:=IF(SS>13,MA(SS,2),SS)/6;
出击:=COUNT(CROSS(短线,8.5),2)>0 AND (短线<30)AND C>REF(C,1);
低位出击:=COUNT(出击,2) AND MM AND MACD>0 AND MACD周>0 ;
DRAWTEXT(FILTER(低位出击 ,5 ) ,H*1.0056,'出击' ),COLORWHITE,LINETHICK1;
LL:=LLV(L,N1);
HH:=HHV(H,2*N1);
H0:=REF(HHV(H,N3),N1+N2);
涨幅60R:=(C-REF(C,60))/REF(C,60)*100;
选股:=6*(HH=HHV(H,N2+N1+N3) AND LL>=H0*0.98 AND LL/HH<0.98)
AND COUNT((CLOSE/REF(CLOSE,1)-1)*100>9.9,16)>1 ;
此门:=选股 AND (REF(H,5)-L)/L>0.24 AND 1.04*REF(C,1)<REF(O,1) AND O/L>1.03
AND CAPITAL/100<300000 AND 涨幅60R<100;
DRAWTEXT(此门,L,'此门' ),COLORWHITE;
桃花:=6*(HH=HHV(H,N2+N1+N3) AND LL>H0*0.90 AND LL/HH<0.98)
AND COUNT((CLOSE/REF(CLOSE,1)-1)*100>9.9,20)>2
AND (REF(H,5)-L)/L>0.25
AND REF(C,1)<0.95*REF(O,1) AND O/L>1.05 AND CAPITAL/100<500000
AND 涨幅60R<100;
DRAWTEXT(桃花,L*0.96,'桃花' ),COLORRED;
短思:=6*(HH=HHV(H,N2+N1+N3) AND LL>H0 AND LL/HH<0.95)
AND SUM(ZF>9.92,16)>3 AND (REF(C,3)-C)/C>0.15
AND CAPITAL/100<160000 AND 涨幅60R<110 AND {V/CAPITAL*100<5}
IF(COUNT(C ,0 )<200,V/CAPITAL*100<15,V/CAPITAL*100<8) AND
IF(COUNT(C ,0 )<200,REF(SUM(V/CAPITAL*100,10)/10,1)<10 ,REF(SUM(V/CAPITAL*100,10)/10,1)<5);
DRAWTEXT(短思,L*0.96,'短思' ),COLORRED;
长思:=6*(HH=HHV(H,N2+N1+N3) AND LL>H0*0.91 AND LL/HH<0.98)
AND COUNT((CLOSE/REF(CLOSE,1)-1)*100>9.8,20)>2 AND REF(C,1)<0.93*REF(O,1)
AND (REF(C,7)-C)/C>0.20 AND CAPITAL/100<160000
AND 涨幅60R<100;
DRAWTEXT(长思,L*0.96,'长思' ),COLORRED;
STICKLINE(ZF>=9.9,O,C,2,0),COLORRED;
STICKLINE(ZF<=-9.9,O,C,2,0),COLORBLUE;

通达信回调买进主图指标公式

 

相关文章