在线检测未来函数

通达信一线买卖主图指标公式

来源:Internet,编辑:股旁网,2021-01-20

{使用说明:线上买,线下卖。}

P1:=18;
NH:=1;
CC:=(2*C+H+L)/4;
KS:=BARSCOUNT(C)+2;
M:=IF(KS<P1,KS,P1);
GL:=ABS((M*CC-SUM(CC,M))/SUM(CC,M))+NH/453;
DTZQ:=INTPART(NH/GL+0.5),NODRAW;
FW:=EMA((2*EMA(C,2*DTZQ)-1*EMA(C,1*DTZQ)),DTZQ);
FW2:=EMA((2*EMA(C,1*DTZQ)-1*EMA(C,2*DTZQ)),DTZQ);
ZJX:(FW+FW2)/2,COLORRED,LINETHICK2;
TA:=IF(DTZQ<8,8,1*DTZQ);
LX:DRAWLINE(H>=HHV(H,TA),H,L<=LLV(L,TA),L,0),COLORFF00CC,LINETHICK2;
LY:DRAWLINE(L<=LLV(L,TA),L,H>=HHV(H,TA),H,0),COLORFF00CC,LINETHICK2;
TT:=BARSLAST(LX=LY),NODRAW;
T2:=REF(TT,1)+1,NODRAW;
ZGX:REF(H,BARSLAST(LX=LY AND C>REF(C,T2))),COLORYELLOW,LINETHICK2;
DGX:REF(L,BARSLAST(LX=LY AND L<REF(L,T2))),COLORYELLOW,LINETHICK2;

通达信一线买卖主图指标公式

 

相关文章