在线检测未来函数

通达信突破买点确认指标公式

来源:Internet,编辑:股旁网,2021-02-10

N:=10;
P1:=3;
M:=5;
年认同价:=MA(C,240);
价格中枢:=(SUM(年认同价,0)/(BARSSINCE(年认同价>0)+239));
箱顶:=价格中枢*1.2;
箱底:=价格中枢*0.8;
毛利润率:=FINANCE(21)/FINANCE(20);
成长价值:=年认同价*(1+毛利润率);
收益价值:=年认同价+FINANCE(33);
回调认同:=EMA(EXPMA(C,20),13);
股价均线:=EMA(C,M);
股价趋势:=股价均线>REF(股价均线,1);
多头:=(回调认同>REF(回调认同,1))AND(成长价值>REF(成长价值,1))AND(收益价值>REF(收益价值,1));
确认趋势:=多头 AND 股价趋势 AND COUNT(股价趋势,P1)<=1;
股价突破:=C>REF(股价均线,1) AND 确认趋势;
{突破买点}
回调条件:=COUNT(C<回调认同,5)>=3;
回调突破:=(REF(C,1)<=REF(回调认同,1))AND(C>回调认同)AND(回调条件)AND 多头;
回调确认:=(COUNT(C>回调认同,3)=3)AND(COUNT(回调突破,3)=1);
成长条件:=COUNT(C<成长价值,5)>=3;
成长突破:=(REF(C,1)<=REF(成长价值,1))AND(C>成长价值)AND(成长条件)AND 多头;
成长确认:=(COUNT(C>成长价值,3)=3)AND(COUNT(成长突破,3)=1);
收益条件:=COUNT(C<收益价值,5)>=3;
收益突破:=(REF(C,1)<=REF(收益价值,1))AND(C>收益价值)AND(收益条件)AND 多头;
收益确认:=(COUNT(C>收益价值,3)=3)AND(COUNT(收益突破,3)=1);
箱底条件:=COUNT(C<箱底,5)>=3;
箱底突破:=(REF(C,1)<=REF(箱底,1))AND(C>箱底)AND(箱底条件)AND 多头;
箱底确认:=(COUNT(C>箱底,3)=3)AND(COUNT(箱底突破,3)=1);
价格条件:=COUNT(C<价格中枢,5)>=3;
价格突破:=(REF(C,1)<=REF(价格中枢,1))AND(C>价格中枢)AND(价格条件)AND 多头;
价格确认:=(COUNT(C>价格中枢,3)=3)AND(COUNT(价格突破,3)=1);
箱顶条件:=COUNT(C<箱顶,5)>=3;
箱顶突破:=(REF(C,1)<=REF(箱顶,1))AND(C>箱顶)AND(箱顶条件)AND 多头;
箱顶确认:=(COUNT(C>箱顶,3)=3)AND(COUNT(箱顶突破,3)=1);
突破买点:(回调突破+成长突破+收益突破+箱底突破+价格突破+箱顶突破),POINTDOT,COLORRED;
STICKLINE(突破买点>=1,3,0,4,0),COLORRED;
突破确认:(回调确认+成长确认+收益确认+箱底确认+价格确认+箱顶确认),POINTDOT,COLORYELLOW;
STICKLINE(突破确认>=1,6,3,4,0),COLORYELLOW;
{支撑买点}
回调回调系数:=ABS(股价均线-回调认同)/回调认同*100<=N;
回调条件成立:=股价突破 AND 回调回调系数;
回调支撑买点:=IF(COUNT(C<REF(回调认同,1),3)=3,0,回调条件成立);
回调支撑优选:=(回调支撑买点 AND COUNT((回调认同>REF(回调认同,1)),5)=5);
成长回调系数:=ABS(股价均线-成长价值)/成长价值*100<=N;
成长条件成立:=股价突破 AND 成长回调系数;{确认多条件成立}
成长支撑买点:=IF(COUNT(C<REF(成长价值,1),3)=3,0,成长条件成立);
成长支撑优选:=(成长支撑买点 AND COUNT((成长价值>REF(成长价值,1)),5)=5);
收益回调系数:=ABS(股价均线-收益价值)/收益价值*100<=N;
收益条件成立:=股价突破 AND 收益回调系数;{确认多条件成立}
收益支撑买点:=IF(COUNT(C<REF(收益价值,1),3)=3,0,收益条件成立);
收益支撑优选:=(收益支撑买点 AND COUNT((收益价值>REF(收益价值,1)),5)=5);
箱底回调系数:=ABS(股价均线-箱底)/箱底*100<=N;
箱底条件成立:=股价突破 AND 箱底回调系数;
箱底支撑买点:=IF(COUNT(C<REF(箱底,1),3)=3,0,箱底条件成立);
箱底支撑优选:=(箱底支撑买点 AND COUNT((箱底>REF(箱底,1)),5)=5);
价格回调系数:=ABS(股价均线-价格中枢)/价格中枢*100<=N;
价格条件成立:=股价突破 AND 价格回调系数;
价格支撑买点:=IF(COUNT(C<REF(价格中枢,1),3)=3,0,价格条件成立);
价格支撑优选:=(价格支撑买点 AND COUNT((价格中枢>REF(价格中枢,1)),5)=5);
箱顶回调系数:=ABS(股价均线-箱顶)/箱顶*100<=N;
箱顶条件成立:=股价突破 AND 箱顶回调系数;
箱顶支撑买点:=IF(COUNT(C<REF(箱顶,1),3)=3,0,箱顶条件成立);
箱顶支撑优选:=(箱顶支撑买点 AND COUNT((箱顶>REF(箱顶,1)),5)=5);
支撑买点:(回调支撑买点+成长支撑买点+收益支撑买点+箱底支撑买点+价格支撑买点+箱顶支撑买点),POINTDOT,COLOR00FF00;
STICKLINE(支撑买点>=1,9,6,4,0),COLOR00FF00;
支撑优选:(回调支撑优选+成长支撑优选+收益支撑优选+箱底支撑优选+价格支撑优选+箱顶支撑优选),POINTDOT,COLORFF00FF;
STICKLINE(支撑优选>=1,12,9,4,0),COLORFF00FF;

通达信突破买点确认指标公式

 

相关文章