在线检测未来函数

通达信强弱平台线主图指标公式

来源:Internet,编辑:股旁网,2021-02-22

本文指标含有选股公式如下:

强弱平台线主图之突买选股指标公式

DRAWGBK(C>0,RGB(20,0,28),RGB(20,0,28),0,0,1);
DRAWBAND(MA(CLOSE,60),RGB(80,0,0),MA(CLOSE,120),RGB(0,91,0));
DRAWBAND(MA(CLOSE,5),RGB(155,50,50),MA(CLOSE,10),RGB(83,123,68));
DRAWKLINE(H,O,L,C);
N:=240;
KK:=BARSLAST(CURRBARSCOUNT=N);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,KK),0));
RR:=CONST(IF(ISLASTBAR=1,LLV(L,KK),0));
KJ:=GD-RR;
高:IF(CURRBARSCOUNT<=N,GD,DRAWNULL),COLOR00FFFF,POINTDOT;
压:IF(CURRBARSCOUNT<=N,GD-KJ*0.191,DRAWNULL),COLORFF00FF,NODRAW;
平衡:IF(CURRBARSCOUNT<=N,RR+KJ/2,DRAWNULL),COLOR00FFFF,NODRAW;
支撑:IF(CURRBARSCOUNT<=N,RR+KJ*0.191,DRAWNULL),COLOR00FF00,NODRAW;
低:IF(CURRBARSCOUNT<=N,RR,DRAWNULL),COLOR00FF00,POINTDOT;
天:BARSLAST(L=RR),COLOR00FFFF,NODRAW;
STICKLINE(CURRBARSCOUNT=N,GD,RR,0,-1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=N,GD,RR,0,-1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1,GD,RR,0,-1),COLORGREEN;
STICKLINE(CURRBARSCOUNT<=N,平衡,平衡,3,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT<=N,压,压,3,-1),COLORRED;
STICKLINE(CURRBARSCOUNT<=N,支撑,支撑,3,-1),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,压,'0.809'),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=1,平衡,'0.500'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=1,支撑,'0.191'),COLOR00FFFF;
A:=EMA(C,21)COLORBLUE,LINETHICK3;
B:=A<REF(A,1);
HY:=IF(B-1,A,DRAWNULL)COLORRED,LINETHICK3;
AA:=EMA(C,3) > EMA(C,21);
BB:=EMA(C,3) < EMA(C,21);
CC:= EMA(C,3) > EMA(C,8);
CC1:=EMA(C,3) < EMA(C,8);
DRAWTEXT(CURRBARSCOUNT=N/2+9,GD-KJ/12,'★强势区域--急拉减仓!'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=N/2+9,GD-KJ/3,'●震荡整理--寻机低吸!'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=N/2+9,RR+KJ/3,'◆反弹中轨--逢高休息!'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/2+9,RR+KJ/10,'■弱势区域--暂不参与!'),COLORFFFF00;
STICKLINE(BARSLAST(CURRBARSCOUNT=3)>=0,REF(C,BARSLAST(CURRBARSCOUNT=3)),REF(C,BARSLAST(CURRBARSCOUNT=3)),6,-1),COLORYELLOW;
AAA:=BARSLAST(DATE!=REF(DATE,1));
前天收:=REF(C,AAA+2)COLORWHITE;
{}
{高点突破};
BDGD:=C=HHV(C,13);
GDSJ:=BARSLAST(FILTER(CROSS(0.8,BDGD),2))+1;
高点:REF(C,GDSJ),COLORFF00FF,POINTDOT;
突破:CROSS(C,REF(高点,1)),COLOR00FFFF,POINTDOT,NODRAW;
STICKLINE(GDSJ<=6,高点,高点,3,0),COLORFF00FF;
DRAWTEXT(突破,LOW,'↑突买'),COLOR00FFFF;
DRAWICON(CROSS(C,HHV(突破,'↑突买')),L*0.98,1);
DRAWICON(CROSS(C,HHV(高点,120)),L*0.98,1);
{}
{主题概念}
ZZ1:=STRCAT(HYBLOCK,'----');
Z2:=STRCAT(ZZ1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,'----');
DRAWTEXT_FIX(1,0.00,0.06,0,' 主题概念:')COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.07,0.06,0,STRCAT(Z4,GNBLOCK)),COLORCYAN;
{涨停颜色粉色,完美区分20%10%5%,创业板20200823前10%照样变色}
BK:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板'),0.2,IF(INBLOCK('ST板块'),0.05,0.1)));
XA_1:=IF(DATE<=1200823,1,0);
STICKLINE((C>=ZTPRICE(REF(CLOSE,1),0.1) AND C=H) AND XA_1=1,O,C,4,0),COLOR007FFF;
STICKLINE((C<=DTPRICE(REF(CLOSE,1),0.1) AND C=L) AND XA_1=1,O,C,4,0),COLOR80FF00;
STICKLINE((C>=ZTPRICE(REF(C,1),BK) AND C=H),C,O,4,0),COLOR007FFF;
STICKLINE((C<=DTPRICE(REF(C,1),BK) AND C=L),C,O,4,0),COLOR80FF00;
STICKLINE((H=ZTPRICE(REF(C,1),BK) AND C<H),H,MAX(C,O),0,0),COLORMAGENTA;{涨停后回落}
STICKLINE((L=DTPRICE(REF(C,1),BK) AND C>L),L,MIN(C,O),0,0),COLORGREEN;{跌停后回升}
RSV:=(((CLOSE - LLV(LOW,12)) / (HHV(HIGH,12) - LLV(LOW,12))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSV12:=(((CLOSE - LLV(LOW,25)) / (HHV(HIGH,25) - LLV(LOW,25))) * 100);
K12:=SMA(RSV12,3,1);
D12:=SMA(K12,3,1);
J12:=((3 * K12) - (2 * D12));
RSV24:=(((CLOSE - LLV(LOW,60)) / (HHV(HIGH,60) - LLV(LOW,60))) * 100);
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=((3 * K24) - (2 * D24));
平台线:IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J)))),LINETHICK4,COLORMAGENTA;
DRAWTEXT(ISLASTBAR,平台线,'平台线')COLORMAGENTA;
TA:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=EMA(TA,13);
VAR88:=REF(CLOSE,1)-REF(ATR,1);
强弱线:HHV(VAR88,13)COLORCYAN,LINETHICK3;
DRAWTEXT(ISLASTBAR,强弱线,'强弱线'),COLORCYAN;

通达信强弱平台线主图指标公式

 

相关文章