在线检测未来函数

通达信CCI趋势操盘升级版指标公式

来源:Internet,编辑:股旁网,2021-02-22

{使用说明:当CC3从低位上穿强弱分界线或上穿压力时,可买入;当CC3下破压力或强弱分界线时,可减仓或清仓。}

TYP:=(HIGH+LOW+CLOSE)/3;
C1:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
C2:=(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84));
C3:=IF(C1<EMA(C1,5),EMA(C1,5),C1);
STICKLINE(C1>100,C1,120,1,0),COLOR38FF00;
STICKLINE(C1<-100,C1,-120,1,0),COLOR00AAFF;
CC1:C1,COLORGREEN,LINETHICK2;
CC2:C2;
CC3:C3,LINETHICK2;
压力:HHV(MA(C3,3),13),LINETHICK2,COLORFF8000;
支撑:LLV(MA(C1,3),13),COLORRED,LINETHICK2;
VARA:=REF(LOW,1);
VARB:=SMA(ABS(LOW-VARA),3,1)/SMA(MAX(LOW-VARA,0),3,1)*100;
VARC:=EMA(IF(CLOSE*1.3,VARB*10,VARB/10),3);
VARD:=LLV(LOW,30);
VARE:=HHV(VARC,30);
VARF:=IF(MA(CLOSE,58),1,0);
VARG:=EMA(IF(LOW<=VARD,(VARC+VARE*2)/2,0),3)/618*VARF;
VARH:=IF(VARG>50,50,VARG);
STICKLINE(VARH>-120,0,VARH,3,1),COLOR80FF80;
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
LL:=REF(CLOSE,1);
MM:=SMA(MAX(CLOSE-LL,0),6,1)/SMA(ABS(CLOSE-LL),6,1)*100;
强弱分界:IF(VARH,0,0),COLORMAGENTA;
底:IF(CROSS(C1,-150),-150,-200),COLORFFFFFF,LINETHICK2;
顶:IF(CROSS(80,MM),200,250),LINETHICK2,COLORCYAN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.009,1,0,'主力进出'),COLORMAGENTA;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1,1,0,'散户进出'),COLORCYAN;

通达信CCI趋势操盘升级版指标公式

 

相关文章