在线检测未来函数

通达信绝杀起点指标公式

来源:Internet,编辑:股旁网,2021-04-06

{使用说明:当出现数字1时买入;出现数字2时可以加仓.也可以选择止盈。}

N:=3;
VAR1:=(C-EMA(C,6))/EMA(C,6)*100;
VAR2:=(C-MA(C,24))/MA(C,24)*100;
VAR3:=(C-MA(C,32))/MA(C,32)*100;
VAR4:=(VAR1+VAR2+VAR3)/3;
KX:MEMA(VAR4,N),NODRAW,COLORWHITE;
DX:MEMA(KX,3),NODRAW,COLORYELLOW;
DRAWBAND(KX,RGB(150,0,100),DX,RGB(100,100,50));
MCD:EMA(EMA(VAR1,3),N)*2,COLORSTICK;
VAR5:=EMA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20;
VAR6:=SMA(SMA(100-3*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+SMA(2*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
VAR7:=VAR6<REF(VAR6,1) AND MCD>REF(MCD,1) AND DX>REF(DX,1) AND V>REF(V,1) AND C>O*1.011;
VAR8:=LLV(VAR5,3)<VAR5;
VAR9:=KX>DX AND DX<7;
必杀①:IF(VAR8>=1 AND VAR9 AND REF(KX<DX,1),1,0),NODRAW,COLORRED;
必杀②:IF(VAR7 AND VAR8 AND VAR9,1,0),NODRAW,COLORYELLOW;
STICKLINE(必杀①,-2,0,2,0),COLORRED;
STICKLINE(必杀②=1 AND REF(必杀②,1)<=0,0,1,2,0),COLORYELLOW;
{文字输出可以不要}
DRAWTEXT(必杀①,0,'①'),COLORWHITE;
DRAWTEXT(必杀② AND REF(必杀②,1)<=0,2,'②'),COLORYELLOW;

通达信绝杀起点指标公式

 

相关文章