在线检测未来函数

3D-BS决策源码(大智慧)

来源:Internet,编辑:股旁网,2010-05-24

3D-BS决策源码,需要LTFunc5.dll支持。

{3D-BS决策}
INPUT:Q1(5,0,1000),Q2(10,0,1000),Q3(20,0,1000),Q4(30,0,1000),Q5(60,0,1000),Q6(120,0,1000);
MA1:MA(C,Q1);
MA2:MA(C,Q2);
MA3:MA(C,Q3);
MA4:MA(C,Q4);
MA5:MA(C,Q5);
MA6:MA(C,Q6);
a:="LTFunc4@FORLT2";
s1:="LTFunc4@LT_S1";
hs:="LTFunc4@LT_HS";
ls:="LTFunc4@LT_LS";
p1:="LTFunc4@LT_P1";
upp:="LTFunc4@LT_UPP";
udd:="LTFunc4@LT_UDD";
{hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};
d1:=ema(abs("日线-DDX.ddx"),60);
d2:=max("日线-DDX.ddx"/d1+7.5,7.5);
d3:=min("日线-DDX.ddx"/d1,10);
fb:=if(s1=0,hs,ls);
tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现S点\n','若明日收盘价> '+numtostrn(upp,2)+',出现B点\n');
tr1:=ifs(s1=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价> '+numtostrn(hs,2)+'短线买入机会');
tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持股'),ifs(cross(1,p1),'S点','持币'));
tr3:=ifs(s1=0,'向下,','向上,');
tr4:='3.能量级别:'+numtostrn(d3,1)+'级';
bs:=''+datestr(date)+'买卖点决策系统提示\n'+'1.BS点:'+tr2+','+tr0+'2.短线:'+tr3+tr1+'\n'+tr4;
drawflagtext(1,fb,bs);
DRAWICON(d3>1,LOW,6),align1;
drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;
drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2;
drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1,l,'bs.bmp'),align1,valign0;
drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1,h,'ss.bmp'),align1,valign2;
BS决策:=if((p1=1 and ref(p1,1)=0),1,if((p1=0 and ref(p1,1)=1),2,0));
BS短线:=if((s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1),1,if((s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1),2,0));
BS能量:=d3;
IF(BS决策<1 and BS短线<1 and BS能量<1) THEN BEGIN
STICKLINE(p1=1 and c>=o and o<>0,c,o,d2,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,c,o,7.5,0),colorblack;
STICKLINE(p1=1 and c>=o and o<>0,c,c,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,o,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,l,c,0.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,h,o,0.5,1),color5454ff;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,o,7.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,h,0.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,l,o,0.5,1),colorffff54;
END;
{金色}
STICKLINE(BS能量>1,C,O,8.3,0),COLOR005555;
STICKLINE(BS能量>1,C,O,6.4,0),COLOR007777;
STICKLINE(BS能量>1,C,O,4.9,0),COLOR009999;
STICKLINE(BS能量>1,C,O,3.4,0),COLOR00BBBB;
STICKLINE(BS能量>1,C,O,1.9,0),COLOR00DDDD;
STICKLINE(BS能量>1,C,O,0.4,0),COLOR00FFFF;
{红色}
STICKLINE(BS决策=1,C,O,8.3,0),COLOR000088;
STICKLINE(BS决策=1,C,O,6.4,0),COLOR0000AA;
STICKLINE(BS决策=1,C,O,4.9,0),COLOR0000CC;
STICKLINE(BS决策=1,C,O,3.4,0),COLOR0000EE;
STICKLINE(BS决策=1,C,O,1.9,0),COLOR5D5DFF;
STICKLINE(BS决策=1,C,O,0.4,0),COLOR8585FF;
{粉红色}
STICKLINE(BS短线=1,C,O,8.3,0),COLOR3333FF;
STICKLINE(BS短线=1,C,O,6.4,0),COLOR5555FF;
STICKLINE(BS短线=1,C,O,4.9,0),COLOR7777FF;
STICKLINE(BS短线=1,C,O,3.4,0),COLOR9999FF;
STICKLINE(BS短线=1,C,O,1.9,0),COLORBBBBFF;
STICKLINE(BS短线=1,C,O,0.4,0),COLORDDDDFF;
{蓝色}
STICKLINE(BS决策=2,C,O,8.3,0),COLORFF0000;
STICKLINE(BS决策=2,C,O,6.4,0),COLORFF2222;
STICKLINE(BS决策=2,C,O,4.9,0),COLORFF4444;
STICKLINE(BS决策=2,C,O,3.4,0),COLORFF6666;
STICKLINE(BS决策=2,C,O,1.9,0),COLORFF8888;
STICKLINE(BS决策=2,C,O,0.4,0),COLORFFAAAA;
{粉蓝色}
STICKLINE(BS短线=2,C,O,8.3,0),COLOR555500;
STICKLINE(BS短线=2,C,O,6.4,0),COLOR777700;
STICKLINE(BS短线=2,C,O,4.9,0),COLOR999900;
STICKLINE(BS短线=2,C,O,3.4,0),COLORBBBB00;
STICKLINE(BS短线=2,C,O,1.9,0),COLORDDDD00;
STICKLINE(BS短线=2,C,O,0.4,0),COLORFFFF00;

相关文章