在线检测未来函数

通达信相同价位开收最高最低连线主图指标公式

来源:Internet,编辑:股旁网,2014-09-28

{只需改动JG1和JG2的赋值 就可以画出收盘价 开盘价 最低价连线 下面是最高价相同连线
高手飘过 新手可以将下面的替换JG1:=H;JG2:=H;
收盘价换成 JG1:=c;JG2:=c;
最低价换成 JG1:=l;JG2:=l;
开盘价换成 JG1:=o;JG2:=o;}
JG1:=H;JG2:=H;
A1:=REFX(JG2,1);A2:=REFX(JG2,2);A3:=REFX(JG2,3);A4:=REFX(JG2,4);A5:=REFX(JG2,5);
A6:=REFX(JG2,6);A7:=REFX(JG2,7);A8:=REFX(JG2,8);A9:=REFX(JG2,9); A10:=REFX(JG2,10);A11:=REFX(JG2,11);
A12:=REFX(JG2,12);A13:=REFX(JG2,13);A14:=REFX(JG2,14);A15:=REFX(JG2,15);A16:=REFX(JG2,16);
A17:=REFX(JG2,17);A18:=REFX(JG2,18);A19:=REFX(JG2,19);A20:=REFX(JG2,20); A21:=REFX(JG2,21);A22:=REFX(JG2,22);
A23:=REFX(JG2,23);A24:=REFX(JG2,24);A25:=REFX(JG2,25);A26:=REFX(JG2,26);A27:=REFX(JG2,27);
A28:=REFX(JG2,28);A29:=REFX(JG2,29);
YZ:=CURRBARSCOUNT<=30 AND (JG1=A1 OR JG1=A2 OR JG1=A3 OR JG1=A4 OR JG1=A5 OR JG1=A6 OR
JG1=A7 OR JG1=A8 OR JG1=A9 OR JG1=A10 OR JG1=A11 OR JG1=A12 OR JG1=A13 OR JG1=A14 OR
JG1=A15 OR JG1=A16 OR JG1=A17 OR JG1=A18 OR JG1=A19 OR JG1=A20 OR JG1=A21 OR JG1=A22 OR JG1=A23 OR
JG1=A24 OR JG1=A25 OR JG1=A26 OR JG1=A27 OR JG1=A28 OR JG1=A29 );
B1:=COUNT(YZ,0);
NOTEXTX1:DRAWLINE(B1=1 AND YZ,JG1,REF(JG1,BArslAst(B1=1 AND YZ))=JG2,JG2,0);
NOTEXTX2:DRAWLINE(B1=2 AND YZ,JG1,REF(JG1,BARSLAST(B1=2 AND YZ))=JG2,JG2,0);
NOTEXTX3:DRAWLINE(B1=3 AND YZ,JG1,REF(JG1,BARSLAST(B1=3 AND YZ))=JG2,JG2,0);
NOTEXTX4:DRAWLINE(B1=4 AND YZ,JG1,REF(JG1,BARSLAST(B1=4 AND YZ))=JG2,JG2,0);
NOTEXTX5:DRAWLINE(B1=5 AND YZ,JG1,REF(JG1,BARSLAST(B1=5 AND YZ))=JG2,JG2,0);
NOTEXTX6:DRAWLINE(B1=6 AND YZ,JG1,REF(JG1,BARSLAST(B1=6 AND YZ))=JG2,JG2,0);
NOTEXTX7:DRAWLINE(B1=7 AND YZ,JG1,REF(JG1,BARSLAST(B1=7 AND YZ))=JG2,JG2,0);
NOTEXTX8:DRAWLINE(B1=8 AND YZ,JG1,REF(JG1,BARSLAST(B1=8 AND YZ))=JG2,JG2,0);
NOTEXTX9:DRAWLINE(B1=9 AND YZ,JG1,REF(JG1,BARSLAST(B1=9 AND YZ))=JG2,JG2,0);
NOTEXTX10:DRAWLINE(B1=10 AND YZ,JG1,REF(JG1,BARSLAST(B1=10 AND YZ))=JG2,JG2,0);
NOTEXTX11:DRAWLINE(B1=11 AND YZ,JG1,REF(JG1,BARSLAST(B1=11 AND YZ))=JG2,JG2,0);
NOTEXTX12:DRAWLINE(B1=12 AND YZ,JG1,REF(JG1,BARSLAST(B1=12 AND YZ))=JG2,JG2,0);
NOTEXTX13:DRAWLINE(B1=13 AND YZ,JG1,REF(JG1,BARSLAST(B1=13 AND YZ))=JG2,JG2,0);
NOTEXTX14:DRAWLINE(B1=14 AND YZ,JG1,REF(JG1,BARSLAST(B1=14 AND YZ))=JG2,JG2,0);
NOTEXTX15:DRAWLINE(B1=15 AND YZ,JG1,REF(JG1,BARSLAST(B1=15 AND YZ))=JG2,JG2,0);

通达信相同价位开收最高最低连线主图指标公式

相关文章