在线检测未来函数

通达信疯牛主图指标公式

来源:Internet,编辑:股旁网,2021-05-28

金叉疯牛: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),LINETHICK2,COLORWHITE;
界:=MA(CLOSE,27);
DRAWBAND(金叉疯牛,RGB(255,0,0),界,RGB(0,255,0));
VAR1:=AMOUNT/VOL/100;
VAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3:=SUM(AMOUNT,5)/VAR1/100;
VAR4:=SUM(AMOUNT,13)/VAR1/100;
VAR5:=SUM(AMOUNT,34)/VAR1/100;
五日成本:=DMA(VAR2,VOL/VAR3);
十三日成本:=DMA(VAR2,VOL/VAR4);
牛熊分界: DMA(VAR2,VOL/VAR5),COLORFF00FF,LINETHICK3;
行情启动支撑线:IF(C>200,C,DMA(VAR2,VOL/CAPITAL)),COLORWHITE,LINETHICK3;
疯牛强势分界线:IF(C>200,C,DMA(VAR2,VOL/CAPITAL))*1.1,COLORYELLOW,LINETHICK3;
日线:=CLOSE;
主力赢利25持仓:=WINNER(C/1.25)*100,LINETHICK0,COLORFF00FF;
主线:=EMA(EMA(C,1),5);
本:=EMA(HHV(主线,5),1);
急:=EMA(HHV(本,21),1);
稳:=EMA(HHV(急,21),2);
投:=EMA(HHV(稳,21),3);
散:=EMA(HHV(投,21),4);
集:=EMA(HHV(散,21),5);
持股线:=MA(C,26);
VAR10:=EMA(SLOPE(EMA(CLOSE,20),10)*34+CLOSE,30);
VAR11:=EMA(VAR10,3);
VAR12:=EMA(VAR11,3);
VAR13:=EMA(VAR12,3);
VAR14:=EMA(VAR13,3);
VA15:=EMA(VAR14,3);
VAR15:=EMA(VA15,3);
VA16:=EMA(VAR15,3);
VAR16:=EMA(VA16,3);
VAR17:=EMA(VAR16,3);
VARA:=BARSLAST(CROSS(CLOSE,VAR17));
VARB:=BARSLAST(CROSS(VAR17,CLOSE));
持仓波段:=IF(CLOSE<VAR17 AND CLOSE<REF(CLOSE,VARB),REF(CLOSE,VARB),REF(CLOSE,VARB));
STICKLINE(CLOSE<VAR17 AND CLOSE<REF(CLOSE,VARB),REF(CLOSE,VARB),界,0,1),COLOR00FF00,LINETHICK1;
卷帘操作:=IF(CLOSE>VAR17 AND CLOSE>REF(CLOSE,VARA),REF(CLOSE,VARA),REF(CLOSE,VARA));
STICKLINE(CLOSE>VAR17 AND CLOSE>REF(CLOSE,VARA),REF(CLOSE,VARA),界,0,1),COLORFF00FF,LINETHICK1;
垂帘休息:=IF(CLOSE>VAR17 AND CLOSE<REF(CLOSE,VARA),REF(CLOSE,VARA),REF(CLOSE,VARA));
STICKLINE(CLOSE>VAR17 AND CLOSE<REF(CLOSE,VARA),REF(CLOSE,VARA),REF(CLOSE,VARA),6,1);
清仓波段:=IF(CLOSE<VAR17,REF(CLOSE,VARB),REF(CLOSE,VARB));
STICKLINE(CLOSE<VAR17,REF(CLOSE,VARB),REF(CLOSE,VARB),16,2),COLOR00FF00,LINETHICK4;
STICKLINE(CLOSE>VAR17,REF(CLOSE,VARA),REF(CLOSE,VARA),16,2),COLORFF00FF,LINETHICK4;
STICKLINE(C>=O,H,L,0,-1),COLORRED;
ANGEL:=EMA(C,2);
DEVIL:=EMA(SLOPE(C,21)*20+C,42);
疯牛马线:EMA(HHV(集,21),6),COLOR00FF00,LINETHICK3;
疯牛压力平台:HHV((H+L)/2,120),COLORFF0080,LINETHICK3;
VAR1A:=CROSS(MA(CLOSE,5),MA(CLOSE,30));
DRAWTEXT(VAR1A AND CLOSE>MA(CLOSE,250) AND 主力赢利25持仓>20,界-1,'■'),COLORWHITE;
XG1:=CROSS(日线,疯牛压力平台);
STICKLINE(XG1,H,L,0,1),COLOR0089FF;
STICKLINE(XG1,C,O,3,0),COLOR0089FF;
XG2:=CROSS(日线,疯牛马线);
STICKLINE(XG2,L,H,0,0),COLOR0000AA;
STICKLINE(XG2,CLOSE,OPEN,0,0),COLORFF00FF;
STICKLINE(XG2,CLOSE,OPEN,3,0),COLORFF00FF;
DRAWTEXT(CROSS(日线,疯牛马线) ,疯牛压力平台*1.22,'强'),COLORYELLOW;
DRAWTEXT(CROSS(日线,疯牛马线) ,疯牛压力平台*1.12,'突'),COLORYELLOW;
XG3:=CROSS(金叉疯牛,疯牛马线);

通达信疯牛主图指标公式

 

相关文章