在线检测未来函数

通达信零点BBIBOLL主图指标公式

来源:Internet,编辑:股旁网,2021-06-02

N:=10;
M:=3;
XA_1:=CLOSE;
bbiboll:(ma(XA_1,3)+MA(XA_1,6)+MA(XA_1,12)+MA(XA_1,24))/4;
UPR:BBIBOLL+M*stD(BBIBOLL,N);
DWN:BBIBOLL-M*STD(BBIBOLL,N);
XA_2:=CLOSE=HHV(CLOSE,13);
XA_3:=BArslAST(FILTER(crOSS(0.8,XA_2),2))+1;
高点:REF(CLOSE,XA_3),POINTDOT,COLORMAGENTA;
突破:CROSS(CLOSE,REF(高点,1)),NODRAW,COLORYELLOW;
STICKLINE(XA_3<=6,高点,高点,3,0),COLORMAGENTA;
DRAWTEXT(突破,LOW,668),COLORYELLOW;
XA_4:=CLOSE=LLV(CLOSE,13);
XA_5:=BARSLAST(FILTER(CROSS(0.8,XA_4),2))+1;
低点:REF(CLOSE,XA_5),POINTDOT,COLORGREEN;
STICKLINE(XA_5<=6,低点,低点,3,0),COLORGREEN;
XA_6:=REF(CLOSE,1);
XA_7:=SMA(MAX(CLOSE-XA_6,0),3,1)/SMA(Abs(CLOSE-XA_6),3,1)*100;
XA_8:=ema(CLOSE,3);
XA_9:=EMA(CLOSE,21);
DRAWTEXT(CROSS(XA_8,XA_9),LOW*0.99,95),COLORRED;
DRAwrECTREL(0,480,205,589,RGB(10,1,30));
XA_10:=SUM(IF(CLOSE>REF(CLOSE,1),vol,0),FROMOPEN);
XA_11:=-SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),FROMOPEN);
XA_12:=XA_10+XA_11;
DRAWBAND(XA_12,RGB(150,0,150),0,RGB(0,100,0)),NODRAW;
资金流量:XA_12,NODRAW;
资金比:XA_12/SUM(VOL,FROMOPEN)*100,NODRAW;
XA_13:=IF(资金比>=0,(资金比+100)/2,100-ABS((资金比-100)/2));
XA_14:=(NVI*0.5+REF(NVI,1)*0.33+REF(NVI,2)*0.17)*SUM(CLOSE,FROMOPEN)/FROMOPEN;
XA_15:=SUM(IF(CLOSE>REF(CLOSE,1),XA_14*VOL,0),FROMOPEN);
XA_16:=-SUM(IF(CLOSE<REF(CLOSE,1),XA_14*VOL,0),FROMOPEN);
攻击流量:XA_15+XA_16,NODRAW;
NOTEXT攻击线:攻击流量,NODRAW;
攻击比:攻击流量/SUM(VOL,FROMOPEN)*100,NODRAW,COLORRED;
XA_17:=IF(攻击比>=0,攻击比+50,100-ABS(攻击比-50));
DRAWTEXT_FIX(1,0.5,0,20,688),COLORRED;
DRAWRECTREL(20,570,180,540,RGB(0,75,200));
DRAWRECTREL(20,570,30,540,RGB(0,250,50));
DRAWRECTREL(20,570,15+CONST(XA_13*150/100),540,RGB(200,50,0));
DRAWTEXT_FIX(1,0,0.5,0,STRCAT(STRCAT(689,CON2STR(XA_13,2)),690)),COLORYELLOW;
DRAWTEXT_FIX(1,5,0.9,0,EXTERNSTR(0,5)),COLORRED;
DRAWTEXT_FIX(1,0,0.2,0,EXTERNSTR(0,5)),COLORRED;
XA_18:=SMA(MAX(CLOSE-REF(CLOSE,1),0),3,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),3,1)*100;
DRAWTEXT(CROSS(88,XA_18) AND MA(CLOSE,3)>EMA(CLOSE,3),HIGH+0.3,96),COLORGREEN;
DRAWTEXT(REF(CLOSE,BARSLAST(REF(CROSS(macd.dif,MacD.DEA),1))+1)>CLOSE AND REF(MACD.DIF,BARSLAST(REF(CROSS(MACD.DIF,MACD.DEA),1))+1)<MACD.DIF AND CROSS(MACD.DIF,MACD.DEA)>0,LOW-0.02,97),COLORRED;
DRAWTEXT(REF(CLOSE,BARSLAST(REF(CROSS(kdj.K,kdJ.D),1))+1)>CLOSE AND REF(KDJ.K,BARSLAST(REF(CROSS(KDJ.K,KDJ.D),1))+1)<KDJ.K AND CROSS(KDJ.K,KDJ.D),LOW-0.1,98),COLORBLUE;
DRAWTEXT(REF(CLOSE,BARSLAST(REF(CROSS(rsi.RSI1,RSI.RSI2),1))+1)>CLOSE AND REF(RSI.RSI1,BARSLAST(REF(CROSS(RSI.RSI1,RSI.RSI2),1))+1)<RSI.RSI1 AND CROSS(RSI.RSI1,RSI.RSI2)>0,LOW-0.18,99);
DRAWTEXT(REF(CLOSE,BARSLAST(REF(CROSS(MACD.DEA,MACD.DIF),1))+1)<CLOSE AND REF(MACD.DIF,BARSLAST(REF(CROSS(MACD.DEA,MACD.DIF),1))+1)>MACD.DIF AND CROSS(MACD.DEA,MACD.DIF)>0,HIGH+0.16,100),COLORGREEN;
DRAWTEXT(REF(CLOSE,BARSLAST(REF(CROSS(KDJ.D,KDJ.K),1))+1)<CLOSE AND REF(KDJ.K,BARSLAST(REF(CROSS(KDJ.D,KDJ.K),1))+1)>KDJ.K AND CROSS(KDJ.D,KDJ.K)>0,HIGH+0.08,101);
XA_19:=EMA(((2*CLOSE+HIGH+LOW)/4-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8);
XA_20:=EMA(XA_19,5);
XA_21:=REFDATE(REF(HHV(HIGH,96),5),DATE);
XA_22:=REFDATE(REF(LLV(LOW,96),5),DATE);
XA_23:=(XA_21+XA_22)/2;
上轨:IF(XA_19>0 AND XA_19-XA_20<=0,XA_21,XA_21),COLORGREEN,LINETHICK3;
支撑:IF(XA_19>0 AND XA_19-XA_20<=0,XA_23,XA_23),COLORGREEN,LINETHICK2;
下轨:IF(XA_19>0 AND XA_19-XA_20<=0,XA_22,XA_22),COLORGREEN,LINETHICK2;
逃顶:IF(XA_19>0 AND XA_19-XA_20>0,XA_21,DRAWNULL),COLORRED,LINETHICK2;
压力:IF(XA_19>0 AND XA_19-XA_20>0,XA_23,DRAWNULL),COLORRED,LINETHICK2;
抄底:IF(XA_19>0 AND XA_19-XA_20>0,XA_22,DRAWNULL),COLORRED,LINETHICK2;
XA_24:=EMA(CLOSE,3)-EMA(CLOSE,6)-(EMA(CLOSE,6)-EMA(CLOSE,12))*(-100);
XA_25:=EMA(XA_24,3);
XA_26:=CROSS(XA_24,XA_25);
XA_27:=CROSS(XA_25,XA_24);
XA_28:=COST(99.900002);
XA_29:=COST(0.1);
XA_30:=(XA_28-XA_29)/50;
XA_31:=XA_28-XA_30;
XA_32:=XA_28-2*XA_30;
XA_33:=XA_28-3*XA_30;
XA_34:=XA_28-4*XA_30;
XA_35:=XA_28-5*XA_30;
XA_36:=XA_28-6*XA_30;
XA_37:=XA_28-7*XA_30;
XA_38:=XA_28-8*XA_30;
XA_39:=XA_28-9*XA_30;
XA_40:=XA_28-10*XA_30;
XA_41:=XA_28-11*XA_30;
XA_42:=XA_28-12*XA_30;
XA_43:=XA_28-13*XA_30;
XA_44:=XA_28-14*XA_30;
XA_45:=XA_28-15*XA_30;
XA_46:=XA_28-16*XA_30;
XA_47:=XA_28-17*XA_30;
XA_48:=XA_28-18*XA_30;
XA_49:=XA_28-19*XA_30;
XA_50:=XA_28-20*XA_30;
XA_51:=XA_28-21*XA_30;
XA_52:=XA_28-22*XA_30;
XA_53:=XA_28-23*XA_30;
XA_54:=XA_28-24*XA_30;
XA_55:=XA_28-25*XA_30;
XA_56:=XA_28-26*XA_30;
XA_57:=XA_28-27*XA_30;
XA_58:=XA_28-28*XA_30;
XA_59:=XA_28-29*XA_30;
XA_60:=XA_28-30*XA_30;
XA_61:=XA_28-31*XA_30;
XA_62:=XA_28-32*XA_30;
XA_63:=XA_28-33*XA_30;
XA_64:=XA_28-34*XA_30;
XA_65:=XA_28-35*XA_30;
XA_66:=XA_28-36*XA_30;
XA_67:=XA_28-37*XA_30;
XA_68:=XA_28-38*XA_30;
XA_69:=XA_28-39*XA_30;
XA_70:=XA_28-40*XA_30;
XA_71:=XA_28-41*XA_30;
XA_72:=XA_28-42*XA_30;
XA_73:=XA_28-43*XA_30;
XA_74:=XA_28-44*XA_30;
XA_75:=XA_28-45*XA_30;
XA_76:=XA_28-46*XA_30;
XA_77:=XA_28-47*XA_30;
XA_78:=XA_28-48*XA_30;
XA_79:=XA_28-49*XA_30;
XA_80:=WINNER(XA_28)*100-WINNER(XA_31)*100;
XA_81:=WINNER(XA_31)*100-WINNER(XA_32)*100;
XA_82:=WINNER(XA_32)*100-WINNER(XA_33)*100;
XA_83:=WINNER(XA_33)*100-WINNER(XA_34)*100;
XA_84:=WINNER(XA_34)*100-WINNER(XA_35)*100;
XA_85:=WINNER(XA_35)*100-WINNER(XA_36)*100;
XA_86:=WINNER(XA_36)*100-WINNER(XA_37)*100;
XA_87:=WINNER(XA_37)*100-WINNER(XA_38)*100;
XA_88:=WINNER(XA_38)*100-WINNER(XA_39)*100;
XA_89:=WINNER(XA_39)*100-WINNER(XA_40)*100;
XA_90:=WINNER(XA_40)*100-WINNER(XA_41)*100;
XA_91:=WINNER(XA_41)*100-WINNER(XA_42)*100;
XA_92:=WINNER(XA_42)*100-WINNER(XA_43)*100;
XA_93:=WINNER(XA_43)*100-WINNER(XA_44)*100;
XA_94:=WINNER(XA_44)*100-WINNER(XA_45)*100;
XA_95:=WINNER(XA_45)*100-WINNER(XA_46)*100;
XA_96:=WINNER(XA_46)*100-WINNER(XA_47)*100;
XA_97:=WINNER(XA_47)*100-WINNER(XA_48)*100;
XA_98:=WINNER(XA_48)*100-WINNER(XA_49)*100;
XA_99:=WINNER(XA_49)*100-WINNER(XA_50)*100;
XA_100:=WINNER(XA_50)*100-WINNER(XA_51)*100;
XA_101:=WINNER(XA_51)*100-WINNER(XA_52)*100;
XA_102:=WINNER(XA_52)*100-WINNER(XA_53)*100;
XA_103:=WINNER(XA_53)*100-WINNER(XA_54)*100;
XA_104:=WINNER(XA_54)*100-WINNER(XA_55)*100;
XA_105:=WINNER(XA_55)*100-WINNER(XA_56)*100;
XA_106:=WINNER(XA_56)*100-WINNER(XA_57)*100;
XA_107:=WINNER(XA_57)*100-WINNER(XA_58)*100;
XA_108:=WINNER(XA_58)*100-WINNER(XA_59)*100;
XA_109:=WINNER(XA_59)*100-WINNER(XA_60)*100;
XA_110:=WINNER(XA_60)*100-WINNER(XA_61)*100;
XA_111:=WINNER(XA_61)*100-WINNER(XA_62)*100;
XA_112:=WINNER(XA_62)*100-WINNER(XA_63)*100;
XA_113:=WINNER(XA_63)*100-WINNER(XA_64)*100;
XA_114:=WINNER(XA_64)*100-WINNER(XA_65)*100;
XA_115:=WINNER(XA_65)*100-WINNER(XA_66)*100;
XA_116:=WINNER(XA_66)*100-WINNER(XA_67)*100;
XA_117:=WINNER(XA_67)*100-WINNER(XA_68)*100;
XA_118:=WINNER(XA_68)*100-WINNER(XA_69)*100;
XA_119:=WINNER(XA_69)*100-WINNER(XA_70)*100;
XA_120:=WINNER(XA_70)*100-WINNER(XA_71)*100;
XA_121:=WINNER(XA_71)*100-WINNER(XA_72)*100;
XA_122:=WINNER(XA_72)*100-WINNER(XA_73)*100;
XA_123:=WINNER(XA_73)*100-WINNER(XA_74)*100;
XA_124:=WINNER(XA_74)*100-WINNER(XA_75)*100;
XA_125:=WINNER(XA_75)*100-WINNER(XA_76)*100;
XA_126:=WINNER(XA_76)*100-WINNER(XA_77)*100;
XA_127:=WINNER(XA_77)*100-WINNER(XA_78)*100;
XA_128:=WINNER(XA_78)*100-WINNER(XA_79)*100;
XA_129:=WINNER(XA_79)*100-WINNER(XA_29)*100;
STICKLINE(ISLASTBAR,XA_28,XA_28,XA_80*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_31,XA_31,XA_80*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_32,XA_32,XA_81*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_33,XA_33,XA_82*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_34,XA_34,XA_83*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_35,XA_35,XA_84*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_36,XA_36,XA_85*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_37,XA_37,XA_86*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_38,XA_38,XA_87*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_39,XA_39,XA_88*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_40,XA_40,XA_89*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_41,XA_41,XA_90*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_42,XA_42,XA_91*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_43,XA_43,XA_92*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_44,XA_44,XA_93*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_45,XA_45,XA_94*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_46,XA_46,XA_95*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_47,XA_47,XA_96*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_48,XA_48,XA_97*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_49,XA_49,XA_98*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_50,XA_50,XA_99*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_51,XA_51,XA_100*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_52,XA_52,XA_101*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_53,XA_53,XA_102*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_54,XA_54,XA_103*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_55,XA_55,XA_104*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_56,XA_56,XA_105*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_57,XA_57,XA_106*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_58,XA_58,XA_107*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_59,XA_59,XA_108*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_60,XA_60,XA_109*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_61,XA_61,XA_110*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_62,XA_62,XA_111*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_63,XA_63,XA_112*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_64,XA_64,XA_113*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_65,XA_65,XA_114*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_66,XA_66,XA_115*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_67,XA_67,XA_116*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_68,XA_68,XA_117*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_69,XA_69,XA_118*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_70,XA_70,XA_119*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_71,XA_71,XA_120*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_72,XA_72,XA_121*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_73,XA_73,XA_122*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_74,XA_74,XA_123*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_75,XA_75,XA_124*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_76,XA_76,XA_125*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_77,XA_77,XA_126*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_78,XA_78,XA_127*100,0),COLORGRAY;
STICKLINE(ISLASTBAR,XA_29,XA_29,XA_129*100,0),COLORGRAY;

通达信零点BBIBOLL主图指标公式

相关文章