在线检测未来函数

通达信三牛犇腾主图指标公式

来源:Internet,编辑:股旁网,2021-06-10

本文指标含有选股公式如下:

三牛犇腾主图之红钻选股指标公式

昨收:DYNAINFO(3),NODRAW;
今开:DYNAINFO(4),NODRAW;
今板:DYNAINFO(3)*1.099,NODRAW;
DRAWBAND(ma(CLOSE,5),RGB(125,0,0),MA(CLOSE,10),RGB(0,111,0));
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
角度线:MA(CLOSE,5),DOTLINE,COLORGREEN;
IF(角度线>REF(角度线,1),角度线,DRAWNULL),COLORWHITE,LINETHICK2;
MA10:MA(CLOSE,10),DOTLINE,COLORLIBLUE;
IF(MA10>REF(MA10,1),MA10,DRAWNULL),COLORYELLOW,LINETHICK2;
MA60:MA(CLOSE,60),POINTDOT,COLORGRAY,LINETHICK3;
IF(MA60>REF(MA60,1),MA60,DRAWNULL),COLORCYAN,LINETHICK2;
X_1:=ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*57.299999;
X_2:=角度线>REF(角度线,1) AND X_1>=60;
IF(X_2,角度线,DRAWNULL),COLORLIMAGENTA,LINETHICK3;
X_3:=IF(INBLOCK(1),0.2,IF(INBLOCK(2),0.2,IF(INBLOCK(3),0.05,0.1)));
stICKLINE(CLOSE>=ZTPRICE(REF(CLOSE,1),X_3) AND CLOSE=HIGH,CLOSE,OPEN,2.7,0),COLORYELLOW;
STICKLINE(CLOSE<=DTPRICE(REF(CLOSE,1),X_3) AND CLOSE=LOW,CLOSE,OPEN,2.7,0),COLORWHITE;
收盘价:REFDATE(CLOSE,DATE),DOTLINE,COLORCYAN;
X_4:=MA(CLOSE,5);
DRAWTEXT_FIX(1,0.98,20,1,12),COLOR666666;
X_5:=ATAN((X_4/REF(X_4,1)-1)*100)*57.299999>=60;
X_6:=REF(X_5,1)<X_5 AND X_5;
攻击力度:ATAN((X_4/REF(X_4,1)-1)*100)*57.299999,NODRAW;
DRAWTEXT_FIX(ISLASTBAR,0.835,0,1,5),COLORWHITE;
DRAWNUMBER_FIX(ISLASTBAR,0.88,0,1,攻击力度),COLORMAGENTA;
X_7:=ema(EMA(CLOSE,9),9);
X_8:=(X_7-REF(X_7,1))/REF(X_7,1)*1000;
X_9:=crOSS(X_8,0);
X_10:=IF(X_8<0,X_8,0);
X_11:=IF(X_9,5,0);
X_12:=IF(X_8>REF(X_8,1) AND X_8>0,X_8,0);
X_13:=100*WINNER(CLOSE*0.95);
X_14:=IF(X_13>50 AND COST(85)<CLOSE AND X_8>0,X_8,0);
IF(角度线>REF(角度线,1) AND (X_12 OR X_11) AND X_5>45,角度线,DRAWNULL),COLORRED,LINETHICK2;
IF(角度线>REF(角度线,1) AND X_14 AND X_5>45,角度线,DRAWNULL),COLORMAGENTA,LINETHICK2;
X_15:=EMA(CLOSE,9);
X_16:=(CLOSE+OPEN)/2;
X_17:=MA(CLOSE,3);
X_18:=MA(CLOSE,2*3);
X_19:=MA(CLOSE,3*3);
X_20:=MA(CLOSE,4*3);
X_21:=MA((X_17+X_18+X_19+X_20)/4,5);
X_22:=EMA(EMA(EMA(CLOSE,2),2),2);
X_23:=EMA(X_15*1.14,5);
X_24:=EMA(CLOSE,3);
X_25:=CROSS(X_24,X_23);
DRAWICON(X_25,角度线*0.895,25);
X_26:=STRCAT(HYBLOCK,6);
X_27:=STRCAT(X_26,DYBLOCK);
X_28:=STRCAT(X_27,6);
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(X_28,GNBLOCK)),COLOR00C0C0;

通达信三牛犇腾主图指标公式

相关文章