在线检测未来函数

通达信右侧交易主图指标公式

来源:Internet,编辑:股旁网,2021-06-17

P1:=5;
P2:=10;
P3:=20;
P4:=60;
MA1:MA(CLOSE,P1);
MA2:MA(CLOSE,P2);
MA3:MA(CLOSE,P3);
MA4:MA(CLOSE,P4);
X_1:=(CLOSE/REF(CLOSE,1)-1)*100>9.5;
X_2:=BARSLAST((CLOSE/REF(CLOSE,1)-1)*100>9.5);
最后涨停距今数:X_2,NODRAW,COLORWHITE;
X_3:=BARSLAST(X_1);
X_4:=REF(HIGH,X_3)-REF(LOW,X_3);
STICKLINE(CLOSE,REF(LOW,X_3)+X_4*0.5,REF(LOW,X_3)+X_4*0.5,1,0),COLORLIMAGENTA;
STICKLINE(CLOSE,REF(LOW,X_3),REF(LOW,X_3),2,0),COLORWHITE;
STICKLINE(X_1,OPEN,CLOSE,2.5,0),COLOR0000E5;
STICKLINE(X_1,OPEN,CLOSE,2.3,0),COLOR335555;
STICKLINE(X_1,OPEN,CLOSE,1.7,0),COLOR338888;
STICKLINE(X_1,OPEN,CLOSE,1.2,0),COLOR33AAAA;
STICKLINE(X_1,OPEN,CLOSE,0.6,0),COLOR33CCCC;
STICKLINE(X_1,OPEN,CLOSE,0.1,0),COLOR33EEEE;
STICKLINE(X_2=3,LOW*0.97,LOW*0.98,3,0),COLORRED;
STICKLINE(X_2=8,LOW*0.97,LOW*0.98,3,0),COLORYELLOW;
X_5:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_6:=EMA(X_5,9);
X_7:=2*(X_5-X_6);
X_8:=BARSLAST((CLOSE/REF(CLOSE,1)-1)*100>9.5);
X_9:=IF(REF(LOW,X_8)>REF(HIGH,X_8+1),REF(CLOSE,X_8+1),REF(OPEN,X_8));
X_10:=BETWEEN(X_8,2,13);
X_11:=CLOSE>=X_9 AND BETWEEN(LOW/X_9,1.035,0.97);
X_12:=VOL<REF(VOL,1) AND VOL<MA(VOL,5);
X_13:=ABS(CLOSE/OPEN-1)*100<5;
X_14:=LLV(CLOSE,X_8)>=X_9;
X_15:=X_7>(-1);
X_16:=X_10 AND X_11 AND X_12 AND X_13 AND X_14 AND X_15;
X_17:=MA(CLOSE,5)>=X_9 AND CLOSE>X_9 AND CLOSE>=MA(CLOSE,5) AND REF(CLOSE,1)<=REF(MA(CLOSE,5),1) AND LLV(LOW,X_8)<X_9*1.045;
X_18:=REF(X_10,1)>0 AND X_17;
STICKLINE(X_18 AND NOT(X_1),OPEN,CLOSE,2.4,0),COLOR000055;
STICKLINE(X_18 AND NOT(X_1),OPEN,CLOSE,1.2,0),COLOR0000AA;
STICKLINE(X_18 AND NOT(X_1),OPEN,CLOSE,0.6,0),COLOR0000CC;
STICKLINE(X_18,OPEN,CLOSE,0.1,0),COLORYELLOW;
X_19:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100<(-9.95);
STICKLINE(X_19,OPEN,CLOSE,2.4,0),COLOR555500;
STICKLINE(X_19,OPEN,CLOSE,1.8,0),COLOR888800;
STICKLINE(X_19,OPEN,CLOSE,1.2,0),COLORAAAA00;
STICKLINE(X_19,OPEN,CLOSE,0.6,0),COLORCCCC00;
STICKLINE(X_19,OPEN,CLOSE,0.1,0),COLOREEEE00;

通达信右侧交易主图指标公式

 

相关文章