在线检测未来函数

通达信阶段前高前低划线主图指标公式

来源:Internet,编辑:股旁网,2021-06-28

ma5:MA(C,5),COLORYELLOW;
NOTEXT5:IF((C<=MA5 OR MA5<=REF(MA5,1)),MA5,DRAWNULL),COLORFFFF00;
TY:=H;
TY2:=L;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BacKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY2,10)=LLV(TY2,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
前期高位:REF(H,BArslAst(HD)),COLORYELLOW,POINTDOT;
STICKLINE(H,前期高位,前期高位,8,0),COLORYELLOW;
前期低位:REF(L,BARSLAST(LD)),COLORFF00FF,POINTDOT;
STICKLINE(L,前期低位,前期低位,8,0),COLORFF00FF;
DRAWNUMBER(FILTER(C1,10),HIGH,H),DRAWAbovE;
{DRAWNUMBER(FILTER(C2,20),LOW,L),DRAWABOVE;}
{DRAWNUMBER(FILTER(C1,10),H,H);}
DRAWNUMBER(FILTER(C2,10),L,L);
DRAWTEXT(ISLASTBAR,(前期高位),STRCAT('',CON2STR(前期高位,2))),COLORWHITE;
DRAWTEXT(ISLASTBAR,(前期低位),STRCAT('',CON2STR(前期低位,2))),COLORWHITE;

通达信阶段前高前低划线主图指标公式

相关文章