在线检测未来函数

大智慧擒龙股比主图指标公式

来源:Internet,编辑:股旁网,2021-06-30

{使用说明:大道至简,趋势为王。短期、中期、长期趋势一目了然,蓝色买点清晰可见。}

ma(CLOSE,152),COLORBB11BB,LINETHICK7;
B1:=MA(CLOSE,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1) ;
CC:B2;
partline(CC,CC>=ref(CC,1),rgb(255,0,0),CC<ref(CC,1),rgb(0,255,0)),LINETHICK2;
SMA2:=MA(B2,5);
FILLRGN(b2,sma2,b2>sma2),colorred;
MA7:ema(Close,30),coloryellow;
MA8:EMA(Close,35),coloryellow;
MA9:EMA(Close,40),coloryellow;
MA10:EMA(Close,45),coloryellow;
MA11:EMA(Close,50),coloryellow;
MA12:EMA(Close,60),coloryellow;
stICKLINE(V/REF(V,1)>1.9,OPEN,CLOSE,7.5,0),COLORyellow;
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(Abs(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND crOSS(A8,MA(A8,2));
STICKLINE(买,OPEN,CLOSE,6,0),COLORblue;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,O,C,6,0), COLORRED ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,L,C,0,0), COLORRED;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=40 ,O,C-(C-O)/2,6,0),COLORBLUE ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=40 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=40 ,O,C-(C-O)/2,6,0), COLORBLUE ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=40 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=50 ,O,C-(C-O)/3,6,0),COLORYELLOW;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=50 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=50 ,O,C-(C-O)/3,6,0),COLORYELLOW ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=50 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1)AND 100*WINNER(C)-REF(100*WINNER(C),1)>=50 ,O,C-(C-O)*2/3,6,0),COLORBLUE;
STICKLINE(C=30 ,O,C,2.5,0),COLOR00FF00 ;
STICKLINE(C=30 ,H,O,0,0), COLOR00FF00 ;
STICKLINE(C=30 ,L,C,0,0), COLOR00FF00;
STICKLINE(C>REF(C,1) AND C=O AND (C-REF(C,1))/REF(C,1)>0.0991 AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,O*1.02,C,2.5,0), COLORRED ;
STICKLINE(C>REF(C,1) AND C=O AND (C-REF(C,1))/REF(C,1)>0.0991 AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,H,C,0,0), COLORRED ;
STICKLINE(C>REF(C,1) AND C=O AND (C-REF(C,1))/REF(C,1)>0.0991 AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,L,C,0,0), COLORRED;
STICKLINE(C>REF(C,1) AND C=O AND (C-REF(C,1))/REF(C,1)>0.0991 AND 100*WINNER(C)-REF(100*WINNER(C),1)>=30 ,H,C,0,0), COLORRED ;
drawtextabs(5,10,bkname);
DRAWTEXTABS(1400,43,'[三线向上,买入]'),LINETHICK2,coloryellow;
gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
STICKLINE(DISPSTATUS=2and c>=今日阻力,今日阻力,今日阻力,20,0),Colorwhite,linethick3;
STICKLINE(DISPSTATUS=2and c<今日阻力,今日阻力,今日阻力,20,0),Colorwhite,linethick3;
STICKLINE(DISPSTATUS=2and c>=今日支撑,今日支撑,今日支撑,20,0),Colorwhite,linethick3;
STICKLINE(DISPSTATUS=2and c<今日支撑,今日支撑,今日支撑,20,0),Colorwhite,linethick3;
DRAWTEXTREL(770,5,'今日支撑:'+NUMTOSTRN(今日支撑 ,2 )),Colorred;
DRAWTEXTREL(630,5,'今日阻力:'+NUMTOSTRN(今日阻力 ,2 )),ColorGREEN;

大智慧擒龙股比主图指标公式

相关文章