在线检测未来函数

同花顺妖动均线指标公式

来源:Internet,编辑:股旁网,2021-07-02

High1:=IF(ISNULL(HIGH),CLOSE,HIGH);
LOW1:=IF(ISNULL(LOW),CLOSE,LOW);
open1:=IF(ISNULL(OPEN),CLOSE,OPEN);
VAR1:=SMA(maX(MAX(HIGH1-LOW1,Abs(HIGH1-REF(CLOSE,1))),ABS(LOW1-REF(CLOSE,1))),14,1);
VAR2:=HIGH1-REF(HIGH1,1);
VAR3:=REF(LOW1,1)-LOW1;
VAR4:=SMA(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),12,1);
VAR5:=SMA(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),12,1);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=SMA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,12,1);
VAR9:=(VAR8+REF(VAR8,5))/2;
VARA:=SUM(HIGH1-OPEN1,12)/SUM(OPEN1-LOW1,12)*100;
VARB:=SUM(MAX(0,HIGH1-REF(CLOSE,1)),12)/SUM(MAX(0,REF(CLOSE,1)-LOW1),12)*100;
MO:=MONEY;
VO:=vol;
IF(VOL==0) VO:=VO[1];
VARD:=(3*HIGH1+LOW1+OPEN1+2*CLOSE)/7;
IF(MO==0)
{
VARC:=VARD;
MO:=VARC*VO/100;
}
ELSE
VARC:=MO/VO/100;
IF(ISNULL(VARC)==1 OR VARC==0) VARC:=VARC[1]; //加上这句就好了
VARE:=SUM(MO,5)/VARC/100;
VARF:=SUM(MO,13)/VARC/100;
VAR10:=SUM(MO,34)/VARC/100;
VAR11:=SUM(MO,209)/VARC/100;
VAR12:=REF(VO,1)+REF(VO,2)+REF(VO,3)+REF(VO,4);
shares:=SHGZG;
IF(shares==0) shares:=shares[1];
VAR13:=VAR12/(shares/100);
VAR14:=VO/(shares/100)*VARD+VAR13*REF(VARC,1);
GJ:C;
cyc5:=dma_(VARD,VO/VARE);
CYC13:=DMA_(VARD,VO/VARF);
CYC34:DMA_(VARD,VO/VAR10);
CYCW:DMA_(VARD,VO/(shares/100));
HJ_1:=DMA(ema(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
HJ_2:=EMA(HIGH,30)*1.15;
HJ_3:=EMA(HIGH,3)*1.03;
HJ_4:=EMA(LOW,3)*0.97;
HJ_5:=EMA(LOW,30)*0.85;
HJ_6:=IF((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.097,1,0);
妖股线:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3);
妖股初成:=(((crOSS(CLOSE,HJ_3) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.04) OR CROSS(妖股线,15)) AND CYCW>CYC34);
DRAWICON(妖股初成>0,LOW,1);

同花顺妖动均线指标公式

相关文章