在线检测未来函数

通达信红股十心主图指标公式

来源:Internet,编辑:股旁网,2021-07-08

{使用说明:上红下灰,向上拐点;上绿下蓝,向下拐点;红中有黄芯,KDJ金叉;绿中有红芯,KDJ死叉;全红,涨停;全蓝,跌停;上灰下蓝,高开低走;VMA13黄色表示强攻,绿色表示回调;★追财神——原则上K线变红时才追;开天眼——只适合做K线向上爬坡,波段初起时的股票

X_1:=INBLOCK(6);
DRAWTEXT_FIX(NOT(X_1),0,0,0,7),COLORYELLOW;
X_2:=DYBLOCK;
X_3:=STRCAT(8,X_2);
X_4:=HYBLOCK;
X_5:=ZSBLOCK;
X_6:=ZHBLOCK;
X_7:=STRCAT(X_3,X_4);
X_8:=STRCAT(X_7,X_5);
X_9:=STRCAT(X_8,X_6);
DRAWTEXT_FIX(X_1,0,0,0,X_9),COLORYELLOW;
DRAWTEXT_FIX(X_1,0.5,0,0,STRCAT(9,STRCAT(CON2STR(CAPITAL/1000000,1),10))),COLORGREEN;
DRAWTEXT_FIX(X_1,0.6,0,0,STRCAT(11,STRCAT(CON2STR(FINANCE(18),1),12))),COLORGREEN;
DRAWTEXT_FIX(X_1,0,0.04,0,13),COLORMAGENTA;
DRAWTEXT_FIX(X_1,0.05,0.04,0,GNBLOCK),COLORMAGENTA;
DRAWTEXT_FIX(X_1,0,0.08,0,14),COLORWHITE;
DRAWTEXT_FIX(X_1,0.05,0.08,0,FGBLOCK),COLORWHITE;
DRAWTEXT_FIX(X_1,0,0.12,0,STRCAT(15,STRCAT(CON2STR(FINANCE(43),1),16))),COLORWHITE;
DRAWTEXT_FIX(X_1,0.13,0.12,0,STRCAT(17,STRCAT(CON2STR(SUM(VOL,5)/CAPITAL*100,1),16))),COLORWHITE;
DRAWTEXT_FIX(X_1,0.23,0.12,0,STRCAT(18,STRCAT(CON2STR(VOL*100/CAPITAL,2),19))),COLORGREEN;
X_10:=CLOSE/REF(CLOSE,1)>=1.095;
X_11:=COUNT(X_10,BARSLAST(X_10+1));
X_12:=STRCAT(20,CON2STR(X_11,0));
X_13:=STRCAT(X_12,21);
X_14:=STRCAT(22,CON2STR(FINANCE(42),0));
X_15:=STRCAT(X_14,23);
X_16:=STRCAT(24,CON2STR(CONST(BARSLAST(X_10)),0));
X_17:=STRCAT(X_16,25);
X_18:=STRCAT(X_15,X_13);
X_19:=STRCAT(X_18,X_17);
X_20:=STRCAT(26,X_19);
DRAWTEXT_FIX(X_1,0,0.16,0,X_20),COLORYELLOW;
STICKLINE(OPEN>0,LOW,HIGH,0,0),COLORLIGRAY;
X_21:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
X_22:=(1-7/100)*DMA(CLOSE,X_21);
X_23:=(1+7/100)*DMA(CLOSE,X_21);
X_24:=MA((LOW+HIGH+CLOSE)/3,5);
X_25:=REFDATE(X_22,DATE);
X_26:=REFDATE(X_23,DATE);
X_27:=MEMA(CLOSE,5);
X_28:=ATAN((X_27/REF(X_27,1)-1)*100)*180/3.1416;
X_29:=IF(X_28>0,X_28,X_28);
X_30:=MA(CLOSE,5);
X_31:=CLOSE=HHV(CLOSE,4) AND (REF(CLOSE,1)>=REF(CLOSE,2) OR REF(CLOSE,1)>=REF(CLOSE,3)) OR REF(CLOSE,1)=HHV(CLOSE,4) AND CLOSE>=REF(CLOSE,2) OR REF(CLOSE,2)=HHV(CLOSE,4) AND REF(CLOSE,3)=LLV(CLOSE,4) AND CLOSE>=REF(CLOSE,1) OR REF(CLOSE,3)=HHV(CLOSE,4) AND CLOSE>=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_32:=CLOSE=HHV(CLOSE,4) AND REF(CLOSE,1)=LLV(CLOSE,4);
X_33:=REF(CLOSE,1)=LLV(CLOSE,4) AND CLOSE>=REF(CLOSE,2) OR REF(CLOSE,2)=LLV(CLOSE,4) AND REF(CLOSE,1)<=REF(CLOSE,3) AND REF(CLOSE,2)<REF(CLOSE,4) AND CLOSE>=REF(CLOSE,1);
X_34:=REF(CLOSE,1)=HHV(CLOSE,4) AND CLOSE<REF(CLOSE,2) OR (REF(CLOSE,2)=HHV(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,3) OR REF(CLOSE,3)=HHV(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,2)) AND REF(CLOSE,2)>=REF(CLOSE,4) AND CLOSE<REF(CLOSE,1);
X_35:=X_24>REF(X_24,1) AND REF(X_24,1)<REF(X_24,2);
X_36:=LOW<HHV(X_24,13) AND HIGH>HHV(X_24,13) AND CLOSE>REF(CLOSE,1) AND CLOSE>OPEN;
X_37:=X_36 AND COUNT(X_35,2);
X_38:=100*EMA(EMA(CLOSE-REF(CLOSE,1),6),6)/EMA(EMA(ABS(CLOSE-REF(CLOSE,1)),6),6);
X_39:=EMA(MA(CLOSE,13),13);
X_40:=FILTER((LLV(X_38,2)=LLV(X_38,7) AND COUNT(X_38<0,2) AND CROSS(X_38,MA(X_38,2)))=1,5);
X_41:=FILTER((HHV(X_38,2)=HHV(X_38,7) AND COUNT(X_38>50,2) AND CROSS(MA(X_38,2),X_38))=1,1);
X_42:=SMA(EMA((CLOSE-REF(CLOSE,1))/REF(CLOSE,1),5)*100,3,1)*10;
X_43:=FILTER((CROSS(X_42,0) OR CROSS(CLOSE,X_39) AND X_40)=1,3);
X_44:=MA(CLOSE,18)>=REF(MA(CLOSE,18),3) AND CROSS(CLOSE,MA(CLOSE,18));
X_45:=X_37 AND NOT(REF(X_37,1));
X_46:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
X_47:=SMA(X_46,3,1);
X_48:=SMA(X_47,3,1);
X_49:=3*X_47-2*X_48;
X_50:=CROSS(X_49,X_48);
X_51:=CROSS(X_48,X_49);
X_52:=X_43 OR X_44 AND X_40;
X_53:=X_43 OR X_44 AND X_33;
X_54:=X_43 OR X_44 AND X_32;
X_55:=X_32 AND X_40 OR (X_33 AND X_40);
X_56:=X_50 AND X_33 OR (X_50 AND X_32) OR (X_50 AND X_40);
STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,(-1)),COLORYELLOW;
STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,(-1)),COLORGREEN;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3.5,0),COLORFF7700;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3.5,0),COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLORRED;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
X_57:=CLOSE=LLV(CLOSE,4) AND (REF(CLOSE,1)<REF(CLOSE,2) OR REF(CLOSE,1)<REF(CLOSE,3)) OR REF(CLOSE,1)=LLV(CLOSE,4) AND CLOSE<REF(CLOSE,2) OR REF(CLOSE,2)=LLV(CLOSE,4) AND REF(CLOSE,1)=HHV(CLOSE,4) AND CLOSE<REF(CLOSE,1) OR REF(CLOSE,3)=LLV(CLOSE,4) AND CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
STICKLINE(X_57,OPEN,(OPEN+CLOSE)/2,3.5,0),COLOR009900;
STICKLINE(X_57,OPEN,(OPEN+CLOSE)/2,2.2,0),COLOR00BB00;
STICKLINE(X_57,OPEN,(OPEN+CLOSE)/2,1.5,0),COLOR00DD00;
STICKLINE(X_57,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORGREEN;
STICKLINE(X_33,OPEN,(OPEN+CLOSE)/2,3.5,0),COLOR999999;
STICKLINE(X_33,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;
STICKLINE(X_33,OPEN,(OPEN+CLOSE)/2,1.5,0),COLORDDDDDD;
STICKLINE(X_33,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORWHITE;
STICKLINE(X_50,OPEN,CLOSE,0.5,0),COLORYELLOW;
STICKLINE(X_51,OPEN,CLOSE,0.5,0),COLOR000099;
DRAWICON(X_45,LOW-0.02,7);
DRAWICON(X_52 OR X_53 OR X_54 OR X_55 OR X_56,LOW-0.02,1);
DRAWICON(X_51 OR X_41 OR CROSS(40,X_38),HIGH+0.02,2);
VMA13:MA(CLOSE,13),COLORFF9900,LINETHICK2;
强攻:IF(X_29>REF(X_29,1) AND X_29>=0,VMA13,DRAWNULL),COLORYELLOW,LINETHICK2;
回调:IF(X_29<REF(X_29,1) AND X_29>0,VMA13,DRAWNULL),COLORGREEN,LINETHICK2;
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLOR000066;
X_58:=MA(CLOSE,20);
MA30:MA(CLOSE,30),POINTDOT,COLORLIRED;
MA60:MA(CLOSE,60),DOTLINE,COLOR05ADC0;
MA120:MA(CLOSE,120),POINTDOT,COLORGREEN;
X_59:=EMA(CLOSE,3);
X_60:=EMA(SLOPE(CLOSE,22)*20+CLOSE,55);
X_61:=MA(X_60,1);
X_62:=X_61*0.985;
X_63:=MA(CLOSE,5);
X_64:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
X_65:=REF(X_64,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_66:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
X_67:=REF(X_66,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_68:=REF(X_66 OR X_67,1) AND X_64;
X_69:=X_68 AND CLOSE>OPEN;
X_70:=REF(X_64,1) AND X_66 AND NOT(REF(CLOSE,3)=LLV(CLOSE,4));
X_71:=REF(X_64 OR X_65,1) AND X_66;
X_72:=IF(CLOSE>MA(CLOSE,4),1,0)+IF(CLOSE<MA(CLOSE,4),(-1),0)+IF(MA(CLOSE,5)>REF(MA(CLOSE,5),1),1,0)+IF(MA(CLOSE,5)<REF(MA(CLOSE,5),1),(-1),0);
X_73:=X_72=(-2) AND CLOSE>OPEN;
X_74:=EMA((CLOSE*2+HIGH+LOW)/4,13)-EMA((CLOSE*2+HIGH+LOW)/4,73);
X_75:=CROSS(X_74,EMA(X_74,2)) AND X_74<=0.05 AND CLOSE/REF(CLOSE,1)>0.035;
X_76:=IF(CLOSE>MA(CLOSE,4),1,0);
X_77:=IF(CLOSE<MA(CLOSE,4),(-1),0);
X_78:=IF(MA(CLOSE,5)>REF(MA(CLOSE,5),1),1,0);
X_79:=IF(MA(CLOSE,5)<REF(MA(CLOSE,5),1),(-1),0);
X_80:=X_76+X_77+X_78+X_79;
X_81:=X_80=2 AND CLOSE<OPEN;
X_82:=X_75 AND NOT(X_81);
X_83:=X_69 AND X_73=0 AND X_82=0;
X_84:=CLOSE/OPEN>1.04 AND CLOSE<SMA(HIGH,19,3) AND CLOSE>REF(CLOSE,1) AND X_73=0;
X_85:=(MAX(CLOSE,OPEN)-MIN(CLOSE,OPEN))/MIN(CLOSE,OPEN)*100;
X_86:=(HIGH-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)*100;
X_87:=(MIN(CLOSE,OPEN)-LOW)/LOW*100;
X_88:=MAX(MA30,MAX(MA60,MA120));
X_89:=MIN(MA30,MIN(MA60,MA120));
X_90:=(X_88-X_89)/X_89*100;
X_91:=MA(REF(LLV(CLOSE,30),1),2);
X_92:=MA30>MA60 AND MA60>MA120;
X_93:=(REF(MIN(CLOSE,OPEN),1)-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)*100;
X_94:=BARSLASTCOUNT(OPEN=REF(CLOSE,1))=2 AND BARSLASTCOUNT(OPEN>CLOSE AND X_85>1.3)=3;
X_95:=X_94 AND X_85<5;
X_96:=COUNT(OPEN>CLOSE AND X_85>2.5,3)>=2 AND CLOSE<X_89 AND MA60=X_88;
X_97:=COUNT(X_95,4)>=1 AND COUNT(X_96,4)>=1 AND X_73 AND CLOSE>REF(CLOSE,1) AND REF(CLOSE<OPEN,1) AND X_90<12;
X_98:=COUNT(X_93>5,3)>=1 AND MA120=X_88;
X_99:=COUNT(X_94,5)>=1 AND COUNT(X_98,4)>=1 AND X_73 AND CLOSE>REF(CLOSE,1);
X_100:=COUNT(X_87>7.4,2)>=1 AND CLOSE<X_89;
X_101:=COUNT(X_94,5)>=1 AND X_100 AND (X_73 OR X_82);
X_102:=REF(X_73 OR X_83,1) AND CLOSE>OPEN;
X_103:=REF(X_94,2) AND X_102 AND REF(CLOSE>X_89 AND CLOSE<X_88,1) AND REF(X_81 OR X_70,4) AND REF(CROSS(CLOSE,MA10)=0,1) AND REF(CROSS(CLOSE,X_91)=0,1);
X_104:=REF(X_83,1) AND REF(CLOSE<X_89,1) AND COUNT(X_81,10)=0 AND COUNT(X_70,9)=0 AND COUNT(X_84,9)=0;
X_105:=COUNT(X_94,4)>=1 AND X_104 AND REF(CROSS(CLOSE,X_91),1) AND CLOSE>OPEN AND REF(X_86,1)<1;
X_106:=REF(X_85<1,1) AND REF(MAX(CLOSE,OPEN),1)>REF(CLOSE,2) AND X_83 AND X_85<1.5 AND CLOSE>REF(CLOSE,1) AND CLOSE>X_88 AND X_92;
X_107:=REF(X_94,2) AND X_106;
X_108:=REF(CLOSE<OPEN AND X_85<1 AND X_85*2<X_86,1) AND CLOSE<OPEN AND BARSLASTCOUNT(MAX(OPEN,CLOSE)>REF(MIN(OPEN,CLOSE),1))>=2 AND REF(OPEN,1)<X_89;
X_109:=COUNT(X_94,4)>=1 AND REF(X_108,1) AND X_83 AND CLOSE>REF(CLOSE,1);
X_110:=X_97 OR X_99 OR X_101 OR X_103 OR X_105 OR X_107 OR X_109;
DRAWICON(X_110,LOW*0.975,27),COLORRED;
X_111:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
X_112:=SMA(X_111,3,1);
X_113:=SMA(X_112,3,1);
X_114:=SMA(X_113,3,1);
X_115:=CROSS(X_113,X_114) AND X_113<20;
DRAWICON(FILTER(X_115,10)=1,LOW*0.95,28),COLORRED;
X_116:=CROSS(X_114,X_113) AND X_113>80;
DRAWICON(FILTER(X_116,5)=1,HIGH*1.01,29),COLORGREEN;
X_117:=(3*CLOSE+OPEN+LOW+HIGH)/6;
X_118:=(20*X_117+19*REF(X_117,1)+18*REF(X_117,2)+17*REF(X_117,3)+16*REF(X_117,4)+15*REF(X_117,5)+14*REF(X_117,6)+13*REF(X_117,7)+12*REF(X_117,8)+11*REF(X_117,9)+10*REF(X_117,10)+9*REF(X_117,11)+8*REF(X_117,12)+7*REF(X_117,13)+6*REF(X_117,14)+5*REF(X_117,15)+4*REF(X_117,16)+3*REF(X_117,17)+2*REF(X_117,18)+REF(X_117,20))/210;
X_119:=MA(X_118,5);
X_120:=(CLOSE+LOW+HIGH)/3;
X_121:=CROSS(X_118,X_119);
X_122:=CROSS(X_119,X_118);
止损价:STICKLINE(ISLASTBAR,HHV(CLOSE,5)*0.95,HHV(CLOSE,5)*0.95,20,2),LINETHICK2;
X_123:=HIGH*0.95;
阻力价:HHV(HIGH,19),NODRAW;
X_124:=(MA(CLOSE,5)-MA(CLOSE,30))/MA(CLOSE,5)*100;
X_125:=CLOSE>MA(CLOSE,5) AND OPEN<MA(CLOSE,5);
X_126:=CLOSE>MA(CLOSE,10) AND OPEN<MA(CLOSE,10);
X_127:=CLOSE>MA(CLOSE,30) AND OPEN<MA(CLOSE,30);
DRAWICON(X_125 AND X_127 AND X_126,LOW*0.999,30),COLORYELLOW;
X_128:=(3*CLOSE+LOW+OPEN+HIGH)/6;
X_129:=(20*X_128+19*REF(X_128,1)+18*REF(X_128,2)+17*REF(X_128,3)+16*REF(X_128,4)+15*REF(X_128,5)+14*REF(X_128,6)+13*REF(X_128,7)+12*REF(X_128,8)+11*REF(X_128,9)+10*REF(X_128,10)+9*REF(X_128,11)+8*REF(X_128,12)+7*REF(X_128,13)+6*REF(X_128,14)+5*REF(X_128,15)+4*REF(X_128,16)+3*REF(X_128,17)+2*REF(X_128,18)+REF(X_128,20))/210;
主力成本:EMA(X_129,13),NODRAW;
X_130:=(OPEN+HIGH+LOW)/3;
X_131:=(HIGH+LOW)/2;
X_132:=EMA(X_130,4)+(X_131-REF(X_130,3))/4;
今日买点:EMA(X_130,3),NODRAW;
X_133:=X_132;
X_134:=REF(X_132,1);
量能饱和度:IF(AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20))*100>100,100,AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20))*100),NODRAW;
X_135:=MA(CLOSE,8);
X_136:=MA(CLOSE,12);
X_137:=ATAN(X_135-REF(X_135,1))*3.1416*10;
X_138:=ATAN(X_136-REF(X_136,1))*3.1416*10;
X_139:=MA(CLOSE,13);
X_140:=ATAN(EMA(X_120,13)-REF(EMA(X_120,13),1))*3.1416*10;
X_141:=EMA(CLOSE,8);
X_142:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
X_143:=SMA(ABS(LOW-X_142),13,1)/SMA(MAX(LOW-X_142,0),10,1);
X_144:=EMA(X_143,10);
X_145:=LLV(LOW,33);
X_146:=EMA(IF(LOW<=X_145,X_144,0),3);
私募进场:IF(X_146>REF(X_146,1),X_146,0),NODRAW,COLORRED;
私募洗盘:IF(X_146<REF(X_146,1),X_146,0),NODRAW,COLORGREEN;
X_147:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
X_148:=SMA(X_147,9,1)+100;
X_149:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
X_150:=SMA(X_149,3,1);
X_151:=SMA(X_150,3,1)+100;
X_152:=X_151-X_148;
X_153:=IF(X_152>60,X_152-60,0);
X_154:=STICKLINE(REF(X_153,1)<X_153,X_153,REF(X_153,1),9,0);
X_155:=STICKLINE(REF(X_153,1)>X_153,X_153,REF(X_153,1),9,0);
X_156:=MA(CLOSE,1)/MA(REF(CLOSE,13),8)*100;
X_157:=MA(FORCAST(X_156,21),3);
X_158:=REF(X_156,1);
X_159:=REF(X_156,2);
X_160:=LLV(LOW,8);
X_161:=HHV(HIGH,13);
X_162:=EMA((CLOSE-X_160)/(X_161-X_160)*100,5);
X_163:=EMA(0.667*REF(X_162,1)+0.333*X_162,2);
X_164:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
X_165:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
X_166:=REF(X_165,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_167:=REF(X_166,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_168:=REF(X_167,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_169:=REF(X_168,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_170:=REF(X_169,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_171:=REF(X_170,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_172:=REF(X_171,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_173:=REF(X_172,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_174:=REF(X_173,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_175:=REF(X_174,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_176:=REF(X_175,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_177:=REF(X_165 OR X_166 OR X_167 OR X_168 OR X_169 OR X_170 OR X_171 OR X_172 OR X_173 OR X_174 OR X_175 OR X_176,1) AND X_164;
X_178:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_179:=EMA(X_178,9);
X_180:=(X_178-X_179)*2;
X_181:=BARSLAST(REF(CROSS(X_178,X_179),1));
X_182:=BARSLAST(REF(CROSS(X_179,X_178),1));
X_183:=REF(CLOSE,X_181+1)>CLOSE AND X_178>REF(X_178,X_181+1) AND CROSS(X_178,X_179);
X_184:=REF(CLOSE,X_182+1)<CLOSE AND REF(X_178,X_182+1)>X_178 AND CROSS(X_179,X_178);
DRAWICON(X_183,LOW*0.99,5),COLORWHITE;
X_185:=STICKLINE(REF((MA(CLOSE,5)-CLOSE)/CLOSE>0.04 AND (MA(CLOSE,10)-MA(CLOSE,5))/MA(CLOSE,5)>0.04 AND X_153=0 AND CLOSE>REF(CLOSE,1),1),OPEN,CLOSE,0.8,0);
DRAWICON(X_185,HIGH*1.01,31),COLORWHITE;
X_186:=STICKLINE(REF(KDJ.J,1)<0 AND KDJ.J>0 AND X_156>=X_157 AND X_158>X_159,OPEN,CLOSE,0.8,0);
DRAWICON(X_186,HIGH*1.01,32),COLORWHITE;
X_187:=STICKLINE(REF(X_162,1)<=13 AND CROSS(X_162,X_163) AND REF(MA(CLOSE,55),1)>REF(MA(CLOSE,55),2) AND (X_177 OR REF(X_177,1)),OPEN,CLOSE,0.8,0);
DRAWICON(X_187,HIGH*1.01,33),COLORWHITE;
X_188:=STICKLINE(X_183,OPEN,CLOSE,0.8,0);
X_189:=REF((MA(CLOSE,5)-CLOSE)/CLOSE>0.04 AND (MA(CLOSE,10)-MA(CLOSE,5))/MA(CLOSE,5)>0.04 AND X_153=0 AND CLOSE>REF(CLOSE,1),1);
DRAWICON(X_189,HIGH*1.02,34),COLORWHITE;
X_190:=DRAWICON(REF(KDJ.J,1)<0 AND KDJ.J>0 AND X_156>=X_157 AND X_158>X_159,36,23);
DRAWICON(X_190,HIGH*1.02,35),COLORWHITE;
X_191:=REF(CLOSE,1);
X_192:=SMA(MAX(CLOSE-X_191,0),6,1)/SMA(ABS(CLOSE-X_191),6,1)*100;
DRAWICON(CROSS(80,X_192),HIGH*1.02,36),COLORYELLOW;
DRAWICON(CROSS(80,X_192),HIGH*1.02,2);
X_193:=SMA(MAX(CLOSE-X_191,0),7,1)/SMA(ABS(CLOSE-X_191),7,1)*100;
X_194:=SMA(MAX(CLOSE-X_191,0),13,1)/SMA(ABS(CLOSE-X_191),13,1)*100;
X_195:=BARSCOUNT(CLOSE);
X_196:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100-60;
X_197:=SMA(X_196,3,1)+100;
X_198:=(CLOSE-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3))*1000;
X_199:=SMA(X_198,3,1);
X_200:=SMA(X_199,3,1)+100;
X_201:=X_200-X_197;
X_202:=EMA((CLOSE-MA(CLOSE,3))/MA(CLOSE,3)*4800,2);
X_203:=EMA((CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*4800,7);
DRAWICON(CROSS(X_202,X_203) AND X_202<0 AND X_203<0,LOW,37),COLORRED;
DRAWICON(CROSS(X_202,X_203),LOW,1);
X_204:=AMOUNT/VOL;
X_205:=LOW<X_204*0.9;
X_206:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
X_207:=LOW<MA(CLOSE,5)*0.921;
X_208:=VOL<MA(VOL,5)*1.5;
X_209:=X_205 AND X_206 AND X_207 AND X_208;
DRAWICON(X_209,LOW*0.985,39),COLOR40CCFF;
DRAWICON(X_209,LOW*0.985,23);
X_210:=MA(REF(HHV(CLOSE,30),1),2);
X_211:=MA(REF(LLV(CLOSE,30),1),2);
X_212:=3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1);
X_213:=EMA(X_212,5);
X_214:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
X_215:=MA(3*SMA(X_214,6,1)-2*SMA(SMA(X_214,5,1),5,1),2);
DRAWICON(CROSS(X_215,0) AND X_213<40,HIGH*0.97,41),COLORYELLOW;
X_216:=SMA(MAX(CLOSE-X_191,0),3,1)/SMA(ABS(CLOSE-X_191),3,1)*100;
X_217:=EMA(CLOSE,21);
DRAWICON(CROSS(X_59,X_217),LOW*0.98,42),COLORA6E500;
X_218:=LLV(LOW,27);
X_219:=HHV(HIGH,34);
X_220:=EMA((CLOSE-X_218)/(X_219-X_218)*4,4)*25;
X_221:=IF(X_220<10,80,100);
X_222:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
X_223:=SMA(X_222,3,1);
X_224:=SMA(X_223,3,1);
X_225:=3*X_223-2*X_224;
X_226:=IF(X_225<0,10,0);
X_227:=LLV(X_225,2)=LLV(X_225,8);
X_228:=IF(CROSS(X_225,REF(X_225+0.01,1)) AND X_227 AND X_225<20,30,0);
X_229:=CLOSE-REF(CLOSE,1);
X_230:=100*EMA(EMA(X_229,6),6)/EMA(EMA(ABS(X_229),6),6);
X_231:=IF(LLV(X_230,2)=LLV(X_230,7) AND COUNT(X_230<0,2) AND CROSS(X_230,MA(X_230,2)),1,0);
X_232:=LLV(CLOSE,100);
X_233:=IF((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.025,1,0);
X_234:=MA(CLOSE,30)-2*STD(CLOSE,60);
X_235:=MA(CLOSE,60);
X_236:=MA(CLOSE,30)+2*STD(CLOSE,60);
X_237:=CROSS(CLOSE,X_236);
DRAWICON(X_237,HIGH*1.01,44),COLORYELLOW;
X_238:=SMA(SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1),3,1);
DRAWICON(X_238>REF(X_238,1) AND REF(X_238,1)<REF(X_238,2),LOW-0.05,34);
DRAWICON(X_238<REF(X_238,1) AND REF(X_238,1)>REF(X_238,2),HIGH+0.05,35);
X_239:=1;
X_240:=MA(CLOSE,3);
X_241:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3);
X_242:=EMA((EMA(CLOSE,1)+EMA(CLOSE,3)+EMA(CLOSE,5))/3,3);
X_243:=IF(X_239!=2,EMA((EMA(CLOSE,5)+EMA(CLOSE,6)+EMA(CLOSE,7))/3,3),DRAWNULL);
X_244:=IF(X_239!=2,X_241-(X_242-X_128*0.977),DRAWNULL);
X_245:=CROSS(X_240,X_244);
本波上升线:IF(X_240>REF(X_243,1),X_243,DRAWNULL),COLORYELLOW,LINETHICK3;
X_246:=MA(CLOSE,8)+MA(CLOSE,8)-REF(MA(CLOSE,8),1);
X_247:=IF(MA(CLOSE,13)<X_246,X_246,MA(CLOSE,13));
X_248:=X_247-(EMA(CLOSE,3)-X_247);
X_249:=BARSLAST(EMA(CLOSE,3)<=EMA(CLOSE,5));
X_250:=IF(EMA(CLOSE,3)>=EMA(CLOSE,3),EMA(CLOSE,5),DRAWNULL);
F5:IF(CURRBARSCOUNT<CONST(X_249+3),X_250,DRAWNULL),COLORMAGENTA,LINETHICK3;
X_251:=CROSS(F5,X_248);
DRAWICON(X_251,HIGH*1.005,4),COLORWHITE;
X_252:=100;
X_253:=0.7;
X_254:=MA(CLOSE,X_252);
X_255:=X_254+X_253*STD(CLOSE,X_252);
X_256:=X_254-X_253*STD(CLOSE,X_252);
X_257:=MA(CLOSE,3);
X_258:=MA(CLOSE,21);
X_259:=(X_257+X_258)/2;
X_260:=MA(CLOSE,13);
X_261:=X_260+2*STD(CLOSE,13);
X_262:=X_260-2*STD(CLOSE,13);
X_263:=MA(CLOSE,13)+MA(CLOSE,13)-REF(MA(CLOSE,13),1);
X_264:=IF(MA(CLOSE,100)<X_263,X_263,MA(CLOSE,100));
X_265:=X_264-(EMA(CLOSE,2)-X_264);
X_266:=CROSS(X_256,X_265);
DRAWICON(X_266,LOW*1,45),COLORWHITE;
X_267:=MA120>MA60 AND MA60>MA30;
X_268:=MA30>MA60 AND MA60>MA120;
X_269:=MAX(MA30,MAX(MA60,MA120));
X_270:=MIN(MA30,MIN(MA60,MA120));
X_271:=IF(MA30!=X_269 AND MA30!=X_270,MA30,IF(MA60!=X_269 AND MA60!=X_270,MA60,MA120));
X_272:=(X_269-X_270)/X_270*100;
X_273:=(X_271-X_270)/X_270*100;
X_274:=MA(REF(HHV(CLOSE,30),1),2);
X_275:=MA(REF(LLV(CLOSE,30),1),2);
X_276:=(X_274-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)*100;
X_277:=(MIN(CLOSE,OPEN)-X_275)/X_275*100;
X_278:=BARSLASTCOUNT(X_275<REF(X_275,1) AND X_275*1.007>=REF(X_275,1));
X_279:=(MAX(CLOSE,OPEN)-MIN(CLOSE,OPEN))/MIN(CLOSE,OPEN)*100;
X_280:=(HIGH-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)*100;
X_281:=(MIN(CLOSE,OPEN)-LOW)/LOW*100;
X_282:=BARSLASTCOUNT(MAX(OPEN,CLOSE)<=REF(MAX(OPEN,CLOSE),1) AND MIN(OPEN,CLOSE)<=REF(MIN(OPEN,CLOSE),1))>=2;
X_283:=(REF(MIN(CLOSE,OPEN),1)-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)*100;
X_284:=BARSLASTCOUNT(X_279>2.1)>=3 AND BARSLASTCOUNT(X_283>2.1)>=2 AND COUNT(X_283>5.5,2) OR (BARSLASTCOUNT(OPEN<REF(OPEN,1) AND CLOSE<REF(CLOSE,1))=2 AND BARSLASTCOUNT(OPEN>CLOSE AND X_279>4)=3);
X_285:=RANGE(MIN(CLOSE,OPEN),MA(CLOSE,5)*0.98,MA(CLOSE,5)*1.02);
X_286:=(MAX(HHV(CLOSE,10),HHV(OPEN,10))-MIN(LLV(CLOSE,10),LLV(OPEN,10)))/MIN(LLV(CLOSE,10),LLV(OPEN,10))*100;
X_287:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
X_288:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
X_289:=REF(X_288,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_290:=REF(X_288 OR X_289,1) AND X_287;
X_291:=X_290 AND CLOSE>OPEN;
X_292:=REF(X_287,1) AND X_288 AND NOT(REF(CLOSE,3)=LLV(CLOSE,4));
X_293:=CLOSE/OPEN>1.04 AND CLOSE<SMA(HIGH,19,3) AND CLOSE>REF(CLOSE,1);
X_294:=IF(CLOSE>MA(CLOSE,4),1,0)+IF(CLOSE<MA(CLOSE,4),(-1),0)+IF(MA(CLOSE,5)>REF(MA(CLOSE,5),1),1,0)+IF(MA(CLOSE,5)<REF(MA(CLOSE,5),1),(-1),0);
X_295:=X_294=(-2) AND CLOSE>OPEN;
X_296:=IF(CLOSE>MA(CLOSE,4),1,0);
X_297:=IF(CLOSE<MA(CLOSE,4),(-1),0);
X_298:=IF(MA(CLOSE,5)>REF(MA(CLOSE,5),1),1,0);
X_299:=IF(MA(CLOSE,5)<REF(MA(CLOSE,5),1),(-1),0);
X_300:=X_296+X_297+X_298+X_299;
X_301:=X_300=2 AND CLOSE<OPEN;
X_302:=EMA((CLOSE*2+HIGH+LOW)/4,13)-EMA((CLOSE*2+HIGH+LOW)/4,73);
X_303:=CROSS(X_302,EMA(X_302,2)) AND X_302<=0.05 AND CLOSE/REF(CLOSE,1)>0.035;
X_304:=X_303 AND NOT(X_301);
X_305:=X_293 AND X_279>3.9 AND X_277<0.2 AND CLOSE>X_275 AND X_281<1.5 AND REF(X_280<3,1) AND (REF(X_279>5.5 AND CLOSE<OPEN,1) AND REF(X_279,1)>X_279)=0 AND X_304=0 AND X_295=0 AND REF(X_292 AND X_304 AND X_291=0,1)=0 AND REF(X_291=0,2);
X_306:=X_275=REF(X_275,1) OR X_278 AND CLOSE<X_270*1.01 AND BARSLASTCOUNT(X_270<=REF(X_270,1))>=7 AND X_273<11.54 AND (BARSLASTCOUNT(X_269>X_274)>=4 AND OPEN<X_275 OR (BARSLASTCOUNT(X_269<X_274)>10 AND OPEN>X_275 AND X_272<10)) AND (X_267 OR CLOSE*1.2<X_270 OR COUNT(CROSS(MA30,MA60),4)) AND BARSLASTCOUNT(X_271<X_274)>=7;
X_307:=X_305 AND X_306;
X_308:=X_293 AND X_279>5.4 AND CLOSE=HHV(CLOSE,4) AND OPEN<=REF(MAX(CLOSE,OPEN),1) AND X_280<1.7 AND X_304=0 AND X_295=0 AND (REF(BARSLASTCOUNT(X_279<1.5 AND X_285)>=3,1) OR REF(COUNT(X_282,2)>=1 AND BARSLASTCOUNT(X_279>1.5)>=3,1)) AND (REF(X_279>4.5 AND CLOSE<OPEN,1)=0 OR REF(X_284,1));
X_309:=X_277<5.4 AND X_276<14 AND CLOSE>X_275 AND CLOSE<X_269*1.01 AND CLOSE>X_270 AND BARSLASTCOUNT(X_269<X_274)>10 AND (COUNT(X_284,7) OR REF(X_286<10,1)) AND (X_268 OR BARSLASTCOUNT(X_269>=REF(X_269,1))>=10);
X_310:=X_308 AND X_309;
X_311:=X_282 AND BARSLASTCOUNT(X_279<2.5)>=3 AND X_295 AND CLOSE<X_275 OR X_284;
X_312:=BARSLASTCOUNT(CLOSE>0)<60 AND CLOSE<MA30*1.01 AND CROSS(CLOSE,MA5) AND CROSS(CLOSE,MA10) OR (X_279>5 AND X_276<14);
X_313:=X_293 AND X_279>3.9 AND X_277<1.05 AND CLOSE>X_275 AND CLOSE<MA30 AND REF(X_275,1)>REF(X_275,2) AND X_275<REF(X_275,1) AND REF(X_311,1) AND X_312;
X_314:=X_307 OR X_310 OR X_313;
龙脉:IF(X_59>X_61,X_61,X_62),CIRCLEDOT,COLORYELLOW;
X_315:=MA(REF(HHV(CLOSE,60),1),2);
X_316:=MA(REF(LLV(CLOSE,60),1),2);
箱顶:MA(REF(HHV(CLOSE,30),1),2),COLORRED,LINETHICK2;
箱底:MA(REF(LLV(CLOSE,30),1),2),COLORGREEN,LINETHICK2;
STICKLINE(X_314,HIGH,LOW,0.1,0),COLORYELLOW;
STICKLINE(X_314,CLOSE,OPEN,3.1,0),COLORYELLOW;
STICKLINE(X_314,CLOSE,OPEN,3.1,0),COLOR0033FF;
STICKLINE(X_314,CLOSE,OPEN,2,0),COLOR0066FF;
STICKLINE(X_314,CLOSE,OPEN,1.5,0),COLOR0099FF;
STICKLINE(X_314,CLOSE,OPEN,1,0),COLOR00CCFF;
STICKLINE(X_314,CLOSE,OPEN,0.5,0),COLORYELLOW;
X_317:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_318:=(CLOSE-OPEN)/OPEN*100;
X_319:=VOL/REF(VOL,1);
X_320:=OPEN/CLOSE>=1.04 OR (REF(CLOSE,1)/CLOSE>=1.03 AND CLOSE<OPEN) AND IF(REF(X_317>1.095,1),VOL/REF(VOL,1)<=1.1,VOL/MA(VOL,60)<=2/3 OR VOL/REF(VOL,1)<=1.15 OR VOL<HHV(VOL,5));
X_321:=ABS(X_317)<=3 AND ABS(X_318)<=2 AND X_319<=2;
X_322:=(CLOSE-REF(CLOSE,3))/REF(CLOSE,3)*100;
X_323:=CLOSE<OPEN AND CLOSE<=REF(LLV(CLOSE,3),1) AND X_322<=(-5);
X_324:=REF(X_320,2) AND REF(X_323,2) AND REF(X_321,1) AND IF(REF(CLOSE<OPEN,1),REF(VOL,1)<REF(VOL,2),REF(VOL,1)<REF(VOL,2) OR REF(VOL,1)>=REF(VOL,2)) AND CLOSE>OPEN AND CLOSE>REF(CLOSE,2) AND (X_317>3 OR X_318>3);
DRAWICON(X_324,HIGH*1.001,46),COLORRED;
X_325:=REF(LOW,1);
X_326:=SMA(ABS(LOW-X_325),13,1)/SMA(MAX(LOW-X_325,0),13,1)*100;
X_327:=EMA(IF(CLOSE*1.2,X_326*13,X_326/13),13);
X_328:=LLV(LOW,34);
X_329:=HHV(X_327,34);
X_330:=IF(LLV(LOW,56),1,0);
X_331:=EMA(IF(LOW<=X_328,(X_327+X_329*2)/2,0),3)/618*X_330;
X_332:=X_331>REF(X_331,1);
X_333:=REF(LLV(LOW,100),3);
X_334:=REFDATE(X_333,DATE);
X_335:=LOW=X_334;
X_336:=X_332 AND X_335;
X_337:=X_336>REF(X_336,1);
X_338:=X_337>REF(X_337,1);
DRAWICON(X_338,HIGH*1.02,47),COLORRED;
确认线:EMA(CLOSE,62),DOTLINE,COLORFF0080;
X_339:=CLOSE>MA(CLOSE,5) AND OPEN<MA(CLOSE,5);
X_340:=CLOSE>MA(CLOSE,10) AND OPEN<MA(CLOSE,10);
X_341:=CLOSE>MA(CLOSE,30) AND OPEN<MA(CLOSE,30);
DRAWICON(X_339 AND X_341 AND X_340 AND CLOSE>EMA(CLOSE,62),LOW*0.975,48),COLORYELLOW;
X_342:=FILTER(X_231=1,5);
DRAWICON(X_228 AND X_221=100 AND X_226=0,LOW*0.965,50),COLORRED;
DRAWICON(X_342,LOW*0.96,51),COLORRED;
X_343:=FILTER(X_140>1 AND EMA(X_120,13)>REF(EMA(X_120,8),1),10);
DRAWICON(X_343,X_141,52),COLORWHITE;
DRAWICON(X_314,HIGH*1.01,53),COLORYELLOW;

通达信红股十心主图指标公式

 

相关文章