在线检测未来函数

通达信看个股的趋势指标公式

来源:Internet,编辑:股旁网,2021-07-08

本文指标含有选股公式如下:

看个股的趋势之空转多选股指标公式

N:=9;M1:=3;M2:=3;
VAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(VAR2+2*VAR3+3*VAR4)/6;
VAR6:=MA(VAR5,3);
MACD: VAR6*5,COLORSTICK ,LINETHICK2 ;
提醒: STICKLINE(VAR6<=-6,0,-25,5,0), COLOR88B7EA ;
关注: STICKLINE(VAR6<=-8,5,25,7,0), ;
出击: STICKLINE(VAR6<=-10,80,100,5,0), COLORYELLOW;
警戒雷达: IF(VAR6<-6,20,0),LINETHICK3 , COLORFF0000;
引导雷达: STICKLINE(VAR6<=-10,65,35,4,0),;
制导雷达: STICKLINE(VAR6<=-10,40,0,4,0), COLORRED;
发射: STICKLINE(VAR6<=-10,80,30,3,0), COLORGREEN;
导弹: STICKLINE(VAR6<=-10,80,60,3,0), COLORWHITE;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,LINETHICK2;
K:SMA(RSV,M1,1),LINETHICK1;
D:SMA(K,M2,1),LINETHICK1;
J:3*K-2*D,COLORFF00FF,LINETHICK1;
IF(J<0,J,DRAWNULL),COLORGREEN,LINETHICK2;
IF(K>90,K,DRAWNULL),COLOR0000FF,LINETHICK2;
IF(D>85,D,DRAWNULL),COLORFFFF11,LINETHICK2;
DRAWICON(CROSS(K,D),D,1);
DRAWICON(CROSS(D,K),K,2);
DRAWICON(CROSS(J,1),J,1);
DRAWICON(K>80 AND D>80 AND CROSS(D,K),D,2);
底: 20,LINETHICK1 , COLOR77AA1A;
强弱分界: 50,LINETHICK1 , COLORCYAN;
入顶: 80,LINETHICK1 , COLOR9966FF;
大顶: 100,LINETHICK1 ,COLOR22A6E6;
多转空:=((((LLV(MACD,4)>0) AND (MACD<REF(MACD,1))) AND (REF(MACD,1)>REF(MACD,2))) AND (REF(MACD,2)>REF(MACD,3)));
空转多:=((((HHV(MACD,4)<0) AND (MACD>REF(MACD,1))) AND (REF(MACD,1)<REF(MACD,2))) AND (REF(MACD,2)<REF(MACD,3)));
DRAWICON(多转空,MACD,2);
DRAWICON(空转多,MACD,1);
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACDD:=2*(DIFF-DEA);
选股:CROSS(MACDD>0,0.5);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
蓝:IF(FILTER(YXF=1,5),20,0),COLORLIBLUE,LINETHICK3;
红: IF(FILTER(YXF=1,5),10,0),COLORRED,LINETHICK2;
黄: IF(FILTER(YXF=1,5),5,0),COLORYELLOW,LINETHICK1;
DIFFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEAA:=EMA(DIFFF,9);
MACD上拐:REF(DEAA,2)>REF(DEAA,1) AND REF(DEAA,1)<DEAA;
过渡:IF(BBI,10,DRAWNULL),COLORWHITE,LINETHICK2;
持股:IF(C>BBI AND BBI>REF(BBI,1),10,DRAWNULL), COLORRED,LINETHICK2;
持币:IF(C<=BBI AND BBI<=REF(BBI,1),10,DRAWNULL),COLORGREEN,LINETHICK2;

通达信看个股的趋势指标公式

 

相关文章