在线检测未来函数

通达信超牛色带主图指标公式

来源:Internet,编辑:股旁网,2021-07-13

M:=1;
天线:(MA(CLOSE,M) * 1.15),COLOR0000FF,LINETHICK2;
地线:(MA(CLOSE,M) * 0.85),COLOR00FF80,LINETHICK2;
B1:=MA(CLOSE,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1) ;
SMA2:MA(B2,4),NODRAW;
DRAWBAND(B2,RGB(250,0,0),SMA2,RGB(0,180,0));
A:='LTFUNC4@FORLT2';
S1:='LTFUNC4@LT_S1';
HS:='LTFUNC4@LT_HS';
LS:='LTFUNC4@LT_LS';
P1:='LTFUNC4@LT_P1';
UPP:='LTFUNC4@LT_UPP';
UDD:='LTFUNC4@LT_UDD';
{HS;LS;HHS;LLS;US;DS;S1;P1;P0;UPP;UDD};
TR0:=IF(P1=1,'明日收盘价<'+CON2STR(UDD,2)+',出现S点\N','若明日收盘价>'+CON2STR(UPP,2)+',出现B点\N');
TR1:=IF(S1=1,'明日收盘价<'+CON2STR(LS,2)+',短线卖出机会','若明日收盘价>'+CON2STR(HS,2)+'短线买入机会');
TR2:=IF(P1=1,IF(CROSS(P1,0),'B点','持股'),IF(CROSS(1,P1),'S点','持币'));
TR3:=IF(S1=0,'向下,','向上,');
STICKLINE(CLOSE>SMA2 OR CLOSE=SMA2,LOW,HIGH,0.1,0),COLOR0022FF;
STICKLINE(CLOSE>SMA2 OR CLOSE=SMA2,OPEN,CLOSE,3,0),COLOR0088FF;
STICKLINE(CLOSE<SMA2 OR CLOSE=SMA2,LOW,HIGH,0.1,0),COLOR009900;
STICKLINE(CLOSE<SMA2 OR CLOSE=SMA2,OPEN,CLOSE,3,0),COLOR009900;
STICKLINE(SMA2>CLOSE ,CLOSE ,OPEN,3,0 ),COLOR009900;
STICKLINE(SMA2>CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00BB00;
STICKLINE(SMA2>CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00DD00;
STICKLINE(SMA2>CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;
STICKLINE(CLOSE>=SMA2,CLOSE,OPEN,3,0) ,COLOR0022FF;
STICKLINE(CLOSE>=SMA2,CLOSE,OPEN,2,0) ,COLOR0066FF;
STICKLINE(CLOSE>=SMA2,CLOSE,OPEN,1,0) ,COLOR00AAFF;
STICKLINE(CLOSE>=SMA2,CLOSE,OPEN,0,0) ,COLOR00EEFF;
{操盘手BS}
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(C,SMA2);
SEL:=CROSS(SMA2,C);
DRAWTEXT(BU,LOW*0.98,'B'),COLORWHITE,LINETHICK4;
DRAWTEXT(SEL,HIGH*1.02,'S'),COLORFFFF00,LINETHICK4;
PT := REF(HIGH,1)-REF(LOW,1);
{强势回调}
MA13:=MA(C,13);
K1:=BACKSET(MA13<REF(MA13,1),2);
MA34:=EMA(C,34);
MA55:=EMA(C,55);
RSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
K:=MA(RSV,2.5);
D:=MA(K,2.5);
J:=3*K-2*D;
JJ:=J<20;
STICKLINE(REF(J,1)<20 AND EMA(C,13)>REF(EMA(C,13),1) AND NOT(JJ),(C+O)/2,O,5,0),COLORFF00FF;
DRAWTEXT(REF(J,1)<20 AND EMA(C,13)>REF(EMA(C,13),1) AND NOT(JJ) ,L-0.15, '←强势回调'),COLORFF00FF;
{以下定义坚决买进}
VAR77:=EMA(AMOUNT/VOL/100,3);
VAR88:=EMA(VAR77,88);
VAR99:=EMA(VAR77,88)*0.85;
VARAH:=VAR99*0.87;
VARBH:=LOW<VARAH AND CLOSE>REF(CLOSE,1)*1.02;
DRAWTEXT(FILTER(VARBH,6),L-0.08,'←坚决买进'),LINETHICK1,COLORFF00FF;
{以下设置强势狙击}
BB05:=ATAN(((MA(C,5))/REF((MA(C,5)),1)-1)*100)*180/3.1416;
BB10:=ATAN(((MA(C,10))/REF((MA(C,10)),1)-1)*100)*180/3.1416;
BB30:=ATAN(((MA(C,30))/REF((MA(C,30)),1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),LINETHICK1,COLORWHITE;
{以下定义资金进场}
VAR3E:=100-(100-3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1));
VAR4E:=100-(100-3*SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1));
VAR5E:=VAR3E>REF(VAR4E,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR5E AND COUNT(VAR5E,30)=1,LOW,'←资金进场'),LINETHICK1,COLORWHITE;

通达信超牛色带主图指标公式

 

相关文章