在线检测未来函数

通达信六趋势共震指标公式

来源:Internet,编辑:股旁网,2021-08-24

{使用使用:1、指标由经久不衰的六项经典指标组成,MACD,KDJ,RSI,LW&R,BBI及ZLMM。 2、当某指标出现金叉,拐点画一个买入红箭头。当某指标出现死叉,拐点画一个卖出绿箭头。 3、红箭金叉趋势向上,绿箭死叉预示趋势向下。当六项指标同时发出红箭头时买入待涨,也就是投资回报大于投资付出!反之亦然,趋势一目了然! 4、出现多于三个向上的红箭头,表示趋势转强!向上的箭头越多,趋势越强! 5、出现多于三个向下的绿箭头,表示趋势转弱!向下的箭头越多,趋势越弱! }

difF:=ema(CLOSE,8)-Ema(CLOSE,13);
DEA:=EMA(DIFF,5);
A1:=DIFF>DEA;
macd金叉:IF(A1,1,0),COLORYELLOW;
RSV1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV1,3,1);
D:=SMA(K,3,1);
DRAWICON(K>D,2,1);
DRAWICON(K<D,2,2);
DRAWTEXT(ISLAstBAR=1,2,'.kdj'),COLORFFFFFF;
A2:=K>D;
kdJ金叉:IF(A2,2,0),COLORYELLOW;
LC:=REF(CLOSE,1);
rsi1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(Abs(CLOSE-LC),5,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;
DRAWICON(RSI1>RSI2,3,1);
DRAWICON(RSI1<RSI2,3,2);
DRAWTEXT(ISLASTBAR=1,3,'.RSI'),COLORFFFFFF;
A3:=RSI1>RSI2;
RSI金叉:IF(A3,3,0),COLORYELLOW;
RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;
Lwr1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,3,1);
DRAWICON(LWR1>LWR2,4,1);
DRAWICON(LWR1<LWR2,4,2);
DRAWTEXT(ISLASTBAR=1,4,'.LWR'),COLORFFFFFF;
A4:=LWR1>LWR2;
LWR金叉:IF(A4,4,0),COLORYELLOW;
bbi:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
DRAWICON(CLOSE>BBI,5,1);
DRAWICON(CLOSE<BBI,5,2);
DRAWTEXT(ISLASTBAR=1,5,'.BBI'),COLORFFFFFF;
A5:=CLOSE>BBI;
BBI金叉:IF(A5,5,0),COLORYELLOW;
mtm:=CLOSE-REF(CLOSE,1);
mms:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
DRAWICON(MMS>MMM,6,1);
DRAWICON(MMS<MMM,6,2);
DRAWTEXT(ISLASTBAR=1,6,'.MTM'),COLORFFFFFF;
A6:=MMS>MMM;
MTM金叉:IF(A6,6,0),COLORYELLOW;
买入:IF((A1 AND A2 AND A3 AND A4 AND A5 AND A6) AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,7,0),COLORBLUE,LINETHICK2;
上涨:IF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,7,0),COLORBLUE,LINETHICK2;

通达信六趋势共震指标公式

相关文章