在线检测未来函数

通达信上山寻宝主图指标公式

来源:Internet,编辑:股旁网,2021-08-31

本文指标含有选股公式如下:

上山寻宝主图之上山选股指标公式

高1:=REF(HHV(H,120),3);
低1:=REF(LLV(L,120),3);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
突破:=REF(ema(C,14),1);
A1X:=(Ema(C,10)-突破)/突破*100;
基准:=IF(A1X>=0,REF(EMA(C,10),BArslAst(crOSS(A1X,0))+1),REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1));
STICKLINE(A1X>=0,基准,突破,5,0),COLOR000099;
STICKLINE(A1X<0,基准,突破,5,0),COLOR00CC66;
AA:=CROSS(A1X,0),LINETHICK0;
STICKLINE(A1X>=0,C,O,2.7,0),COLOR0011FF;
STICKLINE(A1X>=0,C,O,1.8,0),COLOR0044FF;
STICKLINE(A1X>=0,C,O,0.9,0),COLOR0077FF;
STICKLINE(A1X>=0,C,O,0.1,0),COLOR0099FF;
STICKLINE(A1X>=0,H,L,0,0),COLOR0099FF;
STICKLINE(AA,C,O,2.7,0),COLOR330033;
STICKLINE(AA,C,O,1.8,0),COLOR770077;
STICKLINE(AA,C,O,0.9,0),COLORBB00BB;
STICKLINE(AA,C,O,0.1,0),COLORFF00FF;
STICKLINE(AA,H,L,0,0),COLORFF00FF;
DRAWICON(AA,C*0.92,9);
DRAWTEXT(AA,C*0.98,'上山'),COLORRED;
BB:=CROSS(0,A1X),LINETHICK0;
STICKLINE(A1X<0,C,O,2.7,0),COLORAAAAAA;
STICKLINE(A1X<0,C,O,1.8,0),COLORCCCCCC;
STICKLINE(A1X<0,C,O,0.9,0),COLORDDDDDD;
STICKLINE(A1X<0,C,O,0.1,0),COLORFFFFFF;
STICKLINE(A1X<0,H,L,0,0),COLORFFFFFF;
STICKLINE(BB,C,O,2.7,0),COLOR333300;
STICKLINE(BB,C,O,1.8,0),COLOR555500;
STICKLINE(BB,C,O,0.9,0),COLOR777700;
STICKLINE(BB,C,O,0.1,0),COLOR999900;
STICKLINE(BB,H,L,0,0),COLOR999900;
DRAWICON(BB,C*1.05,15);
DRAWTEXT(BB,C*1.01,'下山'),COLOR00FF00;

通达信上山寻宝主图指标公式

相关文章