在线检测未来函数

通达信波峰必杀攻击线主图指标公式

来源:Internet,编辑:股旁网,2021-09-02

{波峰}
TY:=H;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BacKSET(B1,10+1);
HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C002:=BACKSET(B2,10+1);
LD:=FILTER(C002,10);
波峰:REF(H,BArslAst(HD)),COLOR00808F,POINTDOT,LINETHICK4;
STICKLINE(H,波峰,波峰,8,0),COLOR00808F,LINETHICK4;
{彩色k线}
TYX3:=ma(REF(HHV((C+L+O+H)/4,30),1),3);
TYX4:=MA((C+L+O+H)/4,13);
TYX5:=ema((C+L+O+H)/4,21);
{空心红}
STICKLINE(C<TYX5 AND C>O,H,L,0,0),COLORRED;
STICKLINE(C<TYX5 AND C>O,C,O,3,1),COLORRED;
{深绿}
STICKLINE(C<TYX5 AND C<O,H,L,0,0),COLOR007700;
STICKLINE(C<TYX5 AND C<O,C,O,3,0),COLOR005500;
STICKLINE(C<TYX5 AND C<O,C,O,2,0),COLOR006600;
STICKLINE(C<TYX5 AND C<O,C,O,1,0),COLOR007700;
{蓝}
STICKLINE(C>TYX5 AND C<O,H,L,0,0),COLORFFDD44;
STICKLINE(C>TYX5 AND C<O,C,O,3,0 ),COLORFF7700;
STICKLINE(C>TYX5 AND C<O,C,O,2,0 ),COLORFFAA22;
STICKLINE(C>TYX5 AND C<O,C,O,1 ,0 ),COLORFFDD44;
{黄}
STICKLINE(C>TYX5 AND C>O,H,L,0,0 ),COLOR00EEFF;
STICKLINE(C>TYX5 AND C>O,C,O,3,0 ),COLOR00AAFF;
STICKLINE(C>TYX5 AND C>O,C,O,2,0 ),COLOR00CCFF;
STICKLINE(C>TYX5 AND C>O,C,O,1,0 ),COLOR00EEFF;
{粉红}
STICKLINE(C>TYX4 AND C>O,H,L,0,0),COLORFF66AA;
STICKLINE(C>TYX4 AND C>O,C,O,3,0 ),COLORFF11FF;
STICKLINE(C>TYX4 AND C>O,C,O,2,0 ),COLORFF44FF;
STICKLINE(C>TYX4 AND C>O,C,O,1,0 ),COLORFF66FF;
{亮灰}
STICKLINE(C>TYX4 AND C<O,H,L,0,0),COLOR999999;
STICKLINE(C>TYX4 AND C<O,C,O,3,0),COLOR555555;
STICKLINE(C>TYX4 AND C<O,C,O,2,0),COLOR777777;
STICKLINE(C>TYX4 AND C<O,C,O,1,0),COLOR999999;
{深红}
STICKLINE(C>TYX3 AND C>O,H,L,0,0),COLOR0000DD;
STICKLINE(C>TYX3 AND C>O,C,O,3,0),COLOR000099;
STICKLINE(C>TYX3 AND C>O,C,O,2,0),COLOR0000BB;
STICKLINE(C>TYX3 AND C>O,C,O,1,0),COLOR0000DD;
{涨跌停K线}
STICKLINE((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,1,0),COLORYELLOW;
STICKLINE((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,1,0),COLORWHITE;
{突破}
STICKLINE(REF(COUNT(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,1,0),COLOR00CCFF;
STICKLINE(REF(COUNT(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,1,0),COLOR00CCFF;
MA05:=MA(C,5);
MA5角度: ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416,NODRAW;
T01:=CONST(LLVBARS(LOW,10));
T1HIGH:=CONST(REF(HIGH,T01));
MM:=CONST(CURRBARSCOUNT);
T02:=CONST(BARSLAST(CURRBARSCOUNT>MM+T01 AND H>T1HIGH));
T2HIGH:=CONST(REF(HIGH,T02));
T03:=CONST(BARSLAST(CURRBARSCOUNT>MM+T02 AND HIGH>T2HIGH));
T3HIGH:=CONST(REF(HIGH,T03));
攻击线:DRAWLINE(CURRBARSCOUNT=T03+1, T3HIGH, ISLASTBAR, T3HIGH,1),LINETHICK3,COLOR8080FF;
DRAWTEXT(ISLASTBAR, T3HIGH, '必杀攻击线')LINETHICK2,COLORCYAN;
{趋势线}
A6A:=REF(HIGH,6)=HHV(HIGH,2*6+1);
B6A:=FILTER(A6A,6);
C6A:=BACKSET(B6A,6+1);
D6A:=FILTER(C6A,6);
A7A:=REF(LOW,6)=LLV(LOW,2*6+1);
B7A:=FILTER(A7A,6);
C7A:=BACKSET(B7A,6+1);
D7A:=FILTER(C7A,6);
E6A:=(REF(LLV(LOW,2*6),1)+REF(HHV(HIGH,2*6),1))/2;
E7A:=(HIGH+LOW)/2;
H6A:=(D6A AND NOT(D7A AND E6A>=E7A)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
H7A:=D6A AND NOT(D7A AND E6A>=E7A);
L6A:=D7A AND NOT(D6A AND E6A=E7A);
X6A:=REF(BARSLAST(H6A),1)+1;
F6A:=BACKSET(H6A AND COUNT(L6A,X6A)>0,LLVBARS(IF(L6A,LOW,10000),X6A));
G6A:=F6A>REF(F6A,1);
I6A:=BACKSET(G6A,2);
LD2A:=I6A>REF(I6A,1);
L7A:=LD2A OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X7A:=REF(BARSLAST(L7A),1)+1;
F7A:=BACKSET(L7A AND COUNT(H7A,X7A)>0,HHVBARS(IF(H7A,HIGH,0),X7A));
G7A:=F7A>REF(F7A,1);
I7A:=BACKSET(G7A,2);
HD2A:=I7A>REF(I7A,1);
UU3A:=BACKSET(BARSTATUS=2,BARSLAST(LD2A)+1);
VV3A:=UU3A>REF(UU3A,1);
WW3A:=BACKSET(VV3A,REF(BARSLAST(LD2A),1)+2);
XX3A:=WW3A>REF(WW3A,1);
{下支撑线}
DRAWLINE(XX3A,L,VV3A,L,1),COLORCYAN,LINETHICK2;
UU4A:=BACKSET(BARSTATUS=2,BARSLAST(HD2A)+1);
VV4A:=UU4A>REF(UU4A,1);
WW4A:=BACKSET(VV4A,REF(BARSLAST(HD2A),1)+2);
XX4A:=WW4A>REF(WW4A,1);
{上支撑线}
DRAWLINE(XX4A,H,VV4A,H,1),COLOR8000F0,LINETHICK2;

通达信波峰必杀攻击线主图指标公式

相关文章