在线检测未来函数

通达信一路飞扬指标公式

来源:Internet,编辑:股旁网,2021-09-09

本文指标含有选股公式如下:

一路飞扬之选股指标公式

VAR11:=3*SMA((C-LLV(L,480))/(HHV(H,480)-LLV(L,480))*100,5,1)
-2*SMA(SMA((C-LLV(L,480))/(HHV(H,480)-LLV(L,480))*100,180,1),15,1);
超级主升:=EMA(VAR11,5);
主升1:=超级主升-100;
D1:=EMA(C,5);
D2:=(EMA(C,1)+EMA(C,5)+EMA(C,10)+EMA(C,15)+EMA(C,20)+EMA(C,25)+EMA(C,30)+EMA(C,35)+EMA(C,40)+EMA(C,45)+
EMA(C,50)+EMA(C,55)+EMA(C,60)+EMA(C,65)+EMA(C,70)+EMA(C,75)+EMA(C,80)+EMA(C,85)+EMA(C,90)+EMA(C,95)+
EMA(C,100)+EMA(C,105)+EMA(C,110)+EMA(C,115)+EMA(C,120)+EMA(C,125)+EMA(C,130)+EMA(C,135)+EMA(C,140)+EMA(C,150))/30;
DDE:=(D1/D2)*100;
主升2:=DDE-110;
A:=(H+L+2*C)/4;
A1:=(A-REF(A,3))/3+A;
MA5:=EMA(A1,7);
J:=EMA(HHV(A1,20),60),LINETHICK3;
CB5:=EMA(COST(80),30),CIRCLEDOT;
HMX:=EMA(1.4*EMA(FORCAST(A1,20),40),20),LINETHICK2;
金牛线:=(J+CB5+HMX)/3,LINETHICK2;
MA20:=MA(C,20);
UP:=EMA(EMA(C*1.38,50),50),DOTLINE,COLOR0000FF;
白色:=SMA(HIGH,21,2)*1.05;
黄色:=SMA(LOW,21,2)*0.95;
中线:=(白色+黄色)/2;
UP1:=中线+2*STD(中线,20);
UP2:=REF(UP1,0);
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(A1,20))/MA(A1,20);
DD:=DMA(CLOSE,CC);
通道3:=(1+9/100)*DD;
通道4:=(1-7/100)*DD;
界限:=(REF((金牛线+UP+EMA(UP1*1.04,40)+通道3)/4,10)+MA(C,20)*1.04)/2;
AHC1:=H*VOL;
AHC24:=EMA((EXPMA(AHC1,180)/EXPMA(VOL,180)+EXPMA(AHC1,360)/EXPMA(VOL,360)+EXPMA(AHC1,720)/EXPMA(VOL,720)+EXPMA(AHC1,1440)/EXPMA(VOL,1440))/4,34);
C上X:=1.06*AHC24;
C下X:=AHC24*0.94;
AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);
上X:=1.06*AHC22;
下X:=AHC22*0.94;
AHC23:=EMA((EXPMA(AHC1,5)/EXPMA(VOL,5)+EXPMA(AHC1,10)/EXPMA(VOL,10)+EXPMA(AHC1,20)/EXPMA(VOL,20)+EXPMA(AHC1,40)/EXPMA(VOL,40))/4,34);
D上X:=1.06*AHC23;
D下X:=AHC23*0.94;
T:=(C上X+D上X+上X)/3*1.05;
主升3:=(MA5*2/(界限+T)-1)*100;
CBX80:=MA(COST(80),20);
主升4:=(MA5/CBX80-1)*100;
FT:=((HHV(H,42)-LLV(L,42)))/2+LLV(L,42);
FT1:=ABS(HHV(H,40)-LLV(L,40)-LLV(L,40))+FT*0.5;
主升5:=(FT/FT1-1)*100;
P:=EMA(EMA(C*1.14,55),20);
主升6:=(MA5/P-1)*100;
金K线:=(EMA(HHV(H,60),60)+EMA(FT,453)*1.62)/2;
主升7:=(MA5/金K线-1)*100;
主升:(主升1+主升2+主升3+主升4+主升5+主升6+主升7),LINETHICK2,COLORRED;
趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
0,LINETHICK2;
一路飞扬:STICKLINE(CROSS(主升,0),0,趋势,2,0),COLORWHITE;
STICKLINE(CROSS(主升,0),0,趋势,0.5,0),COLORRED;
DRAWTEXT(一路飞扬,趋势/2,'一路飞扬'),,COLORCYAN;

通达信一路飞扬指标公式

 

相关文章