在线检测未来函数

通达信圣手抓妖主图指标公式

来源:Internet,编辑:股旁网,2021-09-09

AS:=(C*3+O+H+L)/6;
XJ:=(AS+0.618*REF(AS,1)+0.382*REF(AS,2)+0.236*REF(AS,3)+0.146*REF(AS,4))/2.382;
{回调认同}
HLX:=EMA(HHV(XJ,3),15);
LLX:=EMA(LLV(XJ,3),15);
CH:=CROSS(XJ,HLX);CL:=CROSS(LLX,XJ);
CHH:=BARSLAST(CH);CLL:=BARSLAST(CL);
YF1:=(CHH<CLL OR CH) AND NOT(CL);
YF2:=(CHH>CLL OR CL) AND NOT(CH);
TF:=IF(YF1,LLX,HLX);
TFB:=(HLX+LLX)/2;
XJK:=SMA(EMA(XJ,3),3,1);
ZWSH:=(HHV(XJ,2)+HHV(XJ,3)+HHV(XJ,4)+HHV(XJ,5))/4;
SH:=EMA(ZWSH,21);
ZWSL:=(LLV(XJ,2)+LLV(XJ,3)+LLV(XJ,4)+LLV(XJ,5))/4;
SL:=EMA(ZWSL,21);
SCH:=CROSS(XJ,SH);SCL:=CROSS(SL,XJ);
SHH:=BARSLAST(SCH);SLL:=BARSLAST(SCL);
SF1:=(SHH<SLL OR SCH) AND NOT(SCL);
SF2:=(SHH>SLL OR SCL) AND NOT(SCH);
TFS:=IF(SF1,SL,SH);
TFBS:=(SL+SH)/2;
{K线}
KX1:=(CLOSE>=OPEN) AND XJ>=TFS;
KX2:=(CLOSE<OPEN) AND XJ>=TFS;
KX3:=(CLOSE>=OPEN) AND XJ<TFS;
KX4:=(CLOSE<OPEN) AND XJ<TFS;
KX5:=((XJ>=TFS AND XJ<TF)OR (XJ<TFS AND XJ>=TF)) AND CLOSE>=OPEN;
KX6:=((XJ>=TFS AND XJ<TF)OR (XJ<TFS AND XJ>=TF)) AND CLOSE<OPEN;
{---------------------【右侧直效-图解模板】---------------------}
{回调认同}
DRAWBAND(TFB,RGB(125,50,50),TFS,RGB(169,169,169));
DRAWBAND(TFB,RGB(185,50,50),TF,RGB(00,100,50));
均价:=(HIGH+LOW+OPEN+CLOSE)/4;
分水岭: MA(3*均价-2*SMA(均价,2,1),12),COLORRED,LINETHICK1;
P:=1;
A01:=(C-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3));
A11:=SMA(A01,2,1);
A21:=SMA(A11,2,1);
A31:=3*A11-2*A21 ;
A41:=2*A31-0.5;
乾坤线:C*(1-(A41-A21)/15),,COLORFF00FF,LINETHICK2;
A:=(L+H)/2;
股价重心:MA(A,5),COLORFFFFFF,NODRAW;
VAR2:=(H+L+O+2*C)/5;
CHH低吸线:=EMA(SLOPE(VAR2,21)*20+VAR2,55);
BB:=LLV(H,1);
逃顶线:FORCAST(FORCAST(BB,15),15), ,COLOR00FF00,LINETHICK2;
抄底线:=FORCAST(FORCAST(BB,25),25), COLORRED,LINETHICK2;
CHH低吸线2:=IF(SLOPE(逃顶线,2)>0,CHH低吸线,C),COLORWHITE;
做多趋势:=IF(均价>分水岭,均价,分水岭),COLORYELLOW;
支撑: REVERSE(做多趋势)+2*分水岭,COLORYELLOW,LINETHICK2;
空仓:IF(CLOSE<SAR(4,2,10),SAR(4,2,10),DRAWNULL),CIRCLEDOT,COLOR889999 ;
多仓:IF(CLOSE>SAR(4,2,10),SAR(4,2,10),DRAWNULL),CIRCLEDOT,COLORRED ;
VARR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARR2:=REF(VARR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARR3:=REF(VARR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VARR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VARR1;
STICKLINE(VAR19,L*0.989,L*0.98,2,0),COLORRED;
VAR1A:=REF(VARR1 OR VARR2 OR VARR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,H*1.01,H,2,0),,COLORFFFFFF{98FD};
VAQR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));VAQR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));VAQR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWICON(CROSS(VAQR2,MA(VAQR3,6)),(LOW * 0.998),1);
DRAWICON(CROSS(MA(VAQR3,6),VAQR1),(HIGH * 1.013),2);
DRAWTEXT(CROSS(VAQR2,MA(VAQR3,6)),(LOW * 0.984),'↖买 '),COLOR4440FF;
DRAWTEXT(CROSS(MA(VAQR3,6),VAQR1),(HIGH * 1.02),'卖 '),COLORFFFF34;
DRAWKLINE(H,O,L,C);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'建仓'),COLORYELLOW;
IF(分水岭<REF(分水岭,1), 分水岭,DRAWNULL),LINETHICK2,,COLOR00FF00;

通达信圣手抓妖主图指标公式

 

相关文章