在线检测未来函数

通达信主力动向强度指标公式

来源:Internet,编辑:股旁网,2021-09-07

本文指标含有选股公式如下:

主力动向强度之主升浪选股指标公式

difF:=ema(CLOSE,12)-Ema(CLOSE,26);
DEAT:=EMA(DIFF,9);
macd:=2000* (2*(DIFF-DEAT))/EMA(C,30),LINETHICK0;
主升浪:0,COLORYELLOW,LINETHICK2;
DRAWBAND(MacD,180,00,30);
stICKLINE(crOSS(MACD,0),0,70,2,0),COLORLIRED;
DRAWTEXT(CROSS(MACD,0),71,'主升浪'),COLORYELLOW;
VARK1:=(HIGH+LOW+CLOSE*2)/4;
VARK2:=EMA(VARK1,21);
VARK3:=STD(VARK1,21);
VARK4:=((VARK1-VARK2)/VARK3*100+200)/4;
VARK5:=(EMA(VARK4,89)-25)*1.56;
VARK6:=EMA(VARK5,5)*1.22;
VARK7:=EMA(VARK6,3);
VARK8:=3*VARK6-2*VARK7;
VAR1A:=IF(CROSS(VARK6,VARK8) AND CROSS(VARK7,VARK8) AND CROSS(VARK7,VARK6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升K:=IF(VAR1D>0.015,VAR1F,0)/45;
STICKLINE(拉升K AND 拉升K>0.05 ,拉升K*10-60,0-60,1,1),COLOR00DDDD;
STICKLINE(拉升K/REF(拉升K,1)>2 AND 拉升K>0.05,拉升K*10-60,0-60,1,0),COLORDD00DD;
MAS:MA(拉升K,5)*10-60,COLORYELLOW;
DRAWICON(拉升K/REF(拉升K,1)>5 AND REF(拉升K,1)/REF(拉升K,2)>5,0-60,38);
趋势:=MA(LOW,20)*1.2,COLOR0080FF,LINETHICK2;
次上趋势:=MA(LOW,20)*1.1,COLORYELLOW;
次下趋势:=MA(HIGH,20)*0.9,COLORWHITE;
下趋势:=MA(HIGH,20)*0.8,COLORGREEN,LINETHICK2;
趋势强度:=IF(C>次上趋势,IF(C>上趋势,4,3),IF(C>次下趋势 AND C<次上趋势,2,IF(C<下趋势,0,1)));
C1:=10000*C/INDEXC;
O1:=10000*O/INDEXO;
主力动向:=MA(C1,5),LINETHICK2,COLORCYAN;
STICKLINE(C1>=O1 AND C1>主力动向 AND 趋势强度=4,C1*55,主力动向*55,2,0),COLORRED;
STICKLINE(C1<O1 AND C1<=主力动向 ,主力动向*55,C1*55,2,0),COLORGREEN;
主力动向K:MA(C1,5)*55,LINETHICK2,COLORCYAN;
DRAWTEXT(ISLASTBAR,主力动向K,' 机构资金'),COLORCYAN;

通达信主力动向强度指标公式

相关文章