在线检测未来函数

通达信启动回调位主图指标公式

来源:Internet,编辑:股旁网,2021-10-11

VAR2:=ema(SLOPE(Ema(CLOSE,20),10)*34+CLOSE,30);
VAR3:=EMA(VAR2,3);
VAR4:=EMA(VAR3,3);
VAR5:=EMA(VAR4,3);
VAR6:=EMA(VAR5,3);
VA7:=EMA(VAR6,3);
VAR7:=EMA(VA7,3);
VA8:=EMA(VAR7,3);
VAR8:=EMA(VA8,3);
VAR9:=EMA(VAR8,3);
VARA:=BArslAst(crOSS(CLOSE,VAR9));
VARB:=BARSLAST(CROSS(VAR9,CLOSE));
启动位:IF(CLOSE>VAR9 AND CLOSE>REF(CLOSE,VARA),REF(CLOSE,VARA),REF(CLOSE,VARA)),COLORRED,POINTDOT,LINETHICK3;
DRAWTEXT(ISLASTBAR AND 启动位,启动位,'____【升浪启动位】'),COLORRED;
DRAWNUMBER(ISLASTBAR AND 启动位,启动位,启动位),COLORRED;
STICKLINE(CLOSE>VAR9 AND CLOSE>REF(CLOSE,VARA),REF(CLOSE,VARA),LOW*1,5,0),COLORRED,LINETHICK2;
强:=IF(CLOSE<VAR9 AND CLOSE<REF(CLOSE,VARB),REF(CLOSE,VARB),REF(CLOSE,VARB)),COLORRED,POINTDOT,LINETHICK1;
STICKLINE(CLOSE<VAR9 AND CLOSE<REF(CLOSE,VARB),REF(CLOSE,VARB),HIGH*1,5,0),COLORGREEN,LINETHICK2;
势:=IF(CLOSE>VAR9 AND CLOSE<REF(CLOSE,VARA),REF(CLOSE,VARA),REF(CLOSE,VARA)),COLORYELLOW,POINTDOT;
STICKLINE(CLOSE>VAR9 AND CLOSE<REF(CLOSE,VARA),REF(CLOSE,VARA),LOW*1.02,6,0),COLORLIGRAY;
回调位:IF(CLOSE<VAR9,REF(CLOSE,VARB),REF(CLOSE,VARB)),COLORLIBLUE,POINTDOT,LINETHICK3;
DRAWTEXT(ISLASTBAR AND 回调位,回调位,'____回调位'),COLORLIBLUE;
DRAWNUMBER(ISLASTBAR AND 回调位,回调位,回调位),COLORLIBLUE;
STICKLINE(CLOSE<VAR9,REF(CLOSE,VARB),REF(CLOSE,VARB),16,0),COLORLIBLUE,LINETHICK5;
STICKLINE(CLOSE>VAR9,REF(CLOSE,VARA),REF(CLOSE,VARA),16,0),COLORRED,LINETHICK5;
STICKLINE(C>=O,H,L,0,0),COLORMAGENTA,LINETHICK2;
MA1:=MA(C,1);
启动比:(MA1-启动位)/启动位*100,COLORYELLOW,NODRAW;
回调比:(MA1-回调位)/回调位*100,COLORGREEN,NODRAW;C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0),COLOR2DFFFF;
STICKLINE(涨停,OPEN,CLOSE,10,0),COLOR008C8C;
STICKLINE(涨停,OPEN,CLOSE,8,0),COLOR00AAAA;
STICKLINE(涨停,OPEN,CLOSE,6,0),COLOR00CacA;
STICKLINE(涨停,OPEN,CLOSE,5,0),COLOR00E3E3;
STICKLINE(涨停,OPEN,CLOSE,4,0),COLOR02FFFF;
STICKLINE(涨停,OPEN,CLOSE,3,0),COLOR02FFFF;
STICKLINE(涨停,OPEN,CLOSE,2,0),COLOR2DFFFF;
STICKLINE(涨停,OPEN,CLOSE,1,0),COLOR2DFFFF;
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0),COLOR33FF33;
STICKLINE(跌停,OPEN,CLOSE,10,0),COLOR009B00;
STICKLINE(跌停,OPEN,CLOSE,8,0),COLOR00B700;
STICKLINE(跌停,OPEN,CLOSE,6,0),COLOR00D200;
STICKLINE(跌停,OPEN,CLOSE,5,0),COLOR00EA00;
STICKLINE(跌停,OPEN,CLOSE,4,0),COLOR0FFF0F;
STICKLINE(跌停,OPEN,CLOSE,3,0),COLOR0FFF0F;
STICKLINE(跌停,OPEN,CLOSE,2,0),COLOR33FF33;
STICKLINE(跌停,OPEN,CLOSE,1,0),COLOR33FF33;
ZT:=C/REF(C,1)>1.097;
BH:=BARSLAST(ZT);
STICKLINE(C,REF(L,BH),REF(L,BH),15,0),COLORLIGRAY,LINETHICK1;
涨停启动位:=C,REF(L,BH),REF(L,BH);
DRAWTEXT(ISLASTBAR AND 涨停启动位,涨停启动位,'____【启动涨停位】'),COLORLIGRAY;
DRAWNUMBER(ISLASTBAR AND 涨停启动位,涨停启动位,涨停启动位),COLORWHITE;

4[1].jpg

相关文章