在线检测未来函数

通达信单双持股主图指标公式

来源:Internet,编辑:股旁网,2021-10-11

本文指标含有选股公式如下:

单双持股主图之买入选股指标公式

双线持币:HHV(ma(HIGH,(3)),2),LINETHICK2,COLOR00FF00;
单线持股3:LLV(MA(HIGH,(3)),1),LINETHICK3,COLOR0000FF;
单线持股2:=LLV(MA(HIGH,(2)),1),LINETHICK2,COLOR0000FF;
单线持股:=LLV(MA(HIGH,(1)),1),LINETHICK1,COLOR0000FF;
DA:=6;FA:=5;CT:=1;P:=0;N:=3;
NS:=IF((HHV(Abs(((HHV(CLOSE,DA)/LLV(CLOSE,DA))-1)),DA)>(10/100)),3,DA);
N1:=IF((MINUTE=5),(NS*48),IF((MINUTE=15),(NS*16),IF((MINUTE=30),(NS*8),IF((MINUTE=60),(NS*4),NS))));
MM:=IF(((P=0) OR (vol=0)),MA(CLOSE,N1),((SUM(AMOUNT,N1)/SUM(VOL,N1))/100));
M1:=REF(MM,1);
{DRAWTEXT(crOSS(0.9,1/VOL*1000>0.01 AND "kdj.J"<0),H*1.08,'地量'),COLOR00FFFF;}
买卖:M1,LINETHICK0,COLORRED;
明日:MM,COLORYELLOW,LINETHICK0;
DRAWNUMBER(CROSS(CLOSE,M1) ,L*0.99,买卖),COLORRED;
DRAWNUMBER(CROSS(M1,CLOSE) ,H*1.03,买卖),COLORGREEN;
DA1:=3;
NS1:=IF((HHV(ABS(((HHV(CLOSE,DA1)/LLV(CLOSE,DA1))-1)),DA1)>(10/100)),1,DA1);
N11:=IF((MINUTE=5),(NS1*48),IF((MINUTE=15),(NS1*16),IF((MINUTE=30),(NS1*8),IF((MINUTE=60),(NS1*4),NS1))));
MM1:=IF(((P=0) OR (VOL=0)),MA(CLOSE,N11),((SUM(AMOUNT,N11)/SUM(VOL,N11))/100));
M11:=REF(MM1,1);
买入:=IF(CROSS(CLOSE,M1),M1,0);
卖出:=IF(CROSS(M1,CLOSE),M1,0);
DRAWTEXT(买入,LOW*0.98,'买入'),COLORRED;
DRAWTEXT(卖出,HIGH*1.02,'卖出'),COLORGREEN;
DW:=BArslAst((卖出>0));
EX10:=HHV((买入>0),(DW+1));
BJ:=IF((EX10>REF(EX10,1)),买入,0);
SJ:=IF((EX10<REF(EX10,1)),卖出,0);
DRAWICON(CROSS(CLOSE,M1),(LOW*0.995),1);
DRAWICON(CROSS(M1,CLOSE),(HIGH*1.005),2);
STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,3,0), COLOR0044FF;
STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,2.6,0), COLOR0077FF;
STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,2.2,0), COLOR1199FF;
STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1.8,0), COLOR22BBFF;
STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1.4,0), COLOR33ddfF;
STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1,0), COLOR33FFFF;
STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,3,0), COLOR000055;
STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,2.6,0), COLOR000077;
STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,2.2,0), COLOR000099;
STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1.8,0), COLOR0000BB;
STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1.4,0), COLOR0000DD;
STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1,0), COLOR0033FF;
STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,3.0,0),COLORFF4400;
STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,2.6,0),COLORFF7700;
STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,2.2,0),COLORFF9911;
STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,1.8,0),COLORFFBB22;
STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,1.4,0),COLORFFDD33;
STICKLINE(((SJ>0) AND (CT=1)),CLOSE,(CLOSE+OPEN)/2,1,0),COLORFFFF33;
STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,3.0,0),COLOR550000;
STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,2.6,0),COLOR770000;
STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,2.2,0),COLOR990000;
STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,1.8,0),COLORBB0000;
STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,1.4,0),COLORDD0000;
STICKLINE(((SJ>0) AND (CT=1)),OPEN,(CLOSE+OPEN)/2,1,0),COLORFF0000;

6[1].jpg

相关文章