在线检测未来函数

通达信综合曲线指标公式

来源:Internet,编辑:股旁网,2021-10-12

N:=5;
ma1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
P01:=IF(MA1>MA2,3,IF(MA2>MA1,-3,0));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=ema(RSV,3);
D:=EMA(K,3);
P02:=IF(K>D,3,IF(D>K,-3,0));
dif:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
macd:=(DIF-DEA)*2;
P03:=IF(DIF>DEA,3,IF(DEA>DIF,-3,0));
wr1:= 100-(100*(HHV(H,10)-C)/(HHV(H,10)-LLV(L,10)));
P04:= IF(WR1>80,3,IF(WR1<20,-3,0));
obv:=SUM(IF(CLOSE>REF(CLOSE,1),vol,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);
MaoBV:=EMA(OBV,24);
P05:=IF(OBV>MAOBV,4,IF(OBV<MAOBV,-4,0));
LC:=REF(C,1);
rsi1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(Abs(CLOSE-LC),6,1)*100;
P06:=IF(RSI1>80,4,IF(RSI1<20,-4,0));
MTR := SMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(L-REF(C,1))),7,1);
HD := H-REF(H,1);
LD := REF(L,1)-L;
DMP:= SMA(IF(HD>0 AND HD>LD,HD,0),7,1);
DMM:= SMA(IF(LD>0 AND LD>HD,LD,0),7,1);
pdi:= DMP*100/MTR;
mdi:= DMM*100/MTR;
ADX:= SMA(ABS(MDI-PDI)/(MDI+PDI)*100,7,1);
ADXR:=(ADX+REF(ADX,7))/2;
P07:=IF(PDI>MDI AND REF(COUNT(ADX>=REF(ADX,1),2)=2,1) AND ADX<REF(ADX,1) AND ADX>50,4,
IF(PDI<MDI AND REF(COUNT(ADX>=REF(ADX,1),2)=2,1) AND ADX<REF(ADX,1) AND ADX>50,-4,0));
boll1:=EMA(C,20);
UBOLL:=BOLL1+1.9104*stD(C,20);
DBOLL:=BOLL1-1.9104*STD(C,20);
P08:=IF(C> UBOLL,4,IF(C< DBOLL,-4,0));
BR:=SUM(MAX(0,H-REF(C,1)),26)/SUM(MAX(0,REF(C,1)-L),26)*100;
AR:=SUM(H-O,26)/SUM(O-L,26)*100;
P09:=IF(BR>350 OR AR>180,4,IF(BR<45 OR AR<45,-4,0));
VR:=SUM(IF(C>LC,V,0),24)/SUM(IF(C<=LC,V,0),24)*100;
P10:=IF(VR>350,4,IF(VR<45,-4,0));
JCQX:50+(P01+P02+P03+P04+P05+P06+P07+P08+P09+P10),NODRAW;
JCQxma:MA(JCQX,8),NODRAW;
STICKLINE(C>0,36,36,10,0),COLOR00FF00;
STICKLINE(C>0,44,44,10,0),COLORYELLOW;
STICKLINE(C>0,56,56,10,0),COLORFF00FF;
STICKLINE(C>0,71,71,10,0),COLORRED;
MB:=EMA(JCQX,N);
UPPER:MB+1.9104*STD(JCQX,N),COLORYELLOW,DOTLINE;
LOWER:MB-1.9104*STD(JCQX,N),COLORLIBLUE,DOTLINE;
IF(JCQX>=56,JCQX,56),COLORRED;
IF(JCQX <56,JCQX,56),COLORWHITE;

4[1].jpg

相关文章