在线检测未来函数

通达信锅底撑压画线主图指标公式

来源:Internet,编辑:股旁网,2021-11-18

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1002”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

LT:=LLVBARS(L,60);
LTT:=BArslAst(CURRBARSCOUNT=CONST(LT)+1);
HT:=FINDHIGHBARS(H,LT+1,60,1);
EXT1:DRAWLINE(CURRBARSCOUNT=CONST(HT)+1,H,ISLASTBAR,REF(H,HT),0),COLORRED,LINETHICK2;
TT:=BARSLAST(CURRBARSCOUNT=CONST(HT)+1);
DRAWLINE(TT=0,H,LTT=0,L,0),COLORRED,LINETHICK2;
EXT2:DRAWLINE(LTT=0,(EXT1-L)*0.618+L,ISLASTBAR,REF((EXT1-L)*0.618+L,LTT),0)DOTLINE,COLORLIMAGENTA;
V1:=IF(C>O OR (C=O AND C>=REF(C,1)),vol,0);
V2:=IF(C<O OR (C=O AND C<REF(C,1)),VOL,0);
LJ:=SUM(V1,LTT)/SUM(V2,LTT);
XGG:=COUNT(crOSS(C>=EXT1,0.5),LTT+1)=1 AND CROSS(C>=EXT1,0.5) AND LJ>1.5;
DRAWICON(XGG,L,25);
STICKLINE(XGG,C,O,2,0),COLORYELLOW;
STICKLINE(XGG,H,L,0,0),COLORYELLOW;
DRAWTEXT(LTT=0,L*0.98,'←锅底'),COLORYELLOW;
T:=BARSLAST(CROSS(C,REF(H,TT)));
GL:=C/REF(H,TT);
TAK:=BARSLAST(GL=HHV(GL,T+1));
DF:=(C-REF(C,TAK+1))/REF(C,TAK+1)*100;
JL:=L/REF(H,TT);
XGK:=DF<-8 AND JL<1.075 AND MIN(C,O)*1.005>=REF(H,TT);
XGT:=BARSLAST(COUNT(XGK,T+1)=1 AND XGK);
QFK:=BacKSET(XGT=0,TAK+1);
QFTK:=BARSLAST(CROSS(QFK=1,0.5));
XZF:=REFX(DF,BARSNEXT(XGT=0));
DRAWICON(CROSS(XGT=0,0.5),L*0.99,1);
DRAWTEXT(CROSS(XGT=0,0.5),L*0.980,'←回踩'),COLORYELLOW;
DRAWLINE(T=0,REF(H,TT),QFTK=0,REF(H,QFTK),0),DOTLINE,COLORYELLOW;
DRAWLINE(QFTK=0,REF(H,QFTK),XGT=0,REF(H,TT),0),DOTLINE,COLORYELLOW;
DRAWTEXT(TT=0,REF(H,TT)*1.05,VARCAT(VARCAT('支撑价:',VAR2STR(REF(H,TT),2)),'元'))COLORYELLOW;
DRAWLINE(QFTK=0,REF(H,QFTK)*1.05,QFTK=10,REF(H,QFTK)*1.05,0),COLORWHITE,LINETHICK3;
DRAWTEXT(QFTK=0,REF(H,QFTK)*1.01,VARCAT(VARCAT('信号处跌幅:',VAR2STR(XZF,2)),'%'))COLORYELLOW;

通达信锅底撑压画线主图指标公式

相关文章