在线检测未来函数

通达信量化交易指标公式

来源:Internet,编辑:股旁网,2021-11-23

stICKLINE(CLOSE,30,40,4,1),COLOR404000;
STICKLINE(CLOSE,20,30,4,1),COLOR404000;
STICKLINE(CLOSE,0,20,4,1),COLOR404000;
STICKLINE(CLOSE,0,10,4,1),COLOR404000;
XA_1:=ema(CLOSE,5);
XA_2:=Ema(vol,5);
XA_3:=MA(CLOSE,5);
XA_4:=MA(CLOSE,10);
XA_5:=MA(CLOSE,20);
XA_6:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55);
XA_7:=CLOSE>XA_3;
XA_8:=CLOSE>XA_4;
XA_9:=CLOSE>XA_5;
XA_10:=XA_3>XA_4;
XA_11:=XA_3>XA_5;
XA_12:=REF(XA_5,1);
XA_13:=XA_5>XA_12;
XA_14:=IF(XA_7,10,0-10)+IF(XA_8,10,0-10)+IF(XA_9,10,0-10)+IF(XA_10,10,0-10)+IF(XA_11,10,0-10)+IF(XA_13,10,0-10);
XA_15:=ATAN((XA_1/REF(XA_1,1)-1)*100)*180/3.1416;
XA_16:=ATAN((XA_2/REF(XA_2,1)-1)*100)*180/3.1416;
XA_17:=CLOSE>XA_6 AND OPEN>XA_6 AND CLOSE>OPEN AND XA_15>50 AND XA_16>70;
XA_18:=FILTER(XA_17,13);
XA_19:=XA_18<=0;
XA_20:=BArslAST(NOT(XA_19));
XA_21:=MA(LOW+(HIGH-LOW)/2,26)*1.15;
XA_22:=MA(LOW+(HIGH-LOW)/2,26)*0.95;
XA_23:=(XA_21+XA_22)/2;
XA_24:=(MA(CLOSE,5)+MA(OPEN,5))/2*1.06;
XA_25:=(MA(CLOSE,5)+MA(OPEN,5))/2*0.98;
XA_26:=(XA_24+XA_25)/2;
XA_27:=XA_24>XA_22;
XA_28:=XA_24>XA_23;
XA_29:=XA_24>XA_21;
XA_30:=XA_26>XA_22;
XA_31:=XA_26>XA_23;
XA_32:=XA_26>XA_21;
XA_33:=XA_25>XA_22;
XA_34:=XA_25>XA_23;
XA_35:=XA_25>XA_21;
XA_36:=IF(XA_27,10,0-10)+IF(XA_28,10,0-10)+IF(XA_29,10,0-10)+IF(XA_30,10,0-10)+IF(XA_31,10,0-10)+IF(XA_32,10,0-10)+IF(XA_33,10,0-10)+IF(XA_34,10,0-10)+IF(XA_35,10,0-10);
XA_37:=EMA(EMA(EMA(CLOSE,13),13),13);
XA_38:=ATAN((XA_37/REF(XA_37,1)-1)*100)*180/3.1416;
XA_39:=XA_38>0;
XA_40:=BARSLAST(NOT(XA_39));
XA_41:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
XA_42:=CEILING(SMA(XA_41,13,8));
XA_43:=XA_42<10 AND XA_14=(-60) AND XA_15<(-60);
XA_44:=BARSLAST(NOT(XA_43<1));
STICKLINE(XA_43>0,1,9,3,1),COLORRED;
STICKLINE(XA_18=1,11,19,3,1),COLORMAGENTA;
STICKLINE(XA_36=10 AND REF(XA_36<10,1),21,29,3,1),COLORGREEN;
STICKLINE(XA_40=1,31,39,3,1),COLORYELLOW;
DRAWNUMBER(XA_39>=0,36,XA_40),COLORWHITE;
DRAWNUMBER(XA_36>=0,26,XA_36),COLORWHITE;
DRAWNUMBER(XA_36<0,26,0),COLORWHITE;
DRAWNUMBER(XA_18<=1,16,XA_20),COLORWHITE;
DRAWNUMBER(XA_43>=0,6,XA_44),COLORWHITE;

通达信量化交易指标公式

相关文章