在线检测未来函数

通达信疯牛启动指标公式

来源:Internet,编辑:股旁网,2021-11-26

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1002”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

RMA:=EMA(CLOSE,7);
NMA:=EMA(CLOSE,19);
做多:RMA>NMA,COLORRED,NODRAW;
做空:RMA<NMA,COLORGREEN,NODRAW;
stICKLINE(RMA>=NMA,0,3,0,0),COLORLIMAGENTA;
STICKLINE(RMA<NMA,0,3,0,0),COLORCYAN;
STICKLINE(crOSS(RMA,NMA),0,4,0.1,0),COLORRED;
A1:=Abs(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,23))/EMA(CLOSE,23));
A2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1);
金线王:=EMA(A2,200)*1.118;
金线王2:=EMA(A2,200)*1.118;
条件:=(C-REF(C,1))/REF(C,1)*100>8;
k线:=CROSS(C,金线王) AND 条件;
RRF:=金K线,STICK;
STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR000088;
STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR0000AA;
STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR0000CC;
STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR0000EE;
STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLOR0000EE;
STICKLINE(IF(RRF,-120,0),+12,0,3,0),COLORLIMAGENTA;
STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLOR770077;
STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLOR990099;
STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLORBB00BB;
STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLORDD00DD;
STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLORFF00FF;
STICKLINE(IF(RRF,-120,0),+9,0,3,0),COLORDD00DD;
STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR003300;
STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR005500;
STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR007700;
STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR009900;
STICKLINE(IF(RRF,-120,0),+6,0,3,0),COLOR00CC00;
STICKLINE(IF(RRF,-120,0),+3,0,3,0),COLOR666666;
STICKLINE(IF(RRF,-120,0),+3,0,3,0),COLOR777777;
STICKLINE(IF(RRF,-120,0),+3,0,3,0),COLOR888888;
STICKLINE(IF(RRF,-120,0),+3,0,3,0),COLOR999999;
STICKLINE(IF(RRF,-120,0),+3,0,3,0),COLORDDDDDD;
STICKLINE(IF(RRF,-120,0),+3,0,3,0),COLORFFFFFF;
DRAWTEXT(RRF,8.5,'   疯'),COLORYELLOW;
DRAWTEXT(RRF,6,'   牛'),COLORYELLOW;
DRAWTEXT(RRF,3.5,'   启'),COLORRED;
DRAWTEXT(RRF,1,'   动'),COLORRED;
VAR1:=MA(CLOSE,3);
VAR2:=MIN(CLOSE,OPEN);
VAR3:=RANGE(REF(LOW,1),REF(VAR1,1)*0.99,REF(VAR1,1)*1.02) AND REF(VAR1,1)<VAR1;
VAR4:=CROSS(VAR1,LOW) AND VAR2>=VAR1;
VAR5:=RANGE(LOW,VAR1*0.99,VAR1*1.01) AND VAR2>=VAR1 AND REF(VAR1,1)<VAR1;
VAR6:=VAR3 AND VAR4;
VAR7:=VAR4 AND EVERY(REF(VAR1,1)<VAR1,3);
VAR8:=MA(CLOSE,4);
VAR9:=MA(CLOSE,10);
短买3: IF(VAR6 OR VAR7 OR VAR5 AND CROSS(VAR8,VAR9),6,0);
DRAWICON(CROSS(VAR8,VAR9) AND (VAR6 OR VAR7 OR VAR5),6.78,1);
DRAWTEXT(短买3=6,6,' 短买3'),COLORYELLOW;
HAR1:=MA(CLOSE,8);
HAR2:=MIN(CLOSE,OPEN);
HAR3:=RANGE(REF(LOW,1),REF(HAR1,1)*0.99,REF(HAR1,1)*1.02) AND REF(HAR1,1)<HAR1;
HAR4:=CROSS(HAR1,LOW) AND HAR2>=HAR1;
HAR5:=RANGE(LOW,HAR1*0.99,HAR1*1.01) AND HAR2>=HAR1 AND REF(HAR1,1)<HAR1;
HAR6:=HAR3 AND HAR4;
HAR7:=HAR4 AND EVERY(REF(HAR1,1)<HAR1,3);
HAR8:=MA(CLOSE,4);
HAR9:=MA(CLOSE,10);
H短买8: IF(HAR6 OR HAR7 OR HAR5 AND CROSS(HAR8,HAR9),6,0),COLORMAGENTA;
DRAWICON(CROSS(HAR8,HAR9) AND (HAR6 OR HAR7 OR HAR5),6.78,1);
DRAWTEXT(H短买8=6,6,' 短买8'),COLORMAGENTA;
ZZT:=REF(C,1)=ZTPRICE(REF(C,2),0.1);{前一天是涨停板}
TK:=O>REF(H,1);{跳空高开}
SSZ:=BETWEEN(C/O,0.97,1.03);{收十字星+\-3%之内}
BP5X:=L>MA(C,5);{最低价未破5日均线}
JXDT:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20);{均线多头排列,以5/10/20为例,可根据需要调整}
JCmacd:=CROSS("MacD.MACD",0);{MACD金叉}
JCkdj:=CROSS("kdJ.J","KDJ.D");{KDJ金叉}
板后星:IF(ZZT AND TK AND SSZ AND BP5X AND JXDT AND (JCMACD OR JCKDJ),8,0),COLORMAGENTA;
DRAWTEXT(板后星=8,8,' 板后星'),COLORMAGENTA;
芝麻点:=((H/L)<1.05);
调后星:IF(C<REF(H*0.96,1) AND 芝麻点 AND JXDT,8,0),COLORGREEN; {很好AAA}
DRAWTEXT(调后星=8,8,' 调后星'),COLORGREEN;
涨停:=REF(C,1)>REF(C,2)*1.097;{跳空高开十字星}
十字星:=ABS(C-O)/O<0.02;
跳空:=L>REF(C,1);
放量:=V>REF(V,1)*2;
跳空高开十字星: IF(涨停 AND 十字星 AND 跳空 AND 放量,10,0),COLORRED;
DRAWTEXT(跳空高开十字星=10,10,' 倍量星'),COLORRED;

通达信疯牛启动指标公式

相关文章