在线检测未来函数

同花顺MACD与成交量指标公式

来源:Internet,编辑:股旁网,2022-01-11

obv:=Ema(SUM(IF(C>REF(C,1),vol,IF(C<REF(C,1),-V,0)),0)/1000,2);
obve:=EMA(OBV,3);
DIFF:=(EMA(obve,12)-EMA(obve,26));
bbdIFF:=DIFF-REF(DIFF,1);
DEA:=EMA(DIFF,9);
bbDEA:=DEA-REF(DEA,1);
macd:2*(DIFF-DEA);
PARTLINE(IF(C,0,0),0,colorwhite);
stICKLINE(DIFF>=REF(DIFF,1) AND DEA>REF(DEA,1),DIFF,dea,8,0),LINETHICK4,Color0089FF;//{橙}
//DRAWTEXT(DIFF>=REF(DIFF,1) AND DEA>REF(DEA,1),L*0.98,"介入");
STICKLINE(DIFF>DEA,DIFF,DEA,8,0),Color0089FF;//{橙--加宽}
STICKLINE(DIFF<REF(DIFF,1) AND DEA<REF(DEA,1),DIFF,DEA,8,0),LINETHICK4,colorblue;//{蓝}
STICKLINE(DIFF<DEA,DIFF,DEA,8,0),colorblue;//{蓝--加宽}
STICKLINE(DIFF>=REF(DIFF,1) AND DEA<REF(DEA,1),DIFF,DEA,8,0),LINETHICK4,Color00C500;//{绿}
STICKLINE(DIFF<REF(DIFF,1) AND DEA>REF(DEA,1),DIFF,DEA,8,0),LINETHICK4,coloryellow;//{黄}
STICKLINE(MacD>REF(MACD,1) AND MACD>0,0,MACD,2,0),colorred;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,2,0),coloryellow;
STICKLINE(MACD<REF(MACD,1) AND MACD<0,0,MACD,2,0),colorgreen;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,2,0),COLOR0099FF;
//IF(C,2*(DEA-DIFF),MACD),LINETHICK2,colorgray;//{加速线}
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,5,0),color0000ff;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,5,0),colorffff00;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,5,0),colorff00ff;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,5,0),color00ff00;
量能饱和度:IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100),NODRAW;
LC:=REF(CLOSE,1);
rsi5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(Abs((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
pdi:=((DMP * 100) / TR1);
mdi:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
0,COLORFF00FF;
AAA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AAA,0),5,1)/SMA(ABS(CLOSE-AAA),5,1)*1000;
HHH:=BBB-LLV(BBB,10);
SS:=(MA(HHH,2)*3+HHH*13)/16;
短线买点:=IF(SS>13,MA(SS,2),SS)/6;
短线出击:IF(crOSS(短线买点,1) AND (短线买点<30),10,0),coloryellow,LINETHICK2;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
wr10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
阶段底部:=(AV + NEWVOL);
准备进场:IF((阶段底部 < 0),-10,0),STICK,coloryellow,LINETHICK1;
{STICKLINE((阶段底部 < 0),0,-10,0.8,1),LINETHICK1,coloryellow;}
趋势线:=LLV(阶段底部,1),colorwhite,LINETHICK0;
STICKLINE(CROSS(阶段底部,0),0,-10,0.5,1),colorred,LINETHICK1;
N:=5;
VAR1:4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),coloryellow,LINETHICK0;
VAR2:8,colorgreen,LINETHICK0;
准备拉升: IF(CROSS(VAR1,VAR2),80,0),STICK,COLOR0000CC,LINETHICK2;
庄家吸筹: IF(VAR1<=8,25,0),STICK,colorwhite,LINETHICK2;
DRAWTEXT(CROSS(VAR1,VAR2),80,'建仓'),COLOR00FFFF;
地域:DRAWTEXT_FIX(ISLASTBAR,0.78,0,1,BLOCK(2,1)),coloryellow;
所属行业:DRAWTEXT_FIX(ISLASTBAR,0.85,0,1,BLOCK(1,1)),coloryellow;
概念:DRAWTEXT_FIX(ISLASTBAR,0.1,0,1,BLOCK(3,1)),colorred;
MA5偏离值:C/MA(C,5)-1,NODRAW;

同花顺MACD与成交量指标公式

相关文章