在线检测未来函数

同花顺四背离指标公式

来源:Internet,编辑:股旁网,2022-01-13

N:=60;
K值:="kdj.K";
DD:=C=LLV(C,N);//{60日低点}
DDSJ:=BArslAst(REF(DD,1));//{上一低点时间}
DDGJ:=REF(CLOSE,DDSJ+1)>CLOSE;//{股价趋势}
kdZB:=REF(K值,DDSJ+1)<K值;//{KDJ.K指标趋势}
K底背离:=DDGJ AND KDZB;
GD:=C=HHV(C,N);//{60日最高点}
GDSJ:=BARSLAST(REF(GD,1));//{上一高点时间}
GDGJ:=REF(CLOSE,GDSJ+1)<CLOSE;//{股价趋势}
KGZB:=REF(K值,GDSJ+1)>K值;
K顶背离:=GDGJ AND KGZB;
macd:="MacD.MACD";
MDZB:=REF(MACD,DDSJ+1)<MACD;//{MACD指标趋势}
M底背离:=DDGJ AND MDZB;
MGZB:=REF(MACD,GDSJ+1)>MACD;
M顶背离:=GDGJ AND MGZB;
rsi:="RSI.RSI1";
RDZB:=REF(RSI,DDSJ+1)<RSI;//{RSI指标趋势}
R底背离:=DDGJ AND RDZB;
RGZB:=REF(RSI,GDSJ+1)>RSI;
R顶背离:=GDGJ AND RGZB;
TYP:=(HIGH + LOW + CLOSE)/3;
cci:=(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
CDZB:=REF(CCI,DDSJ+1)<CCI;//{CCI指标趋势}
C底背离:=DDGJ AND CDZB;
CGZB:=REF(CCI,GDSJ+1)>CCI;
C顶背离:=GDGJ AND CGZB;
//REFLINE: -5,15,30,colorblack;
//DRAWTEXT(ISLASTBAR,29,'KDJ顶背离'),LINETHICK2,colorred;
DRAWTEXT(K顶背离,IF(1,270.5,29),'(×)'),LINETHICK2,colorred;//ISLASTBAR
//DRAWTEXT(ISLASTBAR,26,'MACD顶背离'),LINETHICK2,colormagenta;
DRAWTEXT(M顶背离,IF(1,240.5,26),'(×)'),LINETHICK2,colormagenta,;
//DRAWTEXT(ISLASTBAR,22.1,'RSI顶背离'),LINETHICK2,colorblue;
DRAWTEXT(R顶背离,IF(1,200.5,22.1),'(×)'),LINETHICK2,colorblue;
//DRAWTEXT(ISLASTBAR,18.1,'CCI顶背离'),LINETHICK2,colorgreen;
DRAWTEXT(C顶背离,IF(1,160.6,18.1),'(×)'),LINETHICK2,colorgreen,;
//DRAWTEXT(ISLASTBAR,14.2,'CCI底背离'),LINETHICK2,colorgreen;
DRAWTEXT(C底背离,IF(1,120,14.2),'(√)'),LINETHICK2,colorgreen;
//DRAWTEXT(ISLASTBAR,10,'RSI底背离'),LINETHICK2,colorblue;
DRAWTEXT(R底背离,IF(1,80.5,10),'(√)'),LINETHICK2,colorblue;
//DRAWTEXT(ISLASTBAR,6,'MACD底背离'),LINETHICK2,colormagenta;
DRAWTEXT(M底背离,IF(1,40.5,6),'(√)'),LINETHICK2,colormagenta;
//DRAWTEXT(ISLASTBAR,3,'KDJ底背离'),LINETHICK2,colorred;
DRAWTEXT(K底背离,IF(1,10.5,3),'(√)'),LINETHICK2,colorred;

同花顺四背离指标公式

相关文章