在线检测未来函数

通达信超短分时打板主图指标公式

来源:Internet,编辑:股旁网,2022-01-13

X_0:HHV(H,480),DOTLINE,COLORCYAN;
X_1:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;
X_2:=BArslAst((X_1-REF(X_1,1))!=WEEkdAY-REF(WEEKDAY,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0)+1;
X_3:=REF(C,X_2);
X_4:=REF(X_3,X_2);
X_5:=REF(X_4,X_2);
X_6:=REF(X_5,X_2);
X_7:=REF(X_6,X_2);
X_8:=REF(X_7,X_2);
X_9:=REF(X_8,X_2);
X_10:=REF(X_9,X_2);
X_11:=REF(X_10,X_2);
X_12:=MAX(DYNAINFO(3),DYNAINFO(5));
X_13:=MIN(DYNAINFO(3),DYNAINFO(6));
X_14:=X_12-X_13;
X_15:X_13+X_14*8/9,COLORLIRED,DOTLINE;
X_16:X_13+X_14*0.5/9,COLORGREEN,DOTLINE;
X_17:IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(vol*100,0)),1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0))),COLORYELLOW,DOTLINE;
X_18:=(EMA(CLOSE,12)-EMA(CLOSE,26))+DYNAINFO(3);
X_19:=EMA(X_18,9);
X_20:=10*(X_18-X_19);
X_21:=EMA(X_20,2);
STICKLINE(X_20>=X_21 AND X_20>=0,DYNAINFO(3),X_20+DYNAINFO(3),0,-1),COLORLIGRAY;
STICKLINE(X_20<X_21 AND X_20>0,DYNAINFO(3),X_20+DYNAINFO(3),0,-1),COLORLICYAN;
STICKLINE(X_20>=X_21 AND X_20<0,DYNAINFO(3),X_20+DYNAINFO(3),0,-1),COLORLIGRAY;
STICKLINE(X_20<X_21 AND X_20<0,DYNAINFO(3),X_20+DYNAINFO(3),0,-1),COLORLIGREEN;
X_22:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
X_23:=expma(CLOSE/X_22,20);X_24:=EXPMA(CLOSE/X_22,60);X_25:=EXPMA(CLOSE/X_22,120);
X_26:=1;1.022,NODRAW;X_27:=1.033;
DRAWTEXT(crOSS(X_23,1.02),C*0.999,' 拉'),COLORMAGENTA,LINETHICK9;
DRAWICON(CROSS(X_23,1.04),C,45);
DRAWTEXT(CROSS(X_23,1.04),C*0.999,' 冲'),COLORRED,LINETHICK9;
X_28:=(VOL/CLOSE)/3;
X_29:=SUM((IF(((X_28>40) AND (CLOSE>(REF(CLOSE,1)))),X_28,0)),0);
X_30:=SUM((IF(((X_28>40) AND (CLOSE<(REF(CLOSE,1)))),X_28,0)),0);
X_31:=SUM((IF(((X_28<40) AND (CLOSE>(REF(CLOSE,1)))),X_28,0)),0);
X_32:=SUM((IF(((X_28<40) AND (CLOSE<(REF(CLOSE,1)))),X_28,0)),0);
X_33:=((X_29+X_30)+X_31)+X_32;
X_34:=IF((BARSTATUS=2),((100*X_29)/X_33),0);
X_35:=((IF((BARSTATUS=2),((100*X_30)/X_33),0)));
X_36:=((IF((BARSTATUS=2),((100*X_31)/X_33),0)));
X_37:=((IF((BARSTATUS=2),((100*X_32)/X_33),0)));
DRAWTEXT(LONGCROSS(X_16,C,2),C-0.01,'满仓买入'),COLORRED,LINETHICK9;
DRAWICON(LONGCROSS(X_16,C,2),C-0.01,1);
STICKLINE(LONGCROSS(X_16,C,2),C,X_15,0,-1),COLORCYAN;
DRAWTEXT(LONGCROSS(C,X_15,2),C+0.01,'卖出'),COLORGREEN,LINETHICK9;
DRAWICON(LONGCROSS(C,X_15,2),C+0.01,45);

通达信超短分时打板主图指标公式

相关文章