在线检测未来函数

通达信蛟龙出宫主图指标公式

来源:Internet,编辑:股旁网,2022-01-19

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1005”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

重心:(2*C+H+L)/4,COLOR00FFFF,LINETHICK0;
SJ:=Wma((重心-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);
DRAWTEXT(crOSS(SJ,ZJ) AND LAst(SJ<ZJ,5,1)
AND SJ<30,L-0.1,'←低吸'),COLOR00FF00;
DRAWTEXT(CROSS(ZJ,SJ) AND SJ>70,H+0.1,'←高抛'),COLOR0077FF;
Q5:MA(C,4);
压力:=DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3)
,HHV(HIGH,3),1);
低吸:CROSS(SJ,ZJ) AND LAST(SJ<ZJ,5,1) AND SJ<30,COLORRED,NODRAW;
DRAWICON(低吸,REF(CLOSE,1)*0.96,24);
极品绝底:=IF(L<=LLV(L,100),-10,0);
低吸极品:IF(低吸 AND 极品绝底=-10,-1,0),COLORRED,NODRAW;
蛟龙出宫:REF(低吸,1) AND C>1.02*MA(C,4)
AND CROSS(C,MA(C,4)) AND C>压力 AND C>O,COLORRED,NODRAW;
{压撑线 N 1 100 5}
N:=5;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLOR00C0C0;
A1:=REF(H,N)=HHV(H,2*N+1);
B1:=FILTER(A1,N);
C1:=BacKSET(B1,N+1);
D1:=FILTER(C1,N);
A2:=REF(L,N)=LLV(L,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2;
E2:=(H+L)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2));
H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BArslAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1);
S1:=R1>REF(R1,1),COLORRED,NODRAW;
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);
U1:=T1>REF(T1,1),COLORRED,NODRAW;
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2);
S2:=R2>REF(R2,1),COLORRED,NODRAW;
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);
U2:=T2>REF(T2,1),COLORRED,NODRAW;
DRAWICON(U1,REF(CLOSE,1)*0.98,13);
DRAWICON(S1,H*1.01,25);
DRAWICON(U2,REF(CLOSE,1)*0.98,13);
DRAWICON(S2,H*1.01,25);
NOTEXT1:DRAWLINE(S2,H,S1,H,1),LINETHICK2,COLORRED;
NOTEXT2:DRAWLINE(U2,L,U1,L,1),LINETHICK2,COLORGREEN;
下降压力:DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3)
,HHV(HIGH,3),1),COLORYELLOW,LINETHICK2;
TTJ:=BARSLAST((vol=HHV(VOL,14)));
K0:=TTJ=0;
K1:=SUMBARS(K0,1);
K2:=SUMBARS(K0,2);
K3:=SUMBARS(K0,3);
K4:=SUMBARS(K0,4);
K5:=SUMBARS(K0,5);
K6:=SUMBARS(K0,6);
K7:=SUMBARS(K0,7);
K8:=SUMBARS(K0,8);
K9:=SUMBARS(K0,9);
K10:=SUMBARS(K0,10);
AA:STICKLINE(K1<=30,REF(C,K1-1)*1.0001,REF(C,K1-1),0.3,0),COLORFFFF00;
{涨停变黄三线延伸}
ZT:=C/REF(C,1)>1.097;
STICKLINE(ZT,H,O,1,0),COLOR00FFFF;{涨停当日变黄}
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH); VX2:=H/REF(C,1);
STICKLINE(VX2>=1.0990 AND C<H,O,C,2,0),COLORMAGENTA;
{主力启动点}
V1:=CLOSE/REF(CLOSE,3)>=1.1;
V2:=BACKSET(V1,2);
黄金柱:=STICKLINE((V2 AND COUNT(V2,2)=1),0,VOL,3,0),COLORRED;{与昨日对比全红柱}
拉:DRAWTEXT(黄金柱,H*1.01,'拉'),LINETHICK2,COLOR00FFFF;
{地量+倍量}
昨天地量:=REF(V,1)<=REF(LLV(VOL,60),1);
倍量C:=V/REF(V,1)>1.8;
收阳C:=C>O;
阳线C:=C/REF(C,1)>1.02;
抄底:=昨天地量&&倍量C&&收阳C&&大阳线C;
DRAWTEXT(抄底,L-0.1,'抄底'),COLORWHITE;
DRAWICON(抄底,HIGH+0.2,5);
T1K:=CONST(LLVBARS(LOW,N));
T1HIGH:=CONST(REF(HIGH,T1K));
AD:=CONST(CURRBARSCOUNT);
T2K:=CONST(BARSLAST((CURRBARSCOUNT >(AD+T1K)) AND (HIGH>T1HIGH)));
T2HIGH:=CONST(REF(HIGH,T2K));
T3K:=CONST(BARSLAST((CURRBARSCOUNT >(AD+T2K)) AND (HIGH>T2HIGH)));
T3HIGH:=CONST(REF(HIGH,T3K));
洗盘杀入线:DRAWLINE(CURRBARSCOUNT=10+1,T3HIGH,ISLASTBAR, T3HIGH,1),LINETHICK1,COLORLIRED;
DRAWTEXT(ISLASTBAR, T3HIGH,'杀入线')LINETHICK1,COLORLIRED;

通达信蛟龙出宫主图指标公式

相关文章