在线检测未来函数

通达信资金趋势+敢死队+能量潮指标公式

来源:Internet,编辑:股旁网,2022-01-25

{资金趋势}
DRAWBAND(3*(Ema(C,3)-EMA(C,8)-EMA(EMA(C,3)-EMA(C,8),20))*5+20,RGB(250,80,80),20,RGB(0,180,180 ));
DRAWTEXT(ISLAstBAR,20.5,' 资金'),COLORMAGENTA ;
{仿敢死队}
A:=vol*CLOSE;
B:=SUM(A,1)/SUM(VOL,1);
B1:=EMA(B,8);
敢死队:(B-B1)*100/B,NODRAW,COLORRED;
DRAWBAND(敢死队+35,RGB(250,0,00),35,RGB(0,255,0));
DRAWTEXT(ISLASTBAR,35.5,' 敢死队'),COLORRED;
资金趋势:3*(EMA(C,3)-EMA(C,8)-EMA(EMA(C,3)-EMA(C,8),20))*5,NODRAW,COLORMAGENTA;
{能量潮}
VAR2:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*200*10;
能量: SMA(VAR2,5,1)/100,COLORRED;
DRAWBAND(能量>REF(能量,1),RGB(250,0,120),0,RGB(0,180,180));
STICKLINE(能量>REF(能量,1),0,能量,2.5,0),COLOR7800FF;
STICKLINE(能量<REF(能量,1),0,能量,2.5,0),COLORFF7800;
危险区:18,COLOR208FFF;
次险区:15,COLORFF33FF,DOTLINE;
VAR3:=VOL/((HIGH-LOW)*2-Abs(CLOSE-OPEN));
VAR4:=(IF(CLOSE>OPEN,VAR3*(HIGH-LOW),IF(CLOSE<OPEN,VAR3*(HIGH-OPEN+CLOSE-LOW),VOL/2))/(IF(CLOSE>OPEN,0-VAR3*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-VAR3*(HIGH-LOW),0-VOL/2))*(-1))-IF(CLOSE>OPEN,0-VAR3*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-VAR3*(HIGH-LOW),0-VOL/2))*(-1)/IF(CLOSE>OPEN,VAR3*(HIGH-LOW),IF(CLOSE<OPEN,VAR3*(HIGH-OPEN+CLOSE-LOW),VOL/2)));
VAR5:=AMOUNT/(100*VOL);
VAR6:=MA(VAR5,40);
VAR7:=100*(CLOSE-VAR6)/VAR6;
底部区: IF(VAR4>0 AND VAR7<-12 AND CLOSE/OPEN>1.07,300,200)/100,COLORFFFF00,DOTLINE;
DRAWTEXT(ISLASTBAR,1.5,' 能量'),COLOR7800FF ;
量堆:=COUNT(V>=REF(V,1)*2,BArslAST(crOSS(C,MA(C,20))));
量堆1:=IF(量堆=1,1000,0)/100,COLORYELLOW,LINETHICK3;
{高低距------------------------}
DRAwrECTREL(200,990,0,0,RGB(10,0,0));{活动框};
最高价:=HIGH;
最低价:=LOW;
比:=(H-L)/L*100;
低:=(C-L)/L*100;
图比:=低/比*100;
DRAWRECTREL(40,850,70,150,RGB(0,255,0));
DRAWRECTREL(70,CONST(850-图比*7),40,850,RGB(255,0,0));
DRAWRECTREL(70,150,40,850,RGB(0,0,0));{活动框};
DRAWTEXT_FIX(1,0.09,0.3,0,STRCAT(CON2STR(比-低,2),'%')),COLORRED;
DRAWTEXT_FIX(1,0.09,0.6,0,STRCAT(CON2STR(低,2),'%')),COLORGREEN;
DRAWTEXT_FIX(1,0.09,0.8,0,STRCAT(STRCAT('高低:',CON2STR(比,2)),' %')),COLORWHITE;
低开:=(OPEN-REFV(C,1))/REFV(C,1)*100,COLORWHITE,NODRAW;
DRAWTEXT_FIX(1,0.09,0.05,0,STRCAT(STRCAT('开盘:',CON2STR(高低开,2)),' %')),COLORWHITE;

通达信资金趋势+敢死队+能量潮指标公式

相关文章