在线检测未来函数

通达信超强潜伏选股指标公式

来源:Internet,编辑:股旁网,2022-02-16

X_1:=Ema(SLOPE(CLOSE,34)*20+CLOSE,75);
X_2:=EMA(CLOSE,8);
X_3:=X_2-X_1;
X_4:=X_3>=0;
X_5:=X_3<0;
X_6:=HHV(HIGH,50)-LLV(LOW,50);
X_7:=X_3>=0 AND REF(X_3<0,1) AND COUNT(X_3>=0,6)<=1;
X_8:=MA(CLOSE,1)-MA(CLOSE,6);
X_9:=X_8>0;
X_10:=X_8<0;
X_11:=crOSS(X_8,0);
X_12:=(2*CLOSE+HIGH+LOW+OPEN)/5;
X_13:=(X_12-MA(X_12,14))*100/(1.5*AVEDEV(X_12,14));
X_14:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(Abs(CLOSE-REF(CLOSE,1)),6,1)*100;
X_15:=X_14<25;
X_16:=vol*100/CAPITAL;
X_17:=MA(X_16,4);
X_18:=MA(X_16,8);
X_19:=MA(X_16,16);
X_20:=MA(X_16,32);
X_21:=MA(CLOSE,50);
X_22:=(CLOSE-X_21)/X_21<0.008;
X_23:=(CLOSE-MA(CLOSE,8))/MA(CLOSE,8)<0.058;
X_24:=(X_22=1 AND X_23=1)*0.2;
X_25:=(X_24=0 AND REF(X_24,1)=0.2 AND REF(COUNT(X_24=0.2,10)=10,1)=1)*1;
X_26:=HHV(REF(VOL,1),5);
X_27:=BArslAst(X_26);
X_28:=VOL>X_26 AND CLOSE>REF(CLOSE,X_27+1);
X_29:=X_17>=X_20 AND REF(X_17<X_20,1) AND COUNT(X_19,10)<=2 AND (CLOSE-REF(CLOSE,3))/REF(CLOSE,3)<=0.15;
X_30:=X_17>X_20 AND X_18>X_20 AND X_19<X_20 AND REF(X_18<X_20,1);
X_31:=X_17>X_20 AND X_18>X_20 AND X_19>X_20 AND REF(X_19<X_20,1) AND COUNT(X_18<X_20,3)<=1;
X_32:=X_30 OR X_31;
X_33:=COUNT(X_19,10)<=1;
X_34:=(CLOSE-REF(CLOSE,9))/REF(CLOSE,9)<=0.14;
X_35:=X_32 AND COUNT(X_19,10)<=1 AND X_34;
X_36:=X_17<X_20 AND X_18>=X_20 AND X_19<X_20 AND REF(X_18<X_20,1) AND (CLOSE-REF(CLOSE,10))/REF(CLOSE,10)<=0.28 AND COUNT(X_19,10)<=2;
X_37:=X_11 AND COUNT(X_19,20)<=3 AND X_34;
X_38:=X_18>=X_20 AND X_17>X_20 AND X_19<X_20 AND COUNT(X_19,9)<=1 AND (CLOSE-REF(CLOSE,7))/REF(CLOSE,7)<=0.1;
X_39:=X_17>X_20 AND X_19<X_20 AND X_18<X_20 AND REF(X_17<X_20,1) AND COUNT(X_19,6)=0;
X_40:=X_17>X_18 AND X_18>=X_19 AND X_19>X_20 AND COUNT(X_19,10)<=2 AND (CLOSE-REF(CLOSE,7))/REF(CLOSE,7)<=0.04 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=(-0.05);
X_41:=X_15 AND COUNT(X_29,14)>=1 AND COUNT(X_35,14)>=1;
X_42:=COUNT(X_19,12)<=1 AND (CLOSE-REF(CLOSE,9))/REF(CLOSE,9)<=0.12;
X_43:=COUNT(X_42,6)>=5;
X_44:=X_29 OR X_35 OR X_36 OR X_37 OR X_38 OR X_39 OR X_40 OR X_41 OR X_42 OR X_43;
X_45:=VOL/REF(VOL,1);
X_46:=REF(CLOSE,1)/REF(CLOSE,8);
X_47:=HHV(REF(CLOSE,1),12)/LLV(REF(CLOSE,1),12);
X_48:=COUNT(X_44,20)>=1 AND X_45>=2.7 AND CLOSE>REF(CLOSE,1);
X_49:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)));
X_50:=BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));
X_51:=IF(X_49<X_50,X_49+1,0);
X_52:=MA(CLOSE,5)>MA(CLOSE,20) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,20)>REF(MA(CLOSE,20),1) AND MA(CLOSE,30)>REF(MA(CLOSE,30),1);
X_53:=X_51*X_52;
X_54:=HHV(X_51,5)>=2 AND X_52 AND MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND MA(CLOSE,5)>MA(CLOSE,10);
X_55:=X_54*X_51;
X_56:=X_53>0 AND X_55=0;
X_57:=ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*180/3.14159;
X_58:=X_57>REF(X_57,1) AND REF(X_57,1)<REF(X_57,2);
X_59:=MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND REF(MA(CLOSE,5),1)<REF(MA(CLOSE,5),2);
X_60:=FILTER(X_58 OR X_59 AND CLOSE>MA(CLOSE,5) AND X_54,3);
X_61:=X_55>0 AND REF(X_55,1)=0 AND COUNT(X_44,7)>=1;
X_62:=COUNT(X_25,10)>=1 AND COUNT(X_28,10)>=2 AND COUNT(X_7,10)>=1 AND COUNT(X_48,10)>=1 AND COUNT(X_61,2)>=1 AND CLOSE>OPEN;
X_63:=EMA(CLOSE,4);
X_64:=EMA(SLOPE(CLOSE,20)*10+CLOSE,35);
X_65:=CROSS(X_63,X_64);
X_66:=EMA(CLOSE,3);
X_67:=EMA(CLOSE,21);
X_68:=kdj.J<50;
X_69:=CROSS(kdJ.J,KDJ.D) AND CROSS(KDJ.J,KDJ.K);
X_70:=CROSS(X_63,X_64) AND X_69;
X_71:=CROSS(X_66,X_67) AND X_70;
X_72:=AMOUNT/VOL;
X_73:=LOW<X_72*0.9;
X_74:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
X_75:=LOW<MA(CLOSE,5)*0.921;
X_76:=VOL<MA(VOL,5)*1.5;
X_77:=macd.MacD>0;
X_78:=X_73 AND X_74 AND X_75 AND X_76 AND X_77;
XG:X_78 OR (X_62 AND X_71);

通达信超强潜伏选股指标公式

相关文章