在线检测未来函数

通达信牛股启动背离指标公式

来源:Internet,编辑:股旁网,2022-02-17

{引用周TYP在日线上显示}
高:=HHV(H,5);
低:=LLV(L,5);
周TYP:=(高+低+CLOSE)/3;
日显:((周TYP-ma(周TYP,70))/(0.015*AVEDEV(周TYP,70))/10)+70 LINETHICK2 COLORBROWN;
{引用cci多空}
攻击:=(("CCI.CCI#WEEK")/10)+40 DOTLINE;{周CCI}
力量:=(("CCI.CCI#MONTH")/10)+40 DOTLINE;{月CCI}
{TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=((TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14))/20)+15;
IF(CCI>REF(CCI,1),CCI,DRAWNULL)CIRCLEDOT,LINETHICK1,COLORLIGREEN;}
五日:=REF(C,5);
涨幅:=((C/五日)-1)*100;
五日攻:=((攻击/REF(攻击,1))-1)*100;
五功:IF(攻击<REF(攻击,1)OR 攻击>REF(攻击,1),五日攻,0)NODRAW;
五涨:IF(攻击<REF(攻击,1)OR 攻击>REF(攻击,1),涨幅,0)NODRAW;
涨十:=((C/REF(C,10))-1)*100;
涨二十:=((C/REF(C,20))-1)*100;
十涨:=IF(攻击<REF(攻击,1)OR 攻击>REF(攻击,1),涨十,0)NODRAW;
二十涨:=IF(攻击<REF(攻击,1)OR 攻击>REF(攻击,1),涨二十,0)NODRAW;
十功:=IF(攻击<REF(攻击,1)OR 攻击>REF(攻击,1),((攻击/REF(攻击,6))-1)*100,0)NODRAW;
二十功:=IF(攻击<REF(攻击,1)OR 攻击>REF(攻击,1),((攻击/REF(攻击,16))-1)*100,0)NODRAW;
长能:(二十功-二十涨)+30 COLORGREEN;
中能:(十功-十涨)+30 COLORYELLOW;
短能:(五功-五涨)+30 COLORRED;
日能:日显-REF(日显,1) NODRAW;
IF(攻击>REF(攻击,1) OR 攻击<REF(攻击,1),攻击,DRAWNULL)CIRCLEDOT,LINETHICK2,COLORRED;
IF(力量>REF(力量,1) OR 力量<REF(力量,1),力量,DRAWNULL)CIRCLEDOT,LINETHICK2,COLORYELLOW;
DRAWLINE(攻击>REF(攻击,1) OR 攻击<REF(攻击,1),攻击,攻击>REF(攻击,1) OR 攻击<REF(攻击,1),攻击,2),COLORBLUE;
DRAWLINE(力量>REF(力量,1) OR 力量<REF(力量,1),力量,力量>REF(力量,1) OR 力量<REF(力量,1),力量,1),COLORMAGENTA;

通达信牛股启动背离指标公式

相关文章