在线检测未来函数

通达信竞价量比指标公式

来源:Internet,编辑:股旁网,2022-03-16

M1:=5;
M2:=10;
Vvol:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
stICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,(-1),(-1)),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
maVOL1:MA(VOLUME,M1);
MAVOL2:MA(VOLUME,M2);
X_1:=1*AMOUNT;
X_2:=1*MA(AMOUNT,5);
X_3:=1*MA(AMOUNT,10);
X_4:=HHV(X_1,30)=X_1;
X_5:=HHV(X_1,60)=X_1;
X_6:=HHV(X_1,100)=X_1;
X_7:=HHV(X_1,250)=X_1;
STICKLINE(X_4,VOLUME,VOLUME*0.7,1,0),COLORMAGENTA;
STICKLINE(X_5,VOLUME,VOLUME*0.7,1,0),COLORYELLOW;
STICKLINE(X_6,VOLUME,VOLUME*0.7,1,0),COLORGREEN;
STICKLINE(X_7,VOLUME,VOLUME*0.7,1,0),COLORFF7100;
X_8:=LLV(X_1,30)=X_1;
X_9:=LLV(X_1,60)=X_1;
X_10:=LLV(X_1,100)=X_1;
X_11:=LLV(X_1,250)=X_1;
STICKLINE(X_8,(-50000),0,1,0),COLORMAGENTA;
STICKLINE(X_9,(-50000),0,1,0),COLORYELLOW;
STICKLINE(X_10,(-50000),0,1,0),COLORGREEN;
STICKLINE(X_11,(-50000),0,1,0),COLORFF7100;
IF(crOSS(0.9,1/VOL*1000>0.01 AND kdj.J<0),VOLUME*5,0),COLORYELLOW,LINETHICK2;
PT1:=CONST(LLVBARS(V,5));
STICKLINE(CURRBARSCOUNT=PT1+1,O,V,2.5,0),COLORYELLOW;
{A:FINANCE(7)*0.0003,DOTLINE,COLORWHITE;
DRAWNUMBER(ISLASTBAR,A, 3),COLORYELLOW;}
{倍量}
{STICKLINE(VOLUME>1.8*REF(VOLUME,1) AND C>REF(C,1),O,VOLUME,2,0),COLORRED;}
中间:=VOLUME*0.2;
TT1:=CONST(BArslAST(中间));
STICKLINE(PERIOD=5 AND CURRBARSCOUNT=TT1+2,中间,中间,20,0),COLOR00FF00;
ZG:=VOLUME/1;
TT2:=CONST(BARSLAST(ZG));
STICKLINE(PERIOD=5 AND CURRBARSCOUNT=TT2+2,ZG,ZG,20,0),COLORYELLOW;
市值Z(亿):C*FINANCE(46)/100000000,NODRAW,COLORMAGENTA;
总额(亿):AMOUNT/100000000.0,NODRAW,COLORRED;
换手:SUM(VOL,1)/CAPITAL*100,COLORYELLOW,NODRAW;
Q1:=V/REF(V,1);
{DRAWNUMBER(CURRBARSCOUNT=1,V,Q1);}
竞价金额:DYNAINFO(15)/10000,NODRAW;
价量:DYNAINFO(15)/DYNAINFO(4)/100,NODRAW;
TT3:=CONST(BARSLAST(竞价量));
STICKLINE(PERIOD=5 AND CURRBARSCOUNT=TT3+1,竞价量,竞价量,20,0),COLORMAGENTA;
P:=CONST(BARSLAST(竞价量));
STICKLINE(CURRBARSCOUNT=P+1,O,竞价量,2.5,0),COLORMAGENTA;
OO:=DYNAINFO(15)/DYNAINFO(4)/100;
A:=OO/REF(V,1)*100;
AA:=STRCAT(STRCAT('【竞价量比】: ',CON2STR(A,2)),'%');
DRAWTEXT_FIX(ISLASTBAR,0.5,0,0,AA),COLORLIRED;

通达信竞价量比指标公式

相关文章