在线检测未来函数

通达信开始埋伏主图指标公式

来源:Internet,编辑:股旁网,2022-03-25

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1013”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

DRAWNUMBER(ISLAstBAR ,C,C),COLORmaGENTA;
SJTJ:=DATE<1590301;
AA:=Abs((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,30))/MA(CLOSE,30);
长期趋势线:=DMA((2*CLOSE+LOW+HIGH)/4,AA);
CC:=(CLOSE/长期趋势线);
MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);
MAAA:=((MA1-长期趋势线)/长期趋势线)/3;
TMP:=MA1-MAAA*MA1;
长期趋势上升:IF(TMP>长期趋势线 ,长期趋势线,DRAWNULL),LINETHICK4,COLORRED;
IF(TMP>长期趋势线,长期趋势线,DRAWNULL),COLORYELLOW,POINTDOT,LINETHICK4;
长期趋势下降:IF(TMP<=长期趋势线,长期趋势线,DRAWNULL),LINETHICK4,COLORGREEN;
IF(TMP<=长期趋势线,长期趋势线,DRAWNULL),COLORBLUE,POINTDOT,LINETHICK4;
HZS:=crOSS(TMP,长期趋势线);
LZS:=CROSS(长期趋势线,TMP);
DRAWICON(HZS,长期趋势线-0.1,23);
DRAWICON(LZS,长期趋势线+0.1,24);
{DRAWICON(TMP<=长期趋势线 AND NOT(LZS),长期趋势线-0.1,14)};
{DRAWICON(TMP>长期趋势线 AND NOT(HZS),长期趋势线+0.1,13)};
MAH:=(H*18+REF(H,1)*17+REF(H,2)*16+REF(H,3)*15+REF(H,4)*14+REF(H,5)*13+REF(H,6)*12+REF(H,7)*11+REF(H,8)*10+REF(H,9)*9+REF(H,10)*8+REF(H,11)*7+REF(H,12)*6+REF(H,13)*5+REF(H,14)*4+REF(H,15)*3+REF(H,16)*2+REF(H,17)*1)/171;
MAL:=(L*18+REF(L,1)*17+REF(L,2)*16+REF(L,3)*15+REF(L,4)*14+REF(L,5)*13+REF(L,6)*12+REF(L,7)*11+REF(L,8)*10+REF(L,9)*9+REF(L,10)*8+REF(L,11)*7+REF(L,12)*6+REF(L,13)*5+REF(L,14)*4+REF(L,15)*3+REF(L,16)*2+REF(L,17)*1)/171;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA60:=MA(CLOSE,60);
DK:= SJTJ AND( CLOSE>=MAH OR (C>MA5 AND C>MA10 AND C>MA20 AND C>MA60));
KK:= SJTJ AND( MAL>CLOSE OR (C<MA5 AND C<MA10 AND C<MA20 AND C<MA60));
DK1:=BArslAST(DK);
KK1:=BARSLAST(KK);
DK2:=BARSLAST(CROSS(KK1,DK1));
KK2:=BARSLAST(CROSS(DK1,KK1));
HS:=DK2<KK2;
LS:=KK2<DK2;
W2:=OPEN-CLOSE;
HT:=IF(OPEN>CLOSE,OPEN,CLOSE);
LT:=IF(OPEN<CLOSE,OPEN,CLOSE);
STICKLINE(W2>0 AND HS,OPEN,CLOSE,2,0),COLORRED;
STICKLINE(W2>0 AND HS,OPEN,H,0.0,0),COLORRED;
STICKLINE(W2>0 AND HS,C,L,0.0,0),COLORRED;
STICKLINE(W2<=0 AND HS,OPEN,CLOSE,2,1),COLORRED;
STICKLINE(W2<=0 AND HS,O,L,0.0,0),COLORRED;
STICKLINE(W2<=0 AND HS,C,H,0.0,0),COLORRED;
STICKLINE(W2>0 AND LS,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(W2>0 AND LS,OPEN,H,0.0,0),COLORGREEN;
STICKLINE(W2>0 AND LS,C,L,0.0,0),COLORGREEN;
STICKLINE(W2<=0 AND LS,OPEN,CLOSE,2,1),COLORGREEN;
STICKLINE(W2<=0 AND LS,C,H,0.0,0),COLORGREEN;
STICKLINE(W2<=0 AND LS,O,L,0.0,0),COLORGREEN;
DRAWICON(HS=1 AND REF(LS,1),LOW*0.995,34),COLORYELLOW;
DRAWICON(LS=1 AND REF(HS,1),H*1.005,35),COLORYELLOW;
DRAWNUMBER(ISLASTBAR AND LS,MAH,MAH),COLORYELLOW;
DRAWNUMBER(ISLASTBAR AND HS,MAL,MAL),COLORYELLOW;
趋势线:=(MAH+MAL)/2 COLORGREEN,,LINETHICK2;
中级趋势上升:IF(HS,趋势线,DRAWNULL),LINETHICK2,COLORRED;
中级趋势下降:IF(LS,趋势线,DRAWNULL),LINETHICK2,COLORGREEN;
最新价:IF(SJTJ, C,DRAWNULL),LINETHICK0,COLORYELLOW;
DRAWTEXT_FIX(C>0,0.004,1,0,EXTERNSTR(0,1)),COLORBLUE,LINETHICK2;

M5F:=MA(C,4);
M10F:=MA(C,8),COLORRED,LINETHICK2;
M20F:=MA(C,20);
{M30F:=MA(C,30);}
M60F:=MA(C,60),COLORBLUE,LINETHICK2;
D3:=MIN(MIN(M5F,M10F),M20F)>M60F;
LLM:=LLV("macd.MacD"*100,200);
HHM:=HHV("MACD.MACD"*100,200);
TJA:=C>REF(C,1)*1.05;
T:=BARSLAST(C>REF(C,1)*1.095 AND C=H);
T2L:=BARSLAST(C<REF(C,1)*1.095 AND C>REF(C,1)*1.08);
T3L:=BARSLAST(C<REF(C,1)*1.08 AND C>REF(C,1)*1.07);
T4L:=BARSLAST(C<REF(C,1)*1.07 AND C>REF(C,1)*1.06);
T5L:=BARSLAST(C<REF(C,1)*1.06 AND C>REF(C,1)*1.05);
AAF1:=REF(T,1)>100 AND REF(T2L,1)>100 AND REF(T3L,1)>100 AND REF(T4L,1)>100 AND REF(T5L,1)>80 AND TJA;
XGT:=BARSLAST(AAF1 AND HHM<60 AND LLM>-55);
D6:=BARSSINCEN(MIN(MIN(M5F,M10F),M20F)>M60F,XGT+1);
XGX:=CROSS((XGT=0 AND D3) OR D6=0,0.5);
TJJ:=COUNT(XGX,30)=2 AND XGX;
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=REF(SR2,10+1);
HDF:=REF(SR3,10);
前高:=REF(H,BARSLAST(HDF));
倍量:=vol/REF(VOL,1)>=1.9;
突破前高:=CROSS(C,前高);
YG:= 倍量 AND 突破前高;
低2:=IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL);
SJ:=BARSLAST(YG);
DIF:=MACD.DIF;
H300:=HHVBARS(DIF,300);
AL:=boll.UB;
TQ:=BARSLAST(CROSS(AL>=REF(AL,1),0.5));
E25:=expma(C,25);
ZF:=EVERY(RANGE(C/REF(C,1),0.97,1.05),TQ+1);
ZFF:=(HHV(H,TQ+1)-LLV(L,TQ+1))/LLV(L,TQ+1)*100;
TJQ:=EVERY(MAX(C,O)/AL<1.02 ,TQ+1);
XL:=(ATAN((E25/REF(E25,TQ)-1)*100)*180/3.1415926);
TJ1Q:=CROSS(DIF>=REF(DIF,H300),0.5) AND ZFF<17 AND ZF AND TJQ;
躁动:=TJ1Q AND XL>75;
A1F:=REF(C,1);
AYFF:=REF(C,10);
A31F:=(AYFF-A1F)/A1F*100;
AA1F:=(A31F-REF(A31F,1));
选股1:=CROSS(AAF1,9.8);
A11F:=REF(V,1);
VAR8:=IF(VOL/CAPITAL>0.001,1,EXP(ABS(LOG(VOL/CAPITAL*100))))>2;
A13F:=VAR8/A11F;
AA3F:=(A13F-REF(A13F,1));
选股2:=CROSS(AA3F,500);
潜伏2:=选股1 AND 选股2;
GX:=潜伏2 OR 躁动 OR CURRBARSCOUNT=CONST(SJ)+2 OR TJJ OR (cci<=100 AND L<=低2);
准备:=FILTER(GX=1,3);
A2A:=BARSCOUNT(C);
AH:=HHV(H,200);
A1L:=LLV(L,200);
A0:=(AH-A1L)/190;
B1F:=L-A0;
STICKLINE(准备,B1F,B1F-20*A0,4,0),COLORYELLOW;
DRAWTEXT(准备,H*0.88, '开始埋伏'),COLORRED;

通达信开始埋伏主图指标公式

相关文章