在线检测未来函数

通达信乾坤通道主图指标公式

来源:Internet,编辑:股旁网,2022-04-29

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1005”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

M:=1;
所属地区:DRAWTEXT_FIX(M=1,0,0.05,0,1),COLORCYAN;
DRAWTEXT_FIX(M=1,0.05,0.05,0,DYBLOCK),COLORCYAN;
所属行业:DRAWTEXT_FIX(M=1,0,0.1,0,2),COLORCYAN;
DRAWTEXT_FIX(M=1,0.05,0.1,0,HYBLOCK),COLORCYAN;
所属概念:DRAWTEXT_FIX(M=1,0,0.15,0,3),COLORCYAN;
DRAWTEXT_FIX(M=1,0.05,0.15,0,GNBLOCK),COLORCYAN;
所属风格:DRAWTEXT_FIX(M=1,0,0.2,0,4),COLORCYAN;
DRAWTEXT_FIX(M=1,0.05,0.2,0,FGBLOCK),COLORCYAN;
X_1:=(3*CLOSE+HIGH+LOW+OPEN)/6;
X_2:=(Ema(MEMA(CLOSE,8),8)+EMA(MEMA(CLOSE,13),13)+EMA(MEMA(CLOSE,21),21))/3;
龙马线:WMA(X_1,8),COLORYELLOW,LINETHICK2;
IF(龙马线<=REF(龙马线,1) AND CLOSE<=龙马线,龙马线,DRAWNULL),COLORGREEN,LINETHICK2;
IF(龙马线>=REF(龙马线,1) AND CLOSE>=龙马线,龙马线,DRAWNULL),COLORRED,LINETHICK2;
趋势线:(EMA(MEMA(CLOSE,21),21)+EMA(MEMA(CLOSE,34),34)+EMA(MEMA(CLOSE,55),55))/3,COLOR0080FF,LINETHICK2;
中线:expma((MA(CLOSE,3)+MA(CLOSE,5)+MA(CLOSE,8)+MA(CLOSE,13))/4,34),DOTLINE,COLORYELLOW;
乾线:EXPMA(X_2*1.1,10),COLORMAGENTA;
坤线:EMA(X_2*0.9,10),COLORGREEN;
X_3:=MA(CLOSE,5);
X_4:=MA(CLOSE,10);
X_5:=MA(CLOSE,30);
X_6:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_7:=crOSS(X_6,EMA(X_6,9)) AND EMA(X_6,9)<0;
X_8:=EMA((CLOSE-LLV(LOW,10))/(HHV(HIGH,25)-LLV(LOW,10))*110,10);
X_9:=X_8>REF(X_8,1) AND X_8<20 OR CROSS(X_8,20);
X_10:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
X_11:=SMA(X_10,3,1)>SMA(SMA(X_10,3,1),3,1);
X_12:=MA(vol,5)>MA(VOL,10);
X_13:=(CLOSE-X_3)/X_3*100;
X_14:=(CLOSE-X_5)/X_5*100;
X_15:=ATAN((X_3/REF(X_3,1)-1)*100)*180/3.1416;
X_16:=SMA(EMA((X_3-REF(X_3,1))/REF(X_3,1),3)*100,3,1);
X_17:=EMA(X_16-REF(X_16,1),3);
X_18:=FILTER(COUNT(CROSS(X_15,30),5)>=1 AND X_3>REF(X_3,1) AND X_14>REF(X_14,1) AND X_4>REF(X_4,1) AND X_17>REF(X_17,1) AND X_16>REF(X_16,1),10);
X_19:=COUNT(CROSS(X_13,0),3)>=1 AND X_14>REF(X_14,1) AND X_3>REF(X_3,1) AND (CLOSE/REF(CLOSE,1)-1)*100>5 AND REF(CLOSE,1)<X_5;
DRAWICON(X_7 AND X_9+X_12+X_11>=2 AND (FILTER(X_19,10) OR X_18),LOW,9);
X_20:=EMA((X_1-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100,13);
X_21:=EMA(X_20,3);
X_22:=VOL>=REF(VOL,1)*2 AND CLOSE>=REF(CLOSE,1)*1.045 AND REF(CLOSE,1)<=REF(CLOSE,5)*1.05 AND HHV(REF(HIGH,1),5)/LLV(REF(LOW,1),5)<=1.1 AND CROSS(X_20,X_21);
DRAWICON(X_22,LOW*0.97,25);

通达信乾坤通道主图指标公式

相关文章