在线检测未来函数

通达信买进信号选股指标公式

来源:Internet,编辑:股旁网,2022-05-10

X_1:=Ema(CLOSE,12)-EMA(CLOSE,26);
X_2:=EMA(X_1,9);
X_3:=(X_1-X_2)*2;
X_4:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
X_5:=SMA(X_4,3,1);
X_6:=SMA(X_5,3,1);
X_7:=3*X_5-2*X_6;
X_8:=vol/700000000;
X_9:=1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1);
X_10:=2.5*MAX(X_8,X_9);
X_11:=DMA(CLOSE,X_10);
X_12:=SMA(20*(X_11/REF(X_11,1)-1),2,1);
X_13:=EMA(X_12,2);
X_14:=0.24;
X_15:=CLOSE>=REF(CLOSE,1);
X_16:=IF(X_12>X_14 AND X_13>=0.005 AND X_15,1,0);
X_17:=crOSS(X_16,0.5) AND COUNT(X_16>0.5,10)=1;
X_18:=X_7-REF(X_7,1)>30 AND CLOSE/REF(CLOSE,1)>1.043 AND X_3>0 AND X_2>0;
X_19:=CLOSE/REF(CLOSE,1)>1.048 AND CLOSE=HIGH AND BETWEEN(FORCAst(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
X_20:=FILTER(X_19,28)*100 AND LOW>REF(CLOSE,1)*0.93;
X_21:=X_18 OR X_20 AND X_17;
X_22:=9;
X_23:=10;
X_24:=CLOSE/REF(CLOSE,1)>1+0.01*X_22;
X_25:=EXIST(CLOSE/REF(CLOSE,1)>1+0.01*X_22,X_23);
X_26:=CLOSE/REF(CLOSE,1)>1+0.01*X_22;
X_27:=IF(X_24+X_25+X_26=3,1,0);
X_28:=(HIGH-CLOSE)/(CLOSE-OPEN)<0.33;
X_29:=CLOSE/REF(CLOSE,1)-1>=0.0502 AND CLOSE>REF(CLOSE,1) AND (OPEN-LOW)/(CLOSE-OPEN)>=1.48 AND LOW<REF(LOW,1) AND LOW<REF(LOW,2);
X_30:=CLOSE/REF(CLOSE,1)-1>=0.08;
X_31:=VOL>REF(VOL,1)*1.9 AND CLOSE>REF(CLOSE,1) AND CLOSE/REF(CLOSE,1)-1>=0.049 AND X_28;
X_32:=CLOSE/REF(CLOSE,1)-1>=0.0502 AND CLOSE>REF(CLOSE,1) AND VOL>REF(VOL,1) AND VOL>REF(VOL,1)*2.5 AND X_28;
X_33:=EMA(2.055*EMA(EMA(HIGH,34),34)-EMA(EMA(LOW,34),34),5);
X_34:=IF(FILTER(X_31 OR X_32 OR X_29 OR X_30 AND X_33>CLOSE,34),1,0) AND X_27;
X_35:=X_21 OR X_34;
X_36:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
X_37:=FILTER(X_36,10);
X_38:=BArslAST(X_37);
X_39:=REF(HIGH,X_38+2);
X_40:=REF(HIGH,X_38+1);
X_41:=REF(HIGH,X_38);
X_42:=MAX(X_39,X_40);
X_43:=MAX(X_42,X_41);
X_44:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
X_45:=X_38<150;
X_46:=(OPEN-X_43)/X_43*100<30;
X_47:=(CLOSE-LLV(LOW,X_38))/LLV(LOW,X_38)*100<50;
X_48:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
X_49:=VOL/MA(VOL,5)<3.5;
X_50:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
X_51:=X_44 AND X_45 AND X_46 AND X_47 AND X_48 AND X_49 AND X_50;
X_52:=FILTER(X_51,15);
X_53:=(CLOSE-MA(CLOSE,54))/MA(CLOSE,54)<0.1;
X_54:=(CLOSE-MA(CLOSE,10))/MA(CLOSE,10)<0.3;
X_55:=(X_53=1 AND X_54=1)*0.2;
X_56:=(X_55=0 AND REF(X_55,1)=0.2 AND REF(COUNT(X_55=0.2,10)=10,1)=1)*(-0.1);
X_57:=X_56=(-0.1);
X_58:=X_52 OR X_57;
X_59:=VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
X_60:=X_58 AND CLOSE/REF(CLOSE,1)>1.095 AND X_59;
X_61:=IF(HIGH>CLOSE AND CLOSE>OPEN OR (HIGH>OPEN AND OPEN>=CLOSE),CLOSE,HIGH)+IF(LOW<CLOSE AND CLOSE<OPEN OR (LOW<OPEN AND OPEN<=CLOSE),CLOSE,LOW)/3;
X_62:=EMA((X_61-MA(X_61,84.027))/(0.015*AVEDEV(X_61,84.027)),2.0332);
X_63:=X_62;
X_64:=HHV(MA(X_62,5),21);
X_65:=X_63>X_64;
X_66:=CLOSE*VOL;
X_67:=EMA((EMA(X_66,3)/EMA(VOL,3)+EMA(X_66,6)/EMA(VOL,6)+EMA(X_66,12)/EMA(VOL,12)+EMA(X_66,24)/EMA(VOL,24))/4,13);
X_68:=1.13*X_67;
X_69:=REF(CLOSE,1)*1.1-CLOSE<0.01 AND HIGH=CLOSE;
X_70:=X_65 AND CROSS(CLOSE,X_68) AND X_69;
X_71:=2;
X_72:=CLOSE/REF(CLOSE,1)>=1.0982 AND CLOSE/REF(CLOSE,1)<=1.102 OR CLOSE/REF(CLOSE,1)>=1.1998;
X_73:=COUNT(X_72,X_71)=1 AND X_72;
X_74:=X_35-X_35*0.14 AND X_73;
X_75:=X_35 AND X_60 AND X_70 AND X_74;
X_76:=HIGH=CLOSE;
X_77:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>=0.93 AND X_76;
X_78:=BARSLAST(X_75);
买进信号:X_78 AND X_77 AND X_78<=1;

通达信买进信号选股指标公式

相关文章