在线检测未来函数

通达信洞察主力主图指标公式

来源:Internet,编辑:股旁网,2022-05-11

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1005”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

DRAWGBK(CLOSE>0,RGB(150,50,175),RGB(0,25,100),0,2,0);
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.5,0,0,1),COLORCYAN;
赚钱轨道:(ma(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORRED,LINETHICK2;
X_1:=MA(CLOSE,20);
DRAWBAND(赚钱轨道,RGB(155,50,50),X_1,RGB(0,100,50));
IF(赚钱轨道<X_1 OR CLOSE<赚钱轨道,赚钱轨道,DRAWNULL),COLORBLUE,LINETHICK2;
拉升线:IF(赚钱轨道>X_1,X_1,DRAWNULL),COLORMAGENTA,LINETHICK3;
下跌线:IF(赚钱轨道<=X_1,X_1,DRAWNULL),COLORLIBLUE,LINETHICK2;
X_2:=(CLOSE+HIGH+LOW+OPEN)/4;
X_3:=MA((CLOSE*2+HIGH)/3,5);
X_4:=MA((OPEN*2+HIGH)/3,5);
X_5:=MA((CLOSE+LOW*2)/3,5);
X_6:=MA((OPEN+LOW*2)/3,5);
X_7:=OPEN+(CLOSE-OPEN)/2;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
stICKLINE(dmi.pdi>DMI.mdi,CLOSE,OPEN,2.9,0),COLOR000099;
STICKLINE(DMI.PDI>DMI.MDI,CLOSE,OPEN,1.5,0),COLOR0000CC;
STICKLINE(DMI.PDI>DMI.MDI,CLOSE,OPEN,0.1,0),COLOR9966FF;
STICKLINE(X_3>=X_4,CLOSE,OPEN,2.9,0),COLOR000099;
STICKLINE(X_3>=X_4,CLOSE,OPEN,1.5,0),COLOR0000CC;
STICKLINE(X_3>=X_4,CLOSE,OPEN,0.1,0),COLOR9966FF;
STICKLINE(X_3<X_4 AND DMI.PDI<DMI.MDI,CLOSE,OPEN,2.9,0),COLOR999900;
STICKLINE(X_3<X_4 AND DMI.PDI<DMI.MDI,CLOSE,OPEN,1.5,0),COLORCCCC00;
STICKLINE(X_3<X_4 AND DMI.PDI<DMI.MDI,CLOSE,OPEN,0.1,0),COLORFFFF66;
STICKLINE(X_3>=X_4 AND CLOSE<X_4,X_7,MAX(OPEN,CLOSE),2.8,0),COLORMAGENTA;
STICKLINE(crOSS(X_3,X_4),CLOSE,OPEN,2.8,0),COLORYELLOW;
STICKLINE(X_3<X_4 AND (CROSS(CLOSE,X_6) OR CROSS(X_2,X_6)),X_7,MIN(CLOSE,OPEN),2.8,0),COLORWHITE;
STICKLINE(CROSS(X_4,X_3) AND CLOSE<OPEN AND DMI.PDI<DMI.MDI,CLOSE,OPEN,2.8,0),COLORFF3300;
X_8:=REF(OPEN,1);
X_9:=SMA(MAX(OPEN-X_8,0),6,1)/SMA(Abs(OPEN-X_8),6,1)*100;
X_10:=REF(CLOSE,1);
X_11:=SMA(MAX(CLOSE-X_10,0),6,1)/SMA(ABS(CLOSE-X_10),6,1)*100;
X_12:=REF(HIGH,1);
X_13:=SMA(MAX(HIGH-X_12,0),6,1)/SMA(ABS(HIGH-X_12),6,1)*100;
X_14:=REF(LOW,1);
X_15:=SMA(MAX(LOW-X_14,0),6,1)/SMA(ABS(LOW-X_14),6,1)*100;
X_16:=(MIN(OPEN,CLOSE)-LOW)/LOW*100>vol/CAPITAL*0.001;
X_17:=(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,13))*100;
X_18:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_19:=EMA(X_18,8)*10<(-26);
X_20:=IF(X_16 AND MA(X_17,5)<50 AND X_19,30,0);
X_21:=X_9;
X_22:=X_11;
X_23:=X_13;
X_24:=X_15;
X_25:=MIN(MIN(MIN(X_21,X_22),X_23),X_24);
X_26:=MAX(MAX(MAX(X_21,X_22),X_23),X_24);
DRAWICON(LLV(X_25,5)<=20 OR LLV(X_26,5)<=30 AND CROSS(X_3,X_4),HIGH,9);
X_27:=VOL>REF(VOL,1)*2 AND (CLOSE>=OPEN OR CLOSE>REF(CLOSE,1));
STICKLINE(X_27,CLOSE,OPEN,0.5,0),COLOR0088FF;
DRAWTEXT(CROSS(X_4,X_3) AND CLOSE<赚钱轨道,HIGH,5),COLORCYAN;
X_28:=(CLOSE+LOW+HIGH)/3;
X_29:=ATAN(EMA(X_28,13)-REF(EMA(X_28,13),1))*3.1416*10;
X_30:=EMA(CLOSE,8);
DRAWTEXT(FILTER(X_29>1 AND EMA(X_28,13)>REF(EMA(X_28,8),1),10),X_30,3),COLORWHITE;
X_31:=REF(CLOSE,1);
X_32:=SMA(MAX(CLOSE-X_31,0),3,1)/SMA(ABS(CLOSE-X_31),3,1)*100;
X_33:=EMA(CLOSE,3);
X_34:=EMA(CLOSE,21);
DRAWTEXT(CROSS(X_33,X_34),LOW*0.99,4),COLORA6E500;
DRAWTEXT_FIX(1,0,0,0,GNBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0,0.06,0,FGBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,ZSBLOCK),COLORYELLOW;
X_35:=INDEXADV;
X_36:=INDEXDEC;
X_37:=X_35/(X_35+X_36)*100;
X_38:=IF(X_37>=70,X_37,DRAWNULL);
X_39:=IF(X_37<70,X_37,DRAWNULL);
DRAWTEXT_FIX(1,0,0.18,0,6);
DRAWNUMBER_FIX(1,0.07,0.18,0,CONST(X_38)),COLORYELLOW;
DRAWNUMBER_FIX(1,0.07,0.18,0,CONST(X_39)),COLORGREEN;
DRAWTEXT_FIX(1,0.11,0.18,0,7);
X_40:=HY_INDEXADV;
X_41:=HY_INDEXDEC;
X_42:=X_40/(X_40+X_41)*100;
X_43:=IF(X_42>=70,X_42,DRAWNULL);
X_44:=IF(X_42<70,X_42,DRAWNULL);
DRAWTEXT_FIX(1,0.13,0.18,0,8);
DRAWNUMBER_FIX(1,0.2,0.18,0,CONST(X_43)),COLORYELLOW;
DRAWNUMBER_FIX(1,0.2,0.18,0,CONST(X_44)),COLORGREEN;
DRAWTEXT_FIX(1,0.24,0.18,0,7);
X_45:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X_46:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;
X_47:=FINANCE(23)/FINANCE(10)*3.3;
X_48:=FINANCE(19)/FINANCE(15)*0.6;
X_49:=FINANCE(20)/FINANCE(15)*0.999;
X_50:=X_45+X_46+X_47+X_48+X_49;
DRAWTEXT_FIX(X_50<1.2,0.9,0,0,9),COLORYELLOW;
DRAWTEXT_FIX(BETWEEN(X_50,1.2,2.6),0.9,0,0,10),COLOR0099FF;
DRAWTEXT_FIX(X_50>2.6,0.9,0,0,11),COLORLIBLUE;

通达信洞察主力主图指标公式

相关文章